Re: [PATCH 1/3]: An implementation of HyperV KVP functionality

2010-12-07 Thread Greg KH
On Tue, Dec 07, 2010 at 03:09:52PM -0700, Ky Srinivasan wrote: > This patch is re-based on the latest linux-next tree. > > From: K. Y. Srinivasan > Subject: Reserve a connector index for implementing HyperV Key Value Pair > (KVP) functionality. A hint, this is not how you submit a patch. Please

Re: [PATCH 2/3]: An implementation of HyperV KVP functionality

2010-12-07 Thread Greg KH
On Tue, Dec 07, 2010 at 03:25:56PM -0700, Ky Srinivasan wrote: > This patch is re-based on the latest linux-next tree. > > From: K. Y. Srinivasan > > Subject: The hv_utils module will be composed of more than one file; > rename hv_utils.c to accommodate this without changing the module name. >

Re: [PATCH 2/3]: An implementation of HyperV KVP functionality

2010-12-07 Thread Ky Srinivasan
>>> On 12/7/2010 at 5:29 PM, in message <20101207222933.ga10...@ioremap.net>, Evgeniy Polyakov wrote: > On Tue, Dec 07, 2010 at 03:25:56PM -0700, Ky Srinivasan > (ksriniva...@novell.com) wrote: >> +static void shutdown_onchannelcallback(void *context) >> +{ >> +struct vmbus_channel *chann

Re: [PATCH 3/3]: An implementation of HyperV KVP functionality

2010-12-07 Thread Greg KH
On Tue, Dec 07, 2010 at 03:31:14PM -0700, Ky Srinivasan wrote: > --- /dev/null 1970-01-01 00:00:00.0 + > +++ linux.trees.git/drivers/staging/hv/hv_kvp.c 2010-12-07 > 07:05:39.0 -0500 > @@ -0,0 +1,356 @@ > +/* > + * An implementation of key value pair (KVP) functionality f

[PATCH]: A daemon to support HyperV KVP functionality

2010-12-07 Thread Ky Srinivasan
From: K. Y. Srinivasan Subject: An implementation of key/value pair feature (KVP) for Linux on HyperV. Signed-off-by: K. Y. Srinivasan Index: linux.trees.git/drivers/staging/hv/tools/hv_kvp_daemon.c === --- /dev/null 1970-01-01

Re: [PATCH 2/3]: An implementation of HyperV KVP functionality

2010-12-07 Thread Evgeniy Polyakov
On Tue, Dec 07, 2010 at 03:25:56PM -0700, Ky Srinivasan (ksriniva...@novell.com) wrote: > +static void shutdown_onchannelcallback(void *context) > +{ > + struct vmbus_channel *channel = context; > + u8 *buf; > + u32 buflen, recvlen; > + u64 requestid; > + u8 execute_shutdown =

[PATCH 3/3]: An implementation of HyperV KVP functionality

2010-12-07 Thread Ky Srinivasan
This patch is re-based on the latest linux-next tree. From: K. Y. Srinivasan Subject: An implementation of key/value pair feature (KVP) for Linux on HyperV. Signed-off-by: K. Y. Srinivasan Index: linux.trees.git/drivers/staging/hv/Makefile ===

[PATCH 2/3]: An implementation of HyperV KVP functionality

2010-12-07 Thread Ky Srinivasan
This patch is re-based on the latest linux-next tree. From: K. Y. Srinivasan Subject: The hv_utils module will be composed of more than one file; rename hv_utils.c to accommodate this without changing the module name. Signed-off-by: K. Y. Srinivasan Index: linux.trees.git/drivers/staging/hv/M

[PATCH 1/3]: An implementation of HyperV KVP functionality

2010-12-07 Thread Ky Srinivasan
This patch is re-based on the latest linux-next tree. From: K. Y. Srinivasan Subject: Reserve a connector index for implementing HyperV Key Value Pair (KVP) functionality. Signed-off-by: K. Y. Srinivasan Index: linux.trees.git/include/linux/connector.h =

Re: [PATCH 2/2] tools/virtio: virtio_test tool

2010-12-07 Thread Thiago Farina
On Mon, Nov 29, 2010 at 3:16 PM, Michael S. Tsirkin wrote: > +#define container_of(ptr, type, member) ({                     \ > +       const typeof( ((type *)0)->member ) *__mptr = (ptr);    \ > +       (type *)( (char *)__mptr - offsetof(type,member) );}) > + > +#define uninitialized_var(x) x =