On Sun, Mar 31, 2013 at 10:53 AM, Michael S. Tsirkin wrote:
> On Sat, Mar 30, 2013 at 09:47:58PM +0300, Dmitry Fleytman wrote:
> > Michael, thanks for review,
> > I'll rename command as you suggested, indeed it will be better.
> >
> > Not sure I understand a concept of compat macros.
> > Is there
Paul Bolle writes:
> virtio_balloon.h exports "u16" and "u64" to userspace. Use "__u16" and
> "__u64" instead.
>
> Signed-off-by: Paul Bolle
> ---
> 0) Tested with a kernel build.
>
> 1) Both types are used in this header for quite some time now. So is my
> patch flawed or doesn't userspace actua
On (Sat) 30 Mar 2013 [14:28:28], Rusty Russell wrote:
> Amit Shah writes:
> > When multiple ovq operations are being performed (lots of open/close
> > operations on virtio_console fds), the __send_control_msg() function can
> > get confused without locking.
> >
> > A simple recipe to cause badness
Hello Wenchao,
On Tue, 2013-04-02 at 11:28 +0800, Wenchao Xia wrote:
> Hi, Nicholas
> Have this serial been merged to qemu 1.4?
Not just yet. Asias, MST, Paolo and myself have been working recently
on the series for qemu 1.4.
> If not, I am rebasing it to
> upstream, hope no one else is work
Hi, Nicholas
Have this serial been merged to qemu 1.4? If not, I am rebasing it to
upstream, hope no one else is working on that.
> From: Nicholas Bellinger
>
> Hello Anthony & Co,
>
> This is the fourth installment to add host virtualized target support for
> the mainline tcm_vhost fabric dr
Some head files were split or moved to uapi/ without
updating MAINTAINERS.
Signed-off-by: Amos Kong
---
MAINTAINERS |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index 836a618..a4aae6c 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -8620,6 +862
On Fri, 2013-03-29 at 09:14 +0100, Paolo Bonzini wrote:
> Il 29/03/2013 03:53, Nicholas A. Bellinger ha scritto:
> > On Thu, 2013-03-28 at 06:13 -0400, Paolo Bonzini wrote:
> >>> I think it's the right thing to do, but maybe not the right place
> >>> to do this, need to reset after all IO is done,
From: Nicholas Bellinger
This patch adds virtio_queue_valid() checks in vhost_virtqueue_start()
and vhost_virtqueue_stop() to avoid uninitialized VQs during vhost-scsi-pci
seabios operation, where we currently expect only the request VQ to have
been initialized before virtio-scsi LLD guest hand-o
From: Nicholas Bellinger
This patch adds a number of virtio_queue_valid() checks to virtio-pci
ahead of virtio_queue_get_num() usage in order to skip operation upon
the detection of an uninitialized VQ.
There is one exception in virtio_ioport_read():VIRTIO_PCI_QUEUE_NUM,
where virtio_queue_get_n
From: Michael S. Tsirkin
virtio scsi makes it legal to only setup a subset of rings. The only
way to detect the ring is setup seems to be to check whether PA was
written to. Add API to do this, and teach code to use it instead of
checking hardware queue size.
(nab: use .vring.desc instead of .
From: Nicholas Bellinger
Hi folks,
This series adds a virtio_queue_valid() for use by virtio-pci code in
order to prevent opreations upon uninitialized VQs, which is currently
expected to occur during seabios setup of virtio-scsi with in-flight
vhost-scsi-pci device code.
On the vhost side, it
On Sun, 2013-03-31 at 10:46 +0300, Michael S. Tsirkin wrote:
> On Fri, Mar 29, 2013 at 04:33:09AM +, Nicholas A. Bellinger wrote:
> > From: Nicholas Bellinger
> >
> > Hi folks,
> >
> > This series adds a virtio_queue_valid() for use by virtio-pci code in
> > order to prevent opreations upon
On Sun, 2013-03-31 at 10:45 +0300, Michael S. Tsirkin wrote:
> On Fri, Mar 29, 2013 at 04:33:12AM +, Nicholas A. Bellinger wrote:
> > From: Nicholas Bellinger
> >
> > With the virtio_queue_valid() checks in place to skip uninitialized VQs
> > within virtio-pci code, go ahead and skip the same
On Sun, 2013-03-31 at 10:37 +0300, Michael S. Tsirkin wrote:
> On Fri, Mar 29, 2013 at 04:33:11AM +, Nicholas A. Bellinger wrote:
> > From: Nicholas Bellinger
> >
> > This patch adds a number of virtio_queue_valid() checks to virtio-pci
> > ahead of virtio_queue_get_num() usage in order to sk
"Michael S. Tsirkin" writes:
> Rusty's currently doing some reorgs of -net let's delay
> cleanups there to avoid stepping on each other's toys.
> Let's focus on scsi here.
> E.g. any chance framing assumptions can be fixed in 3.10?
I am waiting for your removal of the dma-compelete ordering stuff
"H. Peter Anvin" writes:
> On 03/27/2013 04:25 AM, Michael S. Tsirkin wrote:
>>
>> Aha. Yes, good idea. As for how large the offsets are,
>> I am guessing we should either just say offset is vqn * X and data is
>> vqn, or give hypervisors full flexibility with 32 bit offset and
>> arbitrary data
Amit Shah writes:
> When multiple ovq operations are being performed (lots of open/close
> operations on virtio_console fds), the __send_control_msg() function can
> get confused without locking.
>
> A simple recipe to cause badness is:
> * create a QEMU VM with two virtio-serial ports
> * in the
virtio_console.h exports "u32" to userspace. Use "__u32" instead.
Signed-off-by: Paul Bolle
---
0) Tested with a kernel build.
1) Again. I'm guessing userspace doesn't use VIRTIO_CONSOLE_BAD_ID.
include/uapi/linux/virtio_console.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --g
virtio_balloon.h exports "u16" and "u64" to userspace. Use "__u16" and
"__u64" instead.
Signed-off-by: Paul Bolle
---
0) Tested with a kernel build.
1) Both types are used in this header for quite some time now. So is my
patch flawed or doesn't userspace actually use virtio_balloon.h?
include/
This short series was triggered by a compile error I ran into when trying to
build the lguest tool (see PATCH 1/8). After fixing that error I decided to
attempt to
solve all related problems.
Paul Bolle (8):
virtio_net: do not export "u16" to userspace
headers_check: add check for kernel inte
20 matches
Mail list logo