Re: [virtio-dev] virtio-vsock live migration

2016-03-19 Thread Stefan Hajnoczi
On Tue, Mar 15, 2016 at 06:12:55PM +0200, Michael S. Tsirkin wrote: > On Tue, Mar 15, 2016 at 03:15:29PM +, Stefan Hajnoczi wrote: > > On Mon, Mar 14, 2016 at 01:13:24PM +0200, Michael S. Tsirkin wrote: > > > On Thu, Mar 03, 2016 at 03:37:37PM +, Stefan Hajnoczi wrote: > > > > Michael

Re: [PATCH] gpu/drm: Use u64_to_user_pointer

2016-03-19 Thread Joe Perches
On Sat, 2016-03-19 at 01:39 +0800, kbuild test robot wrote: > Hi Joe, > > [auto build test WARNING on drm/drm-next] > [also build test WARNING on next-20160318] > [cannot apply to v4.5] > [if your patch is applied to the wrong git tree, please drop us a > note to help improving the system]

Re: [RFC v2 -next 2/2] virtio_net: Read the advised MTU

2016-03-19 Thread Sergei Shtylyov
Hello. On 3/16/2016 12:04 AM, Aaron Conole wrote: This patch checks the feature bit for the VIRTIO_NET_F_MTU feature. If it exists, read the advised MTU and use it. No proper error handling is provided for the case where a user changes the negotiated MTU. A future commit will add proper error

Re: [virtio-dev] virtio-vsock live migration

2016-03-19 Thread Matt Benjamin
Hi, - Original Message - > From: "Stefan Hajnoczi" > To: "Michael S. Tsirkin" > > > > I think the right thing to do is just to teach guests > > > > about 64 bit CIDs. > > > > > > > > For now, can we drop guest CID from guest to host communication

Re: [PATCH v1 11/19] zsmalloc: squeeze freelist into page->mapping

2016-03-19 Thread YiPing Xu
On 2016/3/15 14:51, Minchan Kim wrote: On Tue, Mar 15, 2016 at 03:40:53PM +0900, Sergey Senozhatsky wrote: On (03/11/16 16:30), Minchan Kim wrote: -static void *location_to_obj(struct page *page, unsigned long obj_idx) +static void objidx_to_page_and_ofs(struct size_class *class, +

Re: [PATCH v1 09/19] zsmalloc: keep max_object in size_class

2016-03-19 Thread Sergey Senozhatsky
On (03/11/16 16:30), Minchan Kim wrote: > Every zspage in a size_class has same number of max objects so > we could move it to a size_class. > > Signed-off-by: Minchan Kim > --- > mm/zsmalloc.c | 29 ++--- > 1 file changed, 14 insertions(+), 15

CfP 11th Workshop on Virtualization in High-Performance Cloud Computing (VHPC '16)

2016-03-19 Thread VHPC 16
CALL FOR PAPERS 11th Workshop on Virtualization in High­-Performance Cloud Computing (VHPC '16) held in conjunction with the International Supercomputing Conference - High Performance, June 19-23, 2016, Frankfurt, Germany.

Re: [PATCH v1 05/19] zsmalloc: use first_page rather than page

2016-03-19 Thread Sergey Senozhatsky
On (03/11/16 16:30), Minchan Kim wrote: > This patch cleans up function parameter "struct page". > Many functions of zsmalloc expects that page paramter is "first_page" > so use "first_page" rather than "page" for code readability. > > Signed-off-by: Minchan Kim Reviewed-by:

Re: [PATCH net-next] virtio_net: replace netdev_alloc_skb_ip_align() with napi_alloc_skb()

2016-03-19 Thread Paolo Abeni
On Thu, 2016-03-17 at 18:01 -0700, Venkatesh Srinivas wrote: > On Thu, Mar 17, 2016 at 7:44 AM, Paolo Abeni wrote: > > > > This gives small but noticeable rx performance improvement (2-3%) > > and will allow exploiting future napi improvement. > > > > Signed-off-by: Paolo Abeni

Re: [PATCH v1 07/19] zsmalloc: reordering function parameter

2016-03-19 Thread Sergey Senozhatsky
On (03/11/16 16:30), Minchan Kim wrote: > This patch cleans up function parameter ordering to order > higher data structure first. > > Signed-off-by: Minchan Kim Reviewed-by: Sergey Senozhatsky -ss

Re: [RFC v2 -next 2/2] virtio_net: Read the advised MTU

2016-03-19 Thread Michael S. Tsirkin
On Tue, Mar 15, 2016 at 05:04:13PM -0400, Aaron Conole wrote: > This patch checks the feature bit for the VIRTIO_NET_F_MTU feature. If it > exists, read the advised MTU and use it. > > No proper error handling is provided for the case where a user changes the > negotiated MTU. A future commit

Re: [PATCH v1 08/19] zsmalloc: remove unused pool param in obj_free

2016-03-19 Thread Sergey Senozhatsky
On (03/11/16 16:30), Minchan Kim wrote: > Let's remove unused pool param in obj_free > > Signed-off-by: Minchan Kim Reviewed-by: Sergey Senozhatsky -ss ___ Virtualization mailing list

Re: [PATCH v1 06/19] zsmalloc: clean up many BUG_ON

2016-03-19 Thread Sergey Senozhatsky
On (03/11/16 16:30), Minchan Kim wrote: > There are many BUG_ON in zsmalloc.c which is not recommened so > change them as alternatives. > > Normal rule is as follows: > > 1. avoid BUG_ON if possible. Instead, use VM_BUG_ON or VM_BUG_ON_PAGE > 2. use VM_BUG_ON_PAGE if we need to see struct page's

[net-next v2] virtio_net: replace netdev_alloc_skb_ip_align() with napi_alloc_skb()

2016-03-19 Thread Paolo Abeni
This gives small but noticeable rx performance improvement (2-3%) and will allow exploiting future napi improvement. Signed-off-by: Paolo Abeni -- v2: replace also netdev_alloc_skb_ip_align() invocation in add_recvbuf_small(), suggested by Venkatesh Srinivas ---

Re: [RFC v2 -next 0/2] virtio-net: Advised MTU feature

2016-03-19 Thread Aaron Conole
Pankaj Gupta writes: >> >> The following series adds the ability for a hypervisor to set an MTU on the >> guest during feature negotiation phase. This is useful for VM orchestration >> when, for instance, tunneling is involved and the MTU of the various systems >> should be

Re: [RFC v2 -next 1/2] virtio: Start feature MTU support

2016-03-19 Thread Michael S. Tsirkin
On Wed, Mar 16, 2016 at 11:23:14AM -0700, Stephen Hemminger wrote: > On Tue, 15 Mar 2016 17:04:12 -0400 > Aaron Conole wrote: > > > --- a/include/uapi/linux/virtio_net.h > > +++ b/include/uapi/linux/virtio_net.h > > @@ -55,6 +55,7 @@ > > #define VIRTIO_NET_F_MQ22 /*

Re: [PATCH v1 19/19] zram: use __GFP_MOVABLE for memory allocation

2016-03-19 Thread Sergey Senozhatsky
On (03/11/16 16:30), Minchan Kim wrote: [..] > init > Node 0, zone DMA208120 51 41 11 0 0 0 > 0 0 0 > Node 0, zoneDMA32 16380 13777 9184 3805789 54 3 0 > 0 0 0 > compaction > Node 0, zone DMA

[PATCH net-next] virtio_net: replace netdev_alloc_skb_ip_align() with napi_alloc_skb()

2016-03-19 Thread Paolo Abeni
This gives small but noticeable rx performance improvement (2-3%) and will allow exploiting future napi improvement. Signed-off-by: Paolo Abeni --- drivers/net/virtio_net.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/virtio_net.c

Re: [PATCH net-next] virtio_net: replace netdev_alloc_skb_ip_align() with napi_alloc_skb()

2016-03-19 Thread Venkatesh Srinivas via Virtualization
On Thu, Mar 17, 2016 at 7:44 AM, Paolo Abeni wrote: > This gives small but noticeable rx performance improvement (2-3%) > and will allow exploiting future napi improvement. > > Signed-off-by: Paolo Abeni > Worked in my tests, though the performance win was

Re: [RFC v2 -next 1/2] virtio: Start feature MTU support

2016-03-19 Thread Stephen Hemminger
On Thu, 17 Mar 2016 17:10:55 -0400 Aaron Conole wrote: > Stephen Hemminger writes: > > > On Tue, 15 Mar 2016 17:04:12 -0400 > > Aaron Conole wrote: > > > >> --- a/include/uapi/linux/virtio_net.h > >> +++

Re: [PATCH v1 09/19] zsmalloc: keep max_object in size_class

2016-03-19 Thread xuyiping
On 2016/3/11 15:30, Minchan Kim wrote: Every zspage in a size_class has same number of max objects so we could move it to a size_class. Signed-off-by: Minchan Kim --- mm/zsmalloc.c | 29 ++--- 1 file changed, 14 insertions(+), 15 deletions(-)

Re: [PATCH net-next] virtio_net: replace netdev_alloc_skb_ip_align() with napi_alloc_skb()

2016-03-19 Thread Venkatesh Srinivas via Virtualization
On Thu, Mar 17, 2016 at 7:44 AM, Paolo Abeni wrote: > > This gives small but noticeable rx performance improvement (2-3%) > and will allow exploiting future napi improvement. > > Signed-off-by: Paolo Abeni > --- Worked in my tests, though the performance

Re: [RFC v2 -next 0/2] virtio-net: Advised MTU feature

2016-03-19 Thread Aaron Conole
Rick Jones writes: > On 03/15/2016 02:04 PM, Aaron Conole wrote: >> The following series adds the ability for a hypervisor to set an MTU on the >> guest during feature negotiation phase. This is useful for VM orchestration >> when, for instance, tunneling is involved and the

Re: [PATCH v1 13/19] zsmalloc: factor page chain functionality out

2016-03-19 Thread xuyiping
On 2016/3/11 15:30, Minchan Kim wrote: For migration, we need to create sub-page chain of zspage dynamically so this patch factors it out from alloc_zspage. As a minor refactoring, it makes OBJ_ALLOCATED_TAG assign more clear in obj_malloc(it could be another patch but it's trivial so I want

[PATCH] gpu/drm: Use u64_to_user_pointer

2016-03-19 Thread Joe Perches
Use the newly added u64_to_user_pointer a bit more frequently. Signed-off-by: Joe Perches --- drivers/gpu/drm/armada/armada_gem.c| 2 +- drivers/gpu/drm/nouveau/nouveau_gem.c | 7 --- drivers/gpu/drm/tegra/drm.c| 15 ---

Re: [RFC v2 -next 1/2] virtio: Start feature MTU support

2016-03-19 Thread Aaron Conole
Stephen Hemminger writes: > On Tue, 15 Mar 2016 17:04:12 -0400 > Aaron Conole wrote: > >> --- a/include/uapi/linux/virtio_net.h >> +++ b/include/uapi/linux/virtio_net.h >> @@ -55,6 +55,7 @@ >> #define VIRTIO_NET_F_MQ 22 /* Device

Re: [PATCH v1 03/19] fs/anon_inodes: new interface to create new inode

2016-03-19 Thread Gioh Kim
On 11.03.2016 09:05, Al Viro wrote: On Fri, Mar 11, 2016 at 04:30:07PM +0900, Minchan Kim wrote: From: Gioh Kim The anon_inodes has already complete interfaces to create manage many anonymous inodes but don't have interface to get new inode. Other sub-modules can create

Re: [RFC v2 -next 2/2] virtio_net: Read the advised MTU

2016-03-19 Thread Aaron Conole
"Michael S. Tsirkin" writes: > On Tue, Mar 15, 2016 at 05:04:13PM -0400, Aaron Conole wrote: >> This patch checks the feature bit for the VIRTIO_NET_F_MTU feature. If it >> exists, read the advised MTU and use it. >> >> No proper error handling is provided for the case where a

Re: [PATCH v1 11/19] zsmalloc: squeeze freelist into page->mapping

2016-03-19 Thread Minchan Kim
On Thu, Mar 17, 2016 at 08:09:50PM +0800, YiPing Xu wrote: > > > On 2016/3/15 14:51, Minchan Kim wrote: > >On Tue, Mar 15, 2016 at 03:40:53PM +0900, Sergey Senozhatsky wrote: > >>On (03/11/16 16:30), Minchan Kim wrote: > >>>-static void *location_to_obj(struct page *page, unsigned long obj_idx)

Re: [RFC v2 -next 2/2] virtio_net: Read the advised MTU

2016-03-19 Thread Aaron Conole
Sergei Shtylyov writes: > Hello. > > On 3/16/2016 12:04 AM, Aaron Conole wrote: > >> This patch checks the feature bit for the VIRTIO_NET_F_MTU feature. If it >> exists, read the advised MTU and use it. >> >> No proper error handling is provided for the case

Re: [PATCH] gpu/drm: Use u64_to_user_pointer

2016-03-19 Thread kbuild test robot
-u64_to_user_pointer/20160319-012749 base: git://people.freedesktop.org/~airlied/linux.git drm-next config: m68k-allmodconfig (attached as .config) reproduce: wget https://git.kernel.org/cgit/linux/kernel/git/wfg/lkp-tests.git/plain/sbin/make.cross -O ~/bin/make.cross chmod +x ~/bin