Re: [PATCH 28/31] vdpa: Expose VHOST_F_LOG_ALL on SVQ

2022-02-23 Thread Jason Wang
On Wed, Feb 23, 2022 at 4:06 PM Eugenio Perez Martin wrote: > > On Wed, Feb 23, 2022 at 4:47 AM Jason Wang wrote: > > > > On Tue, Feb 22, 2022 at 4:06 PM Eugenio Perez Martin > > wrote: > > > > > > On Tue, Feb 22, 2022 at 8:41 AM Jason Wang wrote: > > > > > > > > > > > > 在 2022/2/17 下午4:22,

Re: [RFC PATCH 1/5] uapi/linux/if_tun.h: Added new ioctl for tun/tap.

2022-02-23 Thread Jason Wang
On Wed, Feb 23, 2022 at 9:31 PM Yuri Benditovich wrote: > > Hi Jason, > We agree that the same can be done also using the old way, i.e. try to > set specific offload - if failed, probably it is not supported. > We think this is a little not scalable and we suggest adding the ioctl > that will

Re: [PATCH v2 01/11] driver: platform: add and use helper for safer setting of driver_override

2022-02-23 Thread Bjorn Helgaas
On Wed, Feb 23, 2022 at 08:13:00PM +0100, Krzysztof Kozlowski wrote: > Several core drivers and buses expect that driver_override is a > dynamically allocated memory thus later they can kfree() it. > ... > + * set_driver_override() - Helper to set or clear driver override. Doesn't match actual

Re: [PATCH v2 05/11] pci: use helper for safer setting of driver_override

2022-02-23 Thread Bjorn Helgaas
In subject, to match drivers/pci/ convention, do something like: PCI: Use driver_set_override() instead of open-coding On Wed, Feb 23, 2022 at 08:13:04PM +0100, Krzysztof Kozlowski wrote: > Use a helper for seting driver_override to reduce amount of duplicated > code. s/seting/setting/ >

Re: [PATCH v2 01/11] driver: platform: add and use helper for safer setting of driver_override

2022-02-23 Thread Michael S. Tsirkin
On Wed, Feb 23, 2022 at 08:13:00PM +0100, Krzysztof Kozlowski wrote: > Several core drivers and buses expect that driver_override is a > dynamically allocated memory thus later they can kfree() it. > > However such assumption is not documented, there were in the past and > there are already users

Re: [PATCH v2 07/11] spi: use helper for safer setting of driver_override

2022-02-23 Thread Mark Brown
On Wed, Feb 23, 2022 at 08:14:37PM +0100, Krzysztof Kozlowski wrote: > Remove also "const" from the definition of spi_device.driver_override, > because it is not correct. The SPI driver already treats it as > dynamic, not const, memory. We don't modify the string do we, we just allocate a new

Re: [PATCH] vhost: validate range size before adding to iotlb

2022-02-23 Thread Michael S. Tsirkin
On Wed, Feb 23, 2022 at 10:19:23PM +0530, Anirudh Rayabharam wrote: > On Wed, Feb 23, 2022 at 10:15:01AM -0500, Michael S. Tsirkin wrote: > > On Wed, Feb 23, 2022 at 07:48:18PM +0530, Anirudh Rayabharam wrote: > > > On Tue, Feb 22, 2022 at 06:21:50PM -0500, Michael S. Tsirkin wrote: > > > > On

Re: [PATCH] vhost: validate range size before adding to iotlb

2022-02-23 Thread Michael S. Tsirkin
On Wed, Feb 23, 2022 at 07:48:18PM +0530, Anirudh Rayabharam wrote: > On Tue, Feb 22, 2022 at 06:21:50PM -0500, Michael S. Tsirkin wrote: > > On Tue, Feb 22, 2022 at 10:57:41PM +0530, Anirudh Rayabharam wrote: > > > On Tue, Feb 22, 2022 at 10:02:29AM -0500, Michael S. Tsirkin wrote: > > > > On

Re: [RFC PATCH 1/5] uapi/linux/if_tun.h: Added new ioctl for tun/tap.

2022-02-23 Thread Yuri Benditovich
Hi Jason, We agree that the same can be done also using the old way, i.e. try to set specific offload - if failed, probably it is not supported. We think this is a little not scalable and we suggest adding the ioctl that will allow us to query allo the supported features in a single call. We think

Re: [PATCH v2 3/3] virtio-crypto: implement RSA algorithm

2022-02-23 Thread zhenwei pi
On 2/18/22 11:12 AM, zhenwei pi wrote: +void virtio_crypto_akcipher_algs_unregister(struct virtio_crypto +*vcrypto) { +    int i = 0; + +    mutex_lock(_lock); + +    for (i = 0; i < ARRAY_SIZE(virtio_crypto_akcipher_algs); i++) { +    uint32_t service =

Re: [PATCH v1 3/6] virtio: remove flags check for unmap packed indirect desc

2022-02-23 Thread Xuan Zhuo
On Wed, 23 Feb 2022 10:53:26 +0800, Jason Wang wrote: > > 在 2022/2/10 下午4:51, Xuan Zhuo 写道: > > When calling vring_unmap_desc_packed(), it will not encounter the > > situation that the flags contains VRING_DESC_F_INDIRECT. So remove this > > logic. > > > This seems not correct. > > There's a call