Re: [Warzone-dev] Gathering statistics?

2008-05-09 Thread Dennis Schridde
Am Freitag, 9. Mai 2008 07:06:37 schrieb bugs buggy: I rather *not* use the ingame GUI to make a dialog for obvious reasons. (Mainly, it is a PITA to work with the GUI.) I also am not sure why you guys think this is any different that any other program you use that transmits information about

Re: [Warzone-dev] Gathering statistics?

2008-05-09 Thread Per Inge Mathisen
On Fri, May 9, 2008 at 10:00 AM, Dennis Schridde [EMAIL PROTECTED] wrote: http://www.mozilla.com/en-US/legal/eula/firefox2-en.txt As a digression, I would note that few Linux users ever see or can click 'yes' to this EULA, since Firefox is installed quietly by system tools that do not allow EULA

Re: [Warzone-dev] New GUI Update

2008-05-09 Thread Dennis Schridde
Just something I experimented with: #define CALL(OBJECT, METHOD) ((OBJECT)-vtable-METHOD) CALL(xob, xme)(p1, p2); signature.asc Description: This is a digitally signed message part. ___ Warzone-dev mailing list Warzone-dev@gna.org

Re: [Warzone-dev] New GUI Update

2008-05-09 Thread Dennis Schridde
widget.h: int32_t userData; That is the size of the userData blob? Why does it need to be exactly 32bit long? Maybe size_t would be a good type? And userDataSize a better name? --Dennis signature.asc Description: This is a digitally signed message part.

Re: [Warzone-dev] New GUI Update

2008-05-09 Thread Freddie Witherden
Hi, On Fri, 9 May 2008 12:05:47 +0200, Dennis Schridde [EMAIL PROTECTED] wrote: widget.h: int32_t userData; I made it a fixed size so that people would not be tempted to store pointers in it (we have pUserData for that). Knowing it is a fix size may also allow it to be used for storing

Re: [Warzone-dev] New GUI Update

2008-05-09 Thread Freddie Witherden
Hi, On Fri, 9 May 2008 10:38:54 +0200, Dennis Schridde [EMAIL PROTECTED] wrote: Just something I experimented with: #define CALL(OBJECT, METHOD) ((OBJECT)-vtable-METHOD) CALL(xob, xme)(p1, p2); Currently the way virtual methods (i.e., those which use the vtable) are called is exactly the

Re: [Warzone-dev] New GUI Update

2008-05-09 Thread Dennis Schridde
Hello! :) size_t would be fine, also. Just so long as people will not store pointers in it I am happy. So it is not intended to carry the size of pUserData, but it is an independed storage place? To avoid stuff like: pUserData = malloc(sizeof(float)) ? I probably would have done pUserData =

Re: [Warzone-dev] New GUI Update

2008-05-09 Thread Dennis Schridde
Am Freitag, 9. Mai 2008 12:17:43 schrieb Freddie Witherden: On Fri, 9 May 2008 10:38:54 +0200, Dennis Schridde [EMAIL PROTECTED] wrote: Just something I experimented with: #define CALL(OBJECT, METHOD) ((OBJECT)-vtable-METHOD) CALL(xob, xme)(p1, p2); Currently the way virtual methods

Re: [Warzone-dev] New GUI Update

2008-05-09 Thread Freddie Witherden
Hi, On 9 May 2008, at 12:28, Dennis Schridde wrote: Am Freitag, 9. Mai 2008 12:17:43 schrieb Freddie Witherden: On Fri, 9 May 2008 10:38:54 +0200, Dennis Schridde [EMAIL PROTECTED] wrote: Just something I experimented with: #define CALL(OBJECT, METHOD) ((OBJECT)-vtable-METHOD) CALL(xob,