[PATCH libinput 4/6] test: move semi-mt special tracking into the shared litest.c

2014-12-15 Thread Peter Hutterer
An upcoming synaptics semi-mt device needs the same code. Signed-off-by: Peter Hutterer --- test/litest-alps-semi-mt.c | 146 +++-- test/litest.c | 141 +++ test/litest.h | 27 + 3

[PATCH libinput 5/6] test: add a semi-mt + hover synaptics touchpad

2014-12-15 Thread Peter Hutterer
This device sends touch information before BTN_TOUCH https://bugs.freedesktop.org/show_bug.cgi?id=87197 Signed-off-by: Peter Hutterer --- test/Makefile.am | 1 + test/litest-synaptics-hover.c | 132 ++ test/litest.c | 2 +

[PATCH libinput 3/6] touchpad: add a TOUCH_HOVERING state

2014-12-15 Thread Peter Hutterer
Some touchpads provide touch information while the finger hovers over the touchpad, i.e. before BTN_TOUCH. Add a touch state for those touchpads so we can ignore the touches until they actually start. The approach is now: instead of BEGIN we mark a new touch as HOVERING. Use the BTN_TOOL_FINGER, B

[PATCH libinput 2/6] touchpad: use __builtin_ffs instead of a manual count

2014-12-15 Thread Peter Hutterer
BTN_TOOL_FINGER, DOUBLETAP, etc. are mutually exclusive in the kernel, so we can use ffs here instead of manually counting. Signed-off-by: Peter Hutterer --- src/evdev-mt-touchpad.c | 11 +-- 1 file changed, 1 insertion(+), 10 deletions(-) diff --git a/src/evdev-mt-touchpad.c b/src/evde

[PATCH libinput 1/6] touchpad: factor out fake finger handling

2014-12-15 Thread Peter Hutterer
We need this for determining hovering touches on some semi-mt touchpads. This makes the fake_touches mask use bit 1 for BTN_TOUCH, and the other bits for BTN_TOOL_FINGER, BTN_TOOL_DOUBLETAP, etc. BTN_TOUCH is independent of the rest, the others are mutually exclusive in the kernel. Since the mask

[PATCH libinput 6/6] test: add touchpad hover finger test

2014-12-15 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- test/touchpad.c | 322 +++- 1 file changed, 321 insertions(+), 1 deletion(-) diff --git a/test/touchpad.c b/test/touchpad.c index 934674c..9890566 100644 --- a/test/touchpad.c +++ b/test/touchpad.c @@ -2060,9 +

Re: [PATCH 1/3] touchpad: Add a tp_post_pointer_motion helper function

2014-12-15 Thread Peter Hutterer
On Tue, Dec 09, 2014 at 12:47:09PM +0100, Hans de Goede wrote: > Split out the pointer-motion handling into a helper function. > > Signed-off-by: Hans de Goede Reviewed-by: Peter Hutterer Cheers, Peter > --- > src/evdev-mt-touchpad.c | 46 ++ >

Re: [PATCH 3/3] touchpad: Use TOUCHPAD_MIN_SAMPLES in tp_get_delta

2014-12-15 Thread Peter Hutterer
On Fri, Dec 12, 2014 at 01:15:49PM +0100, Hans de Goede wrote: > Hi, > > On 10-12-14 04:34, Peter Hutterer wrote: > >On Tue, Dec 09, 2014 at 12:47:11PM +0100, Hans de Goede wrote: > >>Use TOUCHPAD_MIN_SAMPLES in tp_get_delta rather then hardcoding "4". > > > >s/then/than/ > > > >>Also remove the s

Re: [PATCH weston v2 6/7] text: Don't crash if a seat has no keyboard

2014-12-15 Thread Jan Arne Petersen
Hey, On Mon Dec 08 2014 at 5:57:04 PM Derek Foreman wrote: > A keyboard might not be present in a seat, so check that before > dereferencing keyboard related pointers. > > Also, use the keyboard pointer we set to shorten the code a little bit. > > Signed-off-by: Derek Foreman > --- > Made the c

Re: [PATCH weston 5/6] xdg-shell: Rewrite documentation

2014-12-15 Thread Jasper St. Pierre
Some framework-y applications have multiple apps in one process, like LibreOffice. There's also the Chrome / Firefox "web apps" system where you can launch Chrome / Firefox with a URL as if the web apps were native native. Perhaps they should create a new xdg_shell for every app they create? I don

Re: Feedback on xdg-shell from Plasma crew

2014-12-15 Thread Jasper St. Pierre
On Mon, Dec 15, 2014 at 5:30 AM, Martin Gräßlin wrote: > > Hi all, > > I had a look at the xdg-shell proposal in weston (see [1]) and want to > provide > some feedback from a Plasma/KWin point of view. > > First of all: thanks for the work so far on the xdg-shell. The work looks > quite good and p

Re: [PATCH weston 1/7] editor: Make editor multi-seat aware

2014-12-15 Thread Jan Arne Petersen
On Fri Dec 05 2014 at 10:47:03 PM Derek Foreman wrote: > With multi-seat, multiple entries can occur on the text inputs in the > editor. Also, the panel shouldn't be hidden by the editor if either > text entry is still active. > > Signed-off-by: Derek Foreman > --- > clients/editor.c | 12

Re: Feedback on xdg-shell from Plasma crew

2014-12-15 Thread Jason Ekstrand
Hi Martin! First off, thanks for looking at it and giving your thoughs. I'm going to reply to a few things below from a sort-of "general wayland perspective" I'll leave the hashing out of details to the people who actually work on real compositors. Hopefully, the rest of the list shows similar re

Re: [PATCH weston 0/7] text-input fix-ups

2014-12-15 Thread Pekka Paalanen
On Mon, 15 Dec 2014 17:34:31 +0200 Pekka Paalanen wrote: > On Fri, 5 Dec 2014 15:38:34 -0600 > Derek Foreman wrote: > > > Currently running weston-editor on a multi-seat configuration crashes > > weston. > > This is an attempt to clean up the crashes and fix up the input panel > > handling >

Re: [PATCH weston] input: swallow the key press event when running a compositor key binding

2014-12-15 Thread Pekka Paalanen
On Fri, 5 Dec 2014 18:02:58 +0200 Giulio Camuffo wrote: > --- > src/bindings.c | 5 - > 1 file changed, 4 insertions(+), 1 deletion(-) > > diff --git a/src/bindings.c b/src/bindings.c > index 5cb031a..8d4c133 100644 > --- a/src/bindings.c > +++ b/src/bindings.c > @@ -202,6 +202,9 @@ bindin

Re: [PATCH weston 0/7] text-input fix-ups

2014-12-15 Thread Pekka Paalanen
On Fri, 5 Dec 2014 15:38:34 -0600 Derek Foreman wrote: > Currently running weston-editor on a multi-seat configuration crashes weston. > This is an attempt to clean up the crashes and fix up the input panel handling > a little for multi-seat, with a few minor clean-ups along the way. > > Derek

Re: [PATCH 2/2] ivi-shell: rewrite controller API

2014-12-15 Thread Pekka Paalanen
On Mon, 15 Dec 2014 13:25:39 +0900 Nobuhiko Tanibata wrote: > This fixes the breakage caused by "ivi-shell: make ivi-layout.c as a > part of ivi-shell.so" > > hmi-controller.c: > A reference implementation of controller module does not use the layout > functions directly. This get function point

Re: [PATCH] ivi-shell: clean-up transition animation code.

2014-12-15 Thread Pekka Paalanen
On Mon, 15 Dec 2014 13:18:46 +0900 Nobuhiko Tanibata wrote: > ivi_layout_transition_layer_render_order is not necesary called. Remove > the method and methods called by it. > > Signed-off-by: Nobuhiko Tanibata > --- > ivi-shell/hmi-controller.c| 5 - > ivi-shell/ivi-layout-transition

Re: [PATCH] ivi-shell: clean up unnecesary header

2014-12-15 Thread Pekka Paalanen
On Mon, 15 Dec 2014 13:20:14 +0900 Nobuhiko Tanibata wrote: > Signed-off-by: Nobuhiko Tanibata > --- > ivi-shell/ivi-layout.c | 5 - > ivi-shell/ivi-shell.c | 5 - > 2 files changed, 10 deletions(-) Pushed, thanks, pq ___ wayland-devel maili

Re: [PATCH] ivi-shell: reordering method in ivi_layout.c

2014-12-15 Thread Pekka Paalanen
On Mon, 15 Dec 2014 13:20:44 +0900 Nobuhiko Tanibata wrote: > In the future, re-alignmenet of WL_EXPORT per method should be done. > For that work, re-ordering is required to be used by another method. > > Signed-off-by: Nobuhiko Tanibata > --- > ivi-shell/ivi-layout.c | 171 > +++

Re: [PATCH] ivi-shell: several ivi-layout interfaces moved accross source.

2014-12-15 Thread Pekka Paalanen
On Mon, 15 Dec 2014 13:20:58 +0900 Nobuhiko Tanibata wrote: > Interfaces for properties setting shall be implemented in ivi-layout. > > Signed-off-by: Nobuhiko Tanibata > --- > ivi-shell/ivi-layout-transition.c | 66 -- > ivi-shell/ivi-layout.c|

Re: [PATCH v2 2/2] ivi-shell: Say something when configuration is missing

2014-12-15 Thread Pekka Paalanen
On Sat, 6 Dec 2014 02:49:18 +0100 Ondřej Majerech wrote: > When ivi-module is not set in weston.conf, we probably want to tell the > user about their error instead of just dying. > > Signed-off-by: Ondřej Majerech > --- > ivi-shell/ivi-shell.c | 1 + > 1 file changed, 1 insertion(+) > > diff

Re: [PATCH v2 1/2] compositor: Propagate errors from module_init

2014-12-15 Thread Pekka Paalanen
On Tue, 09 Dec 2014 10:19:22 -0600 Derek Foreman wrote: > On 05/12/14 07:49 PM, Ondřej Majerech wrote: > > load_modules currently ignores errors signalled by both > > weston_load_module and module_init, and instead always returns 0. Its > > return value appears to be checked in callers, so we mos

Feedback on xdg-shell from Plasma crew

2014-12-15 Thread Martin Gräßlin
Hi all, I had a look at the xdg-shell proposal in weston (see [1]) and want to provide some feedback from a Plasma/KWin point of view. First of all: thanks for the work so far on the xdg-shell. The work looks quite good and promising. If you reply to the thread, please keep both the plasma and

Re: [PATCH] Fix bug https://bugs.freedesktop.org/show_bug.cgi?id=86889 by emitting session signals on TTY switches so that the weston backends can handle VT switching when not called from weston-launc

2014-12-15 Thread David Herrmann
Hi On Mon, Dec 15, 2014 at 11:04 AM, Pekka Paalanen wrote: > On Sun, 07 Dec 2014 10:15:29 -0500 > nerdopolis wrote: > >> --- >> src/logind-util.c | 6 ++ >> 1 file changed, 6 insertions(+) >> >> diff --git a/src/logind-util.c b/src/logind-util.c >> index 6a1b498..4308bb6 100644 >> --- a/src

[PATCH wayland v2 2/2] scanner: Fix header generation for server protocols

2014-12-15 Thread Mariusz Ceier
Server protocols headers should include wayland-server.h, instead of wayland-util.h. Otherwise they're not useable with C++ compiler unless wayland-server.h was included earlier. Signed-off-by: Mariusz Ceier --- Notes: v2: s/generatation/generation/ src/scanner.c | 2 +- 1 file changed, 1

[PATCH wayland 2/2] scanner: Fix header generatation for server protocols

2014-12-15 Thread Mariusz Ceier
Server protocols headers should include wayland-server.h, instead of wayland-util.h. Otherwise they're not useable with C++ compiler unless wayland-server.h was included earlier. Signed-off-by: Mariusz Ceier --- src/scanner.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sr

[PATCH wayland 1/2] tests: C++ compilation test

2014-12-15 Thread Mariusz Ceier
This test includes one of wayland headers, which produced error with C++ compiler. C compiler can't be used for this test, because it issues only a warning[1] and only when wayland headers are not installed in system headers path (/usr/include). [1] wayland-server-protocol.h:201:2: warning: implic

Re: [PATCH] Fix bug https://bugs.freedesktop.org/show_bug.cgi?id=86889 by emitting session signals on TTY switches so that the weston backends can handle VT switching when not called from weston-launc

2014-12-15 Thread Pekka Paalanen
On Sun, 07 Dec 2014 10:15:29 -0500 nerdopolis wrote: > --- > src/logind-util.c | 6 ++ > 1 file changed, 6 insertions(+) > > diff --git a/src/logind-util.c b/src/logind-util.c > index 6a1b498..4308bb6 100644 > --- a/src/logind-util.c > +++ b/src/logind-util.c > @@ -695,9 +695,15 @@ signal_e

Re: [PATCH weston v1 16/17] test-helpers: add functions that simulate pointer actions

2014-12-15 Thread Pekka Paalanen
On Fri, 5 Dec 2014 14:36:49 +0100 Marek Chalupa wrote: > Add functions that simulate pointer movement, draging and clicking. > These functions will be handy in more tests, so add them to helpers. > > Signed-off-by: Marek Chalupa > --- > tests/weston-test-client-helper.c | 57 > ++

Re: [PATCH weston v1 14/17] weston-test: use real time instead of magic number

2014-12-15 Thread Pekka Paalanen
On Fri, 5 Dec 2014 14:36:47 +0100 Marek Chalupa wrote: > Pass time from weston_compositor_get_time() into notify_{motion, button} > etc. Until now the time was hardcoded to 100 and with toytoolkit clients > it causes problems, because toytoolkit checks the time. > > Signed-off-by: Marek Chalupa

Re: [PATCH weston v1 13/17] tests: make frame_callback_wait universal

2014-12-15 Thread Pekka Paalanen
On Fri, 5 Dec 2014 14:36:46 +0100 Marek Chalupa wrote: > frame_callback_wait uses wl_display_dispatch. Use display_dispatch > for toytoolkit clients. > > Signed-off-by: Marek Chalupa > --- > tests/weston-test-client-helper.c | 11 ++- > 1 file changed, 10 insertions(+), 1 deletion(-)

Re: [PATCH weston v1 12/17] tests: make client_roundtrip universal

2014-12-15 Thread Pekka Paalanen
On Fri, 5 Dec 2014 14:36:45 +0100 Marek Chalupa wrote: > Make client_roundtrip a function instead of macro and > make it work with both - normal clients and toytoolkit clients. > > Signed-off-by: Marek Chalupa > --- > tests/weston-test-client-helper.c | 17 + > tests/weston-te