On Sun, 21 Jun 2015 16:03:09 +
Emil Velikov wrote:
> On 19/06/15 22:00, Eric Anholt wrote:
> > I find 9/10 weird -- if the DRI drivers need libglapi, why aren't they
> > just linking libglapi?
> >
> Short version - currently they don't because of hysterical raisins, once
> we move to shared
2015-06-23 3:52 GMT+03:00 Bill Spitzak :
> It seems like prev
>
> On Mon, Jun 22, 2015 at 1:02 PM, Giulio Camuffo
> wrote:
>>
>> The backends used to have lots of code dealing with weston specific
>> configs.
>> To allow them to be used by other compositors with their own
>> configurations
>> remo
When edge scrolling is triggered by exceeding the motion threshold (5mm) we
sent the whole delta as the first scroll event, causing a big jump.
Instead, send only the current delta. This effectively introduces a 5mm dead
zone when edge scrolling, still better than the jump.
https://bugs.freedeskt
Reduce the dead zone/initial jump
https://bugs.freedesktop.org/show_bug.cgi?id=90990
Signed-off-by: Peter Hutterer
---
src/evdev-mt-touchpad-edge-scroll.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/evdev-mt-touchpad-edge-scroll.c
b/src/evdev-mt-touchpad-edge-scroll
It seems like prev
On Mon, Jun 22, 2015 at 1:02 PM, Giulio Camuffo
wrote:
> The backends used to have lots of code dealing with weston specific
> configs.
> To allow them to be used by other compositors with their own configurations
> remove all the usage of weston_config from the backends code
Dear Daniel:
Appreciate for your great help!
-邮件原件-
发件人: Daniel Stone [mailto:dan...@fooishbar.org]
发送时间: 2015年6月23日 0:46
收件人: tommy.sun (孫明勇)
抄送: wayland-devel@lists.freedesktop.org; security
主题: Re: question about wayland protocal compatibility between 32bit client and
64bit server
On 06/21/2015 11:33 PM, Nobuhiko Tanibata wrote:
> From: Nobuhiko Tanibata
>
> These tests are implemented on test suite framework, which provides
> helper client.
> Following features are tested for ivi-surface
> - orientation
> - dimension
> - position
> - destination rectangle
> - source recta
On Mon, Jun 22, 2015 at 12:37:43PM +0200, Andreas Pokorny wrote:
> Hi,
>
>
> On Mon, Jun 22, 2015 at 3:37 AM, Peter Hutterer
> wrote:
>
> > On Fri, Jun 19, 2015 at 03:24:38PM +0200, Andreas Pokorny wrote:
> > > + * */
> > > + if (orientation_info) {
> > > + if (orientation_
It uses the weston_client_launch API, which is not available in
libweston.
---
Makefile.am | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index b1d1044..2d24bcc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,7 +79,6 @@ libweston_@ABI_V
The library is versioned, so a -N is appended to its name, e.g. libweston-1.so.
The same is done for the pc file, the include and lib/weston dirs.
This allows multiple libweston versions to be installed together.
---
Makefile.am | 59 ++-
co
libweston still used those functions internally, so it was not linkable
yet by other compositors.
---
src/compositor.c | 144 --
src/weston.c | 145 +++
2 files changed, 145 insertions(+), 1
---
Makefile.am | 2 +-
src/compositor.h | 5 ++--
src/log.c| 69 ++---
src/weston.c | 78
4 files changed, 89 insertions(+), 65 deletions(-)
diff --git a/Makefile.am b/Makefile
Move the code launching the screenshooter client and implementing
the screenshot protocol out of libweston, and make screenshooter.c
a generic way to hook screenshoot protocols into weston.
A new header weston.h is added, with an entry point for the shells
to init the screenshooter.
---
Makefile.a
the --enable/disable-weston-binaries enables or disables the creation
of 'weston', 'weston-launch' and all the binaries that are
installed in $prefix/lib/libexec. This allows, together with
--enable-clients, to only build the libraries, making possible to
build and install different libweston versi
Instead of the central weston_config pointer we now store it in some
module-specific pointers. This way we can remove them one by one.
---
desktop-shell/shell.c | 10 +---
desktop-shell/shell.h | 1 +
fullscreen-shell/fullscreen-shell.c | 3 ++-
ivi-shell/hmi-cont
The backends used to have lots of code dealing with weston specific configs.
To allow them to be used by other compositors with their own configurations
remove all the usage of weston_config from the backends code and move it
in weston.c. The backends are now initialized with the new
weston_composi
Hi,
This is the new revision of libweston, with quite many changes
after Pekka's comments:
- no more weston_compositor_init/fini, but weston_compositor_create/destroy.
in a far future we may manage to make weston_compositor an opaque struct.
- all the backends are now loaded through a common
This commit adds three new exported functions:
- weston_compositor_create() returns a new weston_compositor instance,
initializing it as the now removed weston_compositor_init() did.
- weston_compositor_exit(compositor) asks the compositor to tear
down by calling the compositor's exit vfunc which i
This commits starts to separate the libweston code from the weston
specific code. As such, the main() is moved, together with signals
handling and configuration handling.
---
Makefile.am | 1 +
src/compositor.c | 801 +---
src/weston.c | 8
Hi Tommy,
On 22 June 2015 at 15:17, tommy.sun (孫明勇) wrote:
> I’m a soft engineer from MStar. I’m now considering the possibility of
> integrating wayland into our software. Before doing that, I need to make
> sure that wayland compositor could serve both 32bit client and 64bit client
> at the sa
Dear Wayland developers:
I’m a soft engineer from MStar. I’m now considering the possibility of
integrating wayland into our software. Before doing that, I need to make sure
that wayland compositor could serve both 32bit client and 64bit client at the
same time. That’s to say -- wayland protoc
From: Pekka Paalanen
This moves the single sprite creation code from create_sprites() into a
new function. The readability clean-up is small, but my intention is to
write an alternate version of create_sprites(), and sharing the single
sprite creation code is useful.
[daniels: Genericised from d
Retain drm_plane tracking objects for all actual DRM planes when using
universal planes, not just overlay planes.
These are currently unused.
v2: Rename sprite_list to plane_list.
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 37 +
1 file changed, 2
Add awareness of, rather than support for, universal planes. Activate
the client cap when we start if possible, and if this is activated,
studiously ignore non-overlay planes. For now.
v2: Add asserts to be careful. Bump libdrm dependency version.
Signed-off-by: Daniel Stone
---
configure.ac
Change the type of cursor_plane from a weston_plane (base tracking
structure) to a drm_plane (wrapper containing additional DRM-specific
details), and make it a dynamically-allocated pointer.
Using the standard drm_plane allows us to reuse code which already deals
with drm_planes, e.g. a common cl
If a plane is currently active on another output, don't steal it away.
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/compositor-drm.c b/src/compositor-drm.c
index c9071d2..fa520bc 100644
--- a/src/compositor-drm.c
+++ b/src/compos
Building on the drm_plane work from earlier, use the new atomic
modesetting interface where available, including enabling overlay planes
by default.
It is still highly experimental, but manages to at least prove the
overall atomic modesetting and blob property interfaces.
This patch was jointly a
From: Pekka Paalanen
Cut a chunk of code out from drm_output_set_cursor() and form a new
function for writing a cursor bo data from a weston_view with a wl_shm
buffer.
Add more asserts to verify the assumptions in there.
v2: Use drm_compositor::cursor_{width,height} instead of hard-coded 64.
S
Instead of testing against a hardcoded 64x64 pixel size to see if a view
is suitable for promotion to a cursor plane, use our cursor_width and
cursor_height variables.
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/
From: Pekka Paalanen
Refactor the code for choosing the initial mode for an output from
create_output_for_connector() to drm_output_choose_initial_mode().
This makes create_output_for_connector() slightly easier to read.
v2: Document everything.
Signed-off-by: Pekka Paalanen
Signed-off-by: Da
Use a real drm_plane to back the primary plane, displacing
output->current and output->next to their plane-tracked equivalents.
v2: Remove extra output->{current,next} members. Add primary plane to
plane_list so it gets cleaned up.
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 118
We make the differentiation where planes are an abstract framebuffer
with a position within a CRTC/output, and sprites are special cases of
planes that are neither the primary (base/framebuffer) nor cursor plane.
drm_sprite, OTOH, contains nothing that's actually specific to sprites,
and we end up
Track the current DPMS level for any given output, and track failure (or
otherwise) of the DPMS-setting property call.
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 14 --
1 file changed, 12 insertions(+), 2 deletions(-)
diff --git a/src/compositor-drm.c b/src/compositor-dr
We already keep a GBM BO for the cursor plane, but also keep a DRM FB,
so we can reuse it for atomic modesetting.
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 28 ++--
1 file changed, 26 insertions(+), 2 deletions(-)
diff --git a/src/compositor-drm.c b/src/comp
From: Pekka Paalanen
Refactor the code constructing the connector name into a new function.
This makes create_output_for_connector() slightly easier to read.
Signed-off-by: Pekka Paalanen
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 28 ++--
1 file changed, 1
Track the view a plane is currently displaying, so we can avoid
needlessly recreating buffers.
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 123 +++
1 file changed, 104 insertions(+), 19 deletions(-)
diff --git a/src/compositor-drm.c b/s
From: Pekka Paalanen
Makes create_output_for_connector() slightly easier to read.
Signed-off-by: Pekka Paalanen
Signed-off-by: Daniel Stone
---
src/compositor-drm.c | 41 ++---
1 file changed, 26 insertions(+), 15 deletions(-)
diff --git a/src/compositor-d
Hi,
Thanks to everyone who reviewed the previous series. This new series
cleans up the previous patches, introduces a few fixes (e.g. not relying
on a repaint to pull us out of DPMS), and crucially adds support for the
libdrm TEST_ONLY interface (allowing us to check before we commit, e.g.
that a p
Reviewed-By: Derek Foreman
On 21/06/15 02:25 PM, Mario Kleiner wrote:
> Initialize output->native_mode with the initially chosen
> mode for an output, so weston_output_mode_switch_to_native()
> has something to work with and can switch back from temporary
> selected modes to the outputs native mo
Hi Jon,
this is just a quick casual look, so I'm only mentioning what cought my
eye but mostly ignoring minor issues like style.
I know you sent a v5 series, but it sounded like my comments here are
still applicable.
I do get kind of confused every time a function is used earlier in the
file tha
On Tue, 16 Jun 2015 14:07:32 +0300
Pekka Paalanen wrote:
> From: Pekka Paalanen
>
> This is a follow-up for the patch that removed weston-screensaver. The
> aim is to clean up shell.c a little by removing non-essential
> components. Vanilla Weston desktop is only a demo, external projects are
>
On Wed, 10 Jun 2015 16:57:09 -0500
Derek Foreman wrote:
> Help messages were missing for some command line options.
>
> Signed-off-by: Derek Foreman
> ---
> src/compositor.c | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/src/compositor.c b/src/compositor.c
> index
On Fri, 12 Jun 2015 18:26:02 +0900
JoonCheol Park wrote:
> The headless-backend.so was missing in available backend list
>
> Signed-off-by: JoonCheol Park
> ---
> src/compositor.c | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/src/compositor.c b/src/compositor.c
> index 38c0775..
On Mon, 15 Jun 2015 12:36:29 +0300
Pekka Paalanen wrote:
> On Fri, 12 Jun 2015 16:44:16 -0700
> Bryce Harrington wrote:
>
> > The code generates a cursor-data.h file, with licensing information.
> > Change this from the MIT "X11" license to MIT "Expat" license for
> > consistency with the rest
This change adds strict axis_replacemnt and litest_touch_move_extended
and litest_touch_down_extended to simulate changes to other axes during
touch down and move events.
Signed-off-by: Andreas Pokorny
---
test/litest.c | 95 +++
test/lites
Hi,
Here is the third version. I added major / minor scaling for cases when
x_absinfo.resolution does not match y_absinfo.resolution, and fixed the
compilation errors that sneaked in last time.
regards
Andreas
Andreas Pokorny (5):
litest: add axis_replacement from tablet branch
litest: add a
This change adds four new properties to touch events.
major: diameter of the touch ellipse along the major axis
minor: diameter perpendicular to major axis
pressure: a pressure value mapped into the range [0,1]
orientation: the angle between major and the x axis
Those values are optionally support
Adds a device with various touch related axes and respective device features
to litest.
Signed-off-by: Andreas Pokorny
---
test/Makefile.am | 1 +
test/litest-touch-screen.c | 135 +
test/litest.c | 2 +
test/litest.h
This device provides a circular touch point size and and hence lacks
orientation. It will be used to test default value handling.
Signed-off-by: Andreas Pokorny
---
test/Makefile.am | 1 +
test/litest-nexus4-touch-screen.c | 116 ++
test/lit
Adds the macros ck_assert_double_{eq,ne,lt,gt,le,ge} to compare double
values using a fixed tolerance value. The tolerance value is
picked based on the range of values to be expected by the libinput API.
Signed-off-by: Andreas Pokorny
---
test/litest-selftest.c | 66 +
Hi,
On Mon, Jun 22, 2015 at 3:37 AM, Peter Hutterer
wrote:
> On Fri, Jun 19, 2015 at 03:24:38PM +0200, Andreas Pokorny wrote:
> > + * */
> > + if (orientation_info) {
> > + if (orientation_info->maximum == 1 &&
> > + orientation_info->maximum == 0)
> > +
Hi,
On 22-06-15 06:54, Peter Hutterer wrote:
No functional change, other than that we check for status codes now too.
In tests that don't specifically check the interface itself, a short
enable_tap() or disable_tap() is a lot more obvious to parse for the reader.
Signed-off-by: Peter Hutterer
Hi,
On 22-06-15 04:03, Peter Hutterer wrote:
Multiple devices plugged into the same USB hub have the same
PHYS path and are assigned to the same group.
Prepend the content of the PRODUCT env to the phys path, this at least ensures
that different devices are never grouped together.
https://bugs
53 matches
Mail list logo