Re: [RFC wayland 1/2] client: Introduce 'proxy wrapper' concept

2015-07-14 Thread Pekka Paalanen
On Tue, 14 Jul 2015 11:02:51 -0700 Bill Spitzak wrote: > On Tue, Jul 14, 2015 at 6:26 AM, Pekka Paalanen wrote: > > > > > > bar = wl_new_bar(); > > > wl_proxy_set_queue((struct wl_proxy*)bar, queue); // default queue if > > > this not done > > > wl_bar_add_listener(bar, ...); > > >

[PATCH weston 2/2] ivi-shell: transform refactoring to improve it to more readable code

2015-07-14 Thread Nobuhiko Tanibata
From: Nobuhiko Tanibata Transform matrix for transforming a surface to global_matrix is calculated from * ivi_layout_surface_properties * ivi_layout_layer_properties This patch pareares sub-method like following, 1/ calc_surface_to_global_matrix() calc_transformation_matrix() is called twice wi

[PATCH weston 1/2] ivi-shell: transform refactoring, remove transform part of ivi_layout_surface and ivi_layout_layer once

2015-07-14 Thread Nobuhiko Tanibata
From: Nobuhiko Tanibata To refactor transform of ivi_layout_surface and ivi_layout_surface to be more readable logical flow. Remove following parts once, * definition of weston_transform in ivi_layout_surface * update_layer_orientation * update_layer_position * update_surface_position * update_s

[PATCH weston 0/2] transform refactoring in ivi-shell

2015-07-14 Thread Nobuhiko Tanibata
Hi, Current code in ivi-shell to transform a surface to global_matrix is not readable very much. This patch set improves it. This consists of two patches, - remove transform part once to add transform logic from scratch. - add transform logic as more readable way. BR, Nobuhiko Tanibata _

[PATCH] ivi-shell: remove one indent level from update_prop()

2015-07-14 Thread Nobuhiko Tanibata
From: Nobuhiko Tanibata There is no logic update. Signed-off-by: Nobuhiko Tanibata Reviewed-by: Pekka Paalanen --- ivi-shell/ivi-layout.c | 39 +-- 1 file changed, 21 insertions(+), 18 deletions(-) diff --git a/ivi-shell/ivi-layout.c b/ivi-shell/ivi-layout

Re: Compositor grabs (was: Re: [PATCH] protocol: Add DnD actions)

2015-07-14 Thread Peter Hutterer
sorry, quite late to the discussion here On Fri, Apr 17, 2015 at 04:27:19PM +0200, Michal Suchanek wrote: > On 17 April 2015 at 16:15, Carlos Garnacho wrote: > > Hey Michal, > > > > On Fri, Apr 17, 2015 at 2:47 PM, Michal Suchanek wrote: > > > > > >>> In the X11 world, this would roughly be a V

Re: [PATCH v3 weston] Introduce wl_relative_pointer interface

2015-07-14 Thread Peter Hutterer
On Wed, Jul 15, 2015 at 08:23:09AM +0900, x414e54 wrote: > Hi, > > Just a quick questions: > > 1) Is there any way to un-normalize the values? not at this point, no. fwiw as of libinput 0.19 the normalization only applies to the accelerated delta, the unaccelerated one is generally in device-sp

Re: [PATCH wayland] protocol: define further the behavior of input on the presence of grabs

2015-07-14 Thread Peter Hutterer
late to the party, but anyway: On Tue, Jun 09, 2015 at 07:30:31PM +0200, Carlos Garnacho wrote: > A good piece of this commit is actually defining as protocol > documentation the de-facto behavior in weston and other compositors. > > Additionally, a wl_seat.release_input event is being added, and

[PATCH libinput] touchpad: drop thumb handling from gestures

2015-07-14 Thread Peter Hutterer
Thumb detection interfered with gestures a fair bit but it shouldn't. A pinch gesture with a thumb is a fairly natural move so we shouldn't cancel that. A swipe gesture with a thumb on the touchpad - well, don't do that. No need for code here. Reported-by: Carlos Garnacho Signed-off-by: Peter Hut

Re: Wayland Relative Pointer API Progress

2015-07-14 Thread Bill Spitzak
On Tue, Jul 14, 2015 at 4:14 PM, x414e54 wrote: > You are either just trolling or have no idea what you are talking > about and have never tried to implement anything you are saying. > I stopped listening at "The render loop would be sending the > cursor-positioning request.". Not sure how you

Re: [PATCH libinput] touchpad: disable 2fg scrolling on semi-mt touchpads

2015-07-14 Thread Peter Hutterer
On Tue, Jul 14, 2015 at 01:39:15PM +1000, Peter Hutterer wrote: > These touchpads have a terrible resolution when two fingers are down, causing > scrolling to jump around a lot. That then turns into bug reports that we can't > do much about, the data is simply garbage. > > For Alps: > https://bugs

Re: [PATCH v3 weston] Introduce wl_relative_pointer interface

2015-07-14 Thread x414e54
Hi, Just a quick questions: 1) Is there any way to un-normalize the values? 2) What happens with >1000hz gaming mice for example which need microsecond granularity timestamps? On Mon, Jun 29, 2015 at 3:54 PM, Peter Hutterer wrote: > On Fri, Jun 26, 2015 at 12:38:01PM +0800, Jonas Ådahl wrote:

Re: Wayland Relative Pointer API Progress

2015-07-14 Thread x414e54
You are either just trolling or have no idea what you are talking about and have never tried to implement anything you are saying. I stopped listening at "The render loop would be sending the cursor-positioning request.". Not sure how you cannot see the problem with this. I will be blocking your

Re: [PATCH v6 weston 19/19] input: Don't test keyboard/pointer/touch pointers

2015-07-14 Thread Derek Foreman
Snipped a lot of context this time... any snipped review I've already incorporated into the next patch set. On 01/07/15 03:56 AM, Jonas Ådahl wrote: > On Wed, Jun 03, 2015 at 03:53:38PM -0500, Derek Foreman wrote: >> Keyboards and pointers aren't freed when devices are removed, so we should >> rea

Re: [PATCH weston] README: introduce libweston

2015-07-14 Thread Bryce Harrington
On Tue, Jul 14, 2015 at 01:07:47PM +0300, Pekka Paalanen wrote: > From: Pekka Paalanen > > What is libweston and where do we intend to go with it. > > Cc: Giulio Camuffo > Signed-off-by: Pekka Paalanen > --- > README | 139 > - >

Re: Wayland Relative Pointer API Progress

2015-07-14 Thread Bill Spitzak
On Mon, Jul 13, 2015 at 9:48 PM, x414e54 wrote: > > Okay lets say for whatever reason you allow the client direct access > to set the cursor position in a way that did not introduce any extra > lag. > I'm going to ignore all this, because it is obvious that what I propose has "lag". Avoiding lag

Re: [RFC wayland 1/2] client: Introduce 'proxy wrapper' concept

2015-07-14 Thread Bill Spitzak
On Tue, Jul 14, 2015 at 6:26 AM, Pekka Paalanen wrote: > > > bar = wl_new_bar(); > > wl_proxy_set_queue((struct wl_proxy*)bar, queue); // default queue if > > this not done > > wl_bar_add_listener(bar, ...); > > wl_foo_get_bar(foo, bar); > > > > Note the last function will have to

Re: [RFC wayland 1/2] client: Introduce 'proxy wrapper' concept

2015-07-14 Thread Pekka Paalanen
On Wed, 1 Jul 2015 09:51:41 +0200 Marek Chalupa wrote: > On Wed, Jul 1, 2015 at 9:16 AM, Jonas Ådahl wrote: > > > On Wed, Jul 01, 2015 at 08:57:05AM +0200, Marek Chalupa wrote: > > > On Mon, Jun 29, 2015 at 3:37 PM, Giulio Camuffo > > > > > wrote: > > > > > > > 2015-06-29 14:30 GMT+03:00 Jonas

Re: [RFC wayland 1/2] client: Introduce 'proxy wrapper' concept

2015-07-14 Thread Pekka Paalanen
On Wed, 1 Jul 2015 14:50:58 -0700 Bill Spitzak wrote: > I would worry that there will be more things that can be done to a proxy > besides setting it's queue and listener. So instead of adding lots of > arguments to the get_bar wrapper, allow the proxy to be created and > everything set up *befor

Re: libinput / weston-terminal : missing the caret char in the terminal (^)

2015-07-14 Thread Pekka Paalanen
On Mon, 29 Jun 2015 13:15:48 +0200 Christian Hartmann wrote: > Hi list, > hi Peter and Bill, > > I actually did not have the possibility to enter the caret > (https://en.wikipedia.org/wiki/Caret) char within the weston-terminal. > Does anybody have an idea why or what is missing?? Or does anybod

Re: [PATCH weston v2] compositor: make sure to reset views' pointers to destroyed output

2015-07-14 Thread Daniel Stone
Hi, On 13 July 2015 at 11:26, Pekka Paalanen wrote: > On Sun, 12 Jul 2015 10:52:32 +0300 > Giulio Camuffo wrote: >> @@ -3888,9 +3891,15 @@ WL_EXPORT void >> weston_output_destroy(struct weston_output *output) >> { >> struct wl_resource *resource; >> + struct weston_view *view; >> >>

[PATCH weston] README: introduce libweston

2015-07-14 Thread Pekka Paalanen
From: Pekka Paalanen What is libweston and where do we intend to go with it. Cc: Giulio Camuffo Signed-off-by: Pekka Paalanen --- README | 139 - 1 file changed, 138 insertions(+), 1 deletion(-) diff --git a/README b/README inde

Re: [PATCH] Documentation for the prepare_lock_surface event description, is incorrect

2015-07-14 Thread Bryce Harrington
On Tue, Jul 14, 2015 at 09:20:42AM +0300, Pekka Paalanen wrote: > On Mon, 13 Jul 2015 13:04:38 -0700 > Bryce Harrington wrote: > > > On Mon, Jul 13, 2015 at 09:12:24AM +0300, Pekka Paalanen wrote: > > > On Fri, 10 Jul 2015 15:31:03 -0700 > > > Bryce Harrington wrote: > > > > > > > On Fri, Jul 1