[PATCH libinput] doc: inverse event type restriction of x and y accessors

2015-08-20 Thread Andreas Pokorny
Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com --- src/libinput.h | 12 1 file changed, 8 insertions(+), 4 deletions(-) diff --git a/src/libinput.h b/src/libinput.h index f2b77b3..88b3c05 100644 --- a/src/libinput.h +++ b/src/libinput.h @@ -894,7 +894,8 @@

Re: [PATCH weston v3] ivi-shell: bugfix, an ivi_surface is not removed from list of ivi_layer when the ivi_surface is removed from the compositor.

2015-08-20 Thread Pekka Paalanen
On Wed, 19 Aug 2015 11:25:02 + Ucan, Emre (ADITG/SW1) eu...@de.adit-jv.com wrote: - Introduce the dirty parameter for triggering the render order change - IVI_NOTIFICATION_REMOVE/ADD flags are set only at commit_layer_list. Signed-off-by: Emre Ucan eu...@de.adit-jv.com Hi Ucan-san and

Re: [PATCH weston] compositor-fbdev: fix VT switching crash

2015-08-20 Thread Pekka Paalanen
On Wed, 19 Aug 2015 10:21:07 -0500 Derek Foreman der...@osg.samsung.com wrote: Ouch, Reviewed-by: Derek Foreman der...@osg.samsung.com On 19/08/15 06:03 AM, Pekka Paalanen wrote: From: Pekka Paalanen pekka.paala...@collabora.co.uk This bug was introduced in

[PATCH libinput] doc: ellipse instead of ellipsis

2015-08-20 Thread Andreas Pokorny
Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com --- doc/touchpads.dox | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/doc/touchpads.dox b/doc/touchpads.dox index fa509bc..401f16a 100644 --- a/doc/touchpads.dox +++ b/doc/touchpads.dox @@ -71,7 +71,7 @@ touches,

Re: [PATCH weston v2] ivi-shell: bugfix, list of surfaces on a layer are cumulated when set render order is called several time in one commitchanges.

2015-08-20 Thread Pekka Paalanen
On Thu, 20 Aug 2015 05:45:07 + Tanibata, Nobuhiko (ADITJ/SWG) ntanib...@jp.adit-jv.com wrote: Hi Ucan-san, I reviewed and tested it. Additionally, we shall fix not only this one but also logic of layer list in screen similarly later as well. Tested-by: Nobuhiko Tanibata

[PATCH weston] gl-renderer: gl_renderer_create display cleanup on error

2015-08-20 Thread Dawid Gajownik
Clean up display connection via eglTerminate() in case of EGL initialisation error. Signed-off-by: Dawid Gajownik gajow...@gmail.com --- src/gl-renderer.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/src/gl-renderer.c b/src/gl-renderer.c index fd0720e..d7231f4 100644

Re: [PATCH weston] ivi-shell: bugfix, list of layers on a screen are cumulated when set render order is called several time in one commitchanges.

2015-08-20 Thread Pekka Paalanen
On Wed, 19 Aug 2015 11:25:03 + Ucan, Emre (ADITG/SW1) eu...@de.adit-jv.com wrote: - Always clear pending list at set_render_order API. - Introduce the dirty parameter for triggering the render order change. - IVI_NOTIFICATION_REMOVE/ADD flags are set only at commit_screen_list. Hi, the

[PATCH libinput 2/2] enable -Wall -Werror for CFLAGS

2015-08-20 Thread Andreas Pokorny
Just a small change in test is necessary to enable -Wall -Werror. Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com --- configure.ac | 4 ++-- test/litest.c | 8 ++-- 2 files changed, 8 insertions(+), 4 deletions(-) diff --git a/configure.ac b/configure.ac index 885cb39..b7597f0

RE: [PATCH weston] ivi-shell: bugfix, list of layers on a screen are cumulated when set render order is called several time in one commitchanges.

2015-08-20 Thread Ucan, Emre (ADITG/SW1)
Hi Pekka, -Original Message- From: wayland-devel [mailto:wayland-devel- boun...@lists.freedesktop.org] On Behalf Of Pekka Paalanen Sent: Donnerstag, 20. August 2015 12:43 To: Ucan, Emre (ADITG/SW1) Cc: Tanibata, Nobuhiko (ADITJ/SWG); wayland-devel@lists.freedesktop.org Subject: Re:

[PATCH libinput 1/2] test: fix gcc warning about missing prototypes

2015-08-20 Thread Andreas Pokorny
Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com --- test/litest.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/test/litest.c b/test/litest.c index 8fc7bca..29e764b 100644 --- a/test/litest.c +++ b/test/litest.c @@ -44,6 +44,8 @@ #include sys/sendfile.h #include

Re: [PATCH libinput 2/2] enable -Wall -Werror for CFLAGS

2015-08-20 Thread Pekka Paalanen
On Thu, 20 Aug 2015 12:51:38 +0200 Andreas Pokorny andreas.poko...@canonical.com wrote: Just a small change in test is necessary to enable -Wall -Werror. Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com --- configure.ac | 4 ++-- test/litest.c | 8 ++-- 2 files changed,

RE: [PATCH weston v3] ivi-shell: bugfix, an ivi_surface is not removed from list of ivi_layer when the ivi_surface is removed from the compositor.

2015-08-20 Thread Ucan, Emre (ADITG/SW1)
Hi Pekka, I will send a new patch after I fixed these issues. I used this commit message because it was used before by Tanibata-san. If you want, I can send it also with another (shorter) commit message. Best regards Emre Ucan Software Group I (ADITG/SW1) -Original Message- From:

[PATCH libinput] libinput: litest shall only emit auto assign events when replaced

2015-08-20 Thread Andreas Pokorny
With this change auto assign events will be skipped if no replacement value is provided. This behavior is practical when emitting mt events, as those only contain the axis values that changed. Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com --- test/litest.c | 8 1 file

Re: [PATCH libinput 2/2] enable -Wall -Werror for CFLAGS

2015-08-20 Thread Peter Hutterer
On Thu, Aug 20, 2015 at 02:32:23PM +0300, Pekka Paalanen wrote: On Thu, 20 Aug 2015 12:51:38 +0200 Andreas Pokorny andreas.poko...@canonical.com wrote: Just a small change in test is necessary to enable -Wall -Werror. Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com ---

Re: [PATCH wayland] Revert client: require WAYLAND_DISPLAY to be set

2015-08-20 Thread Bryce Harrington
On Thu, Aug 20, 2015 at 02:18:07PM -0400, Ray Strode wrote: Hi, All of these arguments makes sense, so I guess I agree with reverting this change. +1 Reviewed-by: Bryce Harrington br...@osg.samsung.com Great. pq are going to push before the beta? Yes, the right time to revert it is

Re: [PATCH libinput] doc: inverse event type restriction of x and y accessors

2015-08-20 Thread Peter Hutterer
On Thu, Aug 20, 2015 at 10:33:32AM +0200, Andreas Pokorny wrote: Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com merged, thanks. Cheers, Peter --- src/libinput.h | 12 1 file changed, 8 insertions(+), 4 deletions(-) diff --git a/src/libinput.h

Re: [PATCH libinput] doc: ellipse instead of ellipsis

2015-08-20 Thread Peter Hutterer
On Thu, Aug 20, 2015 at 10:31:47AM +0200, Andreas Pokorny wrote: Signed-off-by: Andreas Pokorny andreas.poko...@canonical.com merged, thanks. Cheers, Peter --- doc/touchpads.dox | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/doc/touchpads.dox

Re: Patchwork upgrade?

2015-08-20 Thread Bryce Harrington
On Thu, Aug 13, 2015 at 03:58:26PM +0200, Damien Lespiau wrote: On Fri, Aug 07, 2015 at 04:40:11PM -0700, Bryce Harrington wrote: Damien, would you have time to update Patchwork in the next week or two? Also, it would be awesome to have Cairo included in patchwork, for patches going

[ANNOUNCE] libinput 0.99.1

2015-08-20 Thread Peter Hutterer
The first release candidate for libinput 1.0 is now available. No additions to the API, this release only contains a couple of bugfixes and general improvements. The most obvious fix is that natural scrolling now also works for edge scrolling. The threshold needed to trigger scrolling on a

Re: [PATCH libinput] libinput: litest shall only emit auto assign events when replaced

2015-08-20 Thread Peter Hutterer
On Thu, Aug 20, 2015 at 01:43:40PM +0200, Andreas Pokorny wrote: With this change auto assign events will be skipped if no replacement value is provided. This behavior is practical when emitting mt events, as those only contain the axis values that changed. Signed-off-by: Andreas Pokorny

Re: [PATCH weston] compositor-drm: rename outputs to follow kernel style

2015-08-20 Thread Bryce Harrington
On Thu, Aug 20, 2015 at 10:04:45AM +0300, Pekka Paalanen wrote: On Wed, 19 Aug 2015 10:46:41 -0500 Derek Foreman der...@osg.samsung.com wrote: Excellent! Incidentally, this is also how Enlightenment names its outputs. Reviewed-by: Derek Foreman der...@osg.samsung.com Cheers.

Re: [PATCH wayland] Revert client: require WAYLAND_DISPLAY to be set

2015-08-20 Thread Ray Strode
Hi, All of these arguments makes sense, so I guess I agree with reverting this change. Great. pq are going to push before the beta? --Ray ___ wayland-devel mailing list wayland-devel@lists.freedesktop.org

Re: [PATCH weston 2/3] ivi-shell: clear order.layer_list before reordering it

2015-08-20 Thread Bill Spitzak
On Thu, Aug 20, 2015 at 7:13 AM, Ucan, Emre (ADITG/SW1) eu...@de.adit-jv.com wrote: Checking wl_list_empty() on a link offers no information: if it returns true, wl_list_remove() is safe to do. If it returns false, you still do not know if wl_list_remove() is safe; the link could be part of

[PATCH weston 3/3] ivi-shell: remove redundant wl_list_empty/init calls

2015-08-20 Thread Ucan, Emre (ADITG/SW1)
Checking wl_list_empty() on a link offers no information: if it returns true, wl_list_remove() is safe to do. If it returns false, you still do not know if wl_list_remove() is safe; the link could be part of a list, or the link could be uninitialized (e.g. just wl_list_remove()'d). (From Pekka

[PATCH weston 1/3] ivi-shell: clear order.surface_list before reordering it

2015-08-20 Thread Ucan, Emre (ADITG/SW1)
It is only possible to remove a surface from the order.surface_list of a layer, when ivi_layout_layer_set_render_order is called with an empty array. Therefore, list of surfaces are cumulated if the API is called many times with different list of surfaces. Change how the flags are set: -

[PATCH weston 2/3] ivi-shell: clear order.layer_list before reordering it

2015-08-20 Thread Ucan, Emre (ADITG/SW1)
It is only possible to remove a layer from the order.layer_list of a screen, when ivi_layout_screen_set_render_order is called with an empty array. Therefore, list of layers are cumulated if the API is called many times with different list of layers. Change how the flags are set: - Introduce

[PATCH weston 0/3] ivi-shell: Bugfix for ivi_layout_screen/layer_render_order

2015-08-20 Thread Ucan, Emre (ADITG/SW1)
Hi all, First two patches are actually new versions of my previous patches, but I wrote different commit summaries for them, because they were too long. The last patch removes redundant wl_list_empty/init calls as Pekka suggested. My previous patches can be removed from the patchwork. Emre

Re: [PATCH weston] compositor-drm: rename outputs to follow kernel style

2015-08-20 Thread Pekka Paalanen
On Wed, 19 Aug 2015 10:46:41 -0500 Derek Foreman der...@osg.samsung.com wrote: Excellent! Incidentally, this is also how Enlightenment names its outputs. Reviewed-by: Derek Foreman der...@osg.samsung.com Cheers. Any objections to landing this for 1.9-beta? It does force users to fix