Re: [PATCH v2 3/3 wayland] Validate the protocol xml during scanning

2015-11-17 Thread Pekka Paalanen
On Tue, 10 Nov 2015 09:53:08 +1000 Peter Hutterer wrote: > Embed the wayland.dtd protocol data into the scanner binary so we can validate > external protocol files without requiring makefile changes. Hat-tip to Pekka > Paalanen for the embedding trick. > The embedding

Re: [PATCH v2 3/3 wayland] Validate the protocol xml during scanning

2015-11-17 Thread Pekka Paalanen
On Tue, 17 Nov 2015 14:57:14 +0200 Pekka Paalanen wrote: > On Tue, 10 Nov 2015 09:53:08 +1000 > Peter Hutterer wrote: > > > Embed the wayland.dtd protocol data into the scanner binary so we can > > validate > > external protocol files without

[PATCH weston] releasing.txt: Add step about checking wayland-protocols dependency

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl Cc: Bryce Harrington --- Hi Bryce, Last time you asked about something like this, but it slipped my mind. Is this enough of a reminder or should it be more descriptive? Jonas releasing.txt | 20 1

Re: Changing wl_output.transform type to unsigned?

2015-11-17 Thread Jonas Ådahl
On Mon, Nov 16, 2015 at 12:46:21PM +0200, Pekka Paalanen wrote: > On Sun, 15 Nov 2015 22:17:38 +0100 > "Nils Chr. Brause" wrote: > > > On Sun, Nov 15, 2015 at 9:48 PM, Auke Booij wrote: > > > On 9 November 2015 at 18:17, Bill Spitzak

[PATCH libinput 14/14] doc: tablet documentation updates

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- doc/svg/tablet.svg | 199 + doc/tablet-support.dox | 52 - src/libinput.h | 5 +- 3 files changed, 252 insertions(+), 4 deletions(-) create mode 100644

[PATCH libinput 06/14] tablet: rename tool_proximity_state to tablet_tool_proximity state

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/libinput-private.h | 2 +- src/libinput.c | 6 +++--- src/libinput.h | 4 ++-- tools/event-debug.c| 2 +- 4 files changed, 7 insertions(+), 7 deletions(-) diff --git a/src/libinput-private.h

[PATCH libinput 03/14] tablet: rename the tablet axes to "LIBINPUT_TABLET_TOOL_AXIS_..."

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/evdev-tablet.c | 126 +-- src/evdev-tablet.h | 48 +-- src/libinput-private.h | 4 +- src/libinput.c | 66 +++--- src/libinput.h | 36 test/tablet.c

[PATCH libinput 11/14] tablet: rename LIBINPUT_EVENT_TABLET to LIBINPUT_EVENT_TABLET_TOOL

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- doc/tablet-support.dox | 2 +- src/libinput.c | 104 +- src/libinput.h | 46 +++ test/litest.c | 16 +++--- test/misc.c| 4 +- test/tablet.c

[PATCH libinput 05/14] tablet: rename TOOL_TYPE to TABLET_TOOL_TYPE

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/evdev-tablet.c | 54 ++--- src/evdev-tablet.h | 18 +- src/libinput.h | 26 +- test/tablet.c | 8 tools/event-debug.c |

[PATCH libinput 08/14] tablet: rename tool_tip_state to tablet_tool_tip_state

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/evdev-tablet.c | 4 ++-- src/libinput-private.h | 6 +++--- src/libinput.c | 10 +- src/libinput.h | 4 ++-- tools/event-debug.c| 2 +- 5 files changed, 13 insertions(+), 13 deletions(-) diff

[PATCH libinput 09/14] tablet: rename TOOL_TIP to TABLET_TOOL_TIP

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/evdev-tablet.c | 8 src/libinput.h | 4 ++-- test/tablet.c | 38 +++--- tools/event-debug.c | 2 +- tools/event-gui.c | 2 +- 5 files changed, 27 insertions(+), 27

[PATCH libinput 13/14] tablet: rename the libinput_tool calls to libinput_tablet_tool

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/evdev-tablet.c | 2 +- src/libinput.c | 26 ++-- src/libinput.h | 34 +-- src/libinput.sym| 18 +++--- test/tablet.c | 68

[PATCH libinput 12/14] tablet: rename libinput_event_tablet to libinput_event_tablet_tool

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/libinput.c | 56 +++ src/libinput.h | 66 src/libinput.sym| 32 ++-- test/litest.c | 30 ++-- test/litest.h | 2 +- test/misc.c | 16 +- test/tablet.c | 438

[PATCH libinput 01/14] tablet: rename libinput_tool to libinput_tablet_tool

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/evdev-tablet.c | 24 src/libinput-private.h | 10 +- src/libinput.c | 36 ++-- src/libinput.h | 26 +- test/tablet.c

[PATCH libinput 02/14] tablet: rename libinput_tablet_axis to libinput_tablet_tool_axis

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/evdev-tablet.c | 14 +++--- src/evdev-tablet.h | 10 +- src/libinput.c | 10 +- src/libinput.h | 12 ++-- tools/event-debug.c | 2 +- 5 files changed, 24 insertions(+), 24 deletions(-)

[PATCH libinput 00/14] tablet: the big "tablet" -> "tablet tool" rename

2015-11-17 Thread Peter Hutterer
The current tablet API is a bit inconsistent, we have various 'tablet' prefixes (libinput_event_tablet) and 'tool' prefixes (libinput_tool_get_serial). That made sense in the early stages when the emphasis on tools wasn't as strong as it is now. The tablet interface now is aimed solely at tablet

[PATCH libinput 07/14] tablet: rename TOOL_PROXIMITY_ to TABLET_TOOL_PROXIMITY

2015-11-17 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/evdev-tablet.c | 4 ++-- src/libinput.c | 6 +++--- src/libinput.h | 8 test/tablet.c | 6 +++--- tools/event-debug.c | 4 ++-- tools/event-gui.c | 2 +- 6 files changed, 15 insertions(+), 15 deletions(-)

[PATCH weston v4 01/20] input: Make pointer grab motion callbacks take an event struct

2015-11-17 Thread Jonas Ådahl
Instead of only passing absolute pointer coordinates, effectively loosing motion event data, pass a struct that can potentially contain different types of motion events, currently being absolute and relative. A helper function to get resulting absolute coordinates was added for when previous

[PATCH weston v4 02/20] desktop-shell: Track the black surface by its view

2015-11-17 Thread Jonas Ådahl
In preparation for further refactoring. Signed-off-by: Jonas Ådahl Signed-off-by: Arnaud Vrac --- desktop-shell/shell.c | 34 +++--- 1 file changed, 19 insertions(+), 15 deletions(-) diff --git a/desktop-shell/shell.c

[PATCH weston v4 07/20] libinput: Expose unaccelerated motion deltas in motion event struct

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl --- src/compositor.h | 3 +++ src/libinput-device.c | 9 - 2 files changed, 11 insertions(+), 1 deletion(-) diff --git a/src/compositor.h b/src/compositor.h index 032c637..3b1f63e 100644 --- a/src/compositor.h +++ b/src/compositor.h @@

[PATCH weston v4 13/20] clients: Add API for pointer locking and pointer confinement

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl Reviewed-by: Bryce Harrington --- Changes since v3: Uses the XML file from wayland-protocols. Updated implementation given interface renaming. Updated implementation given protocol changes (see protocol patch).

[PATCH weston v4 08/20] input: Don't send wl_pointer.motion if position didn't change

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl --- src/input.c | 12 1 file changed, 8 insertions(+), 4 deletions(-) diff --git a/src/input.c b/src/input.c index 0a567da..3fd4dae 100644 --- a/src/input.c +++ b/src/input.c @@ -173,6 +173,8 @@ default_grab_pointer_motion(struct

[PATCH weston v4 11/20] Implement the relative pointer protocol

2015-11-17 Thread Jonas Ådahl
A wp_relative_pointer object is an extension to the wl_pointer interface only used for emitting relative pointer events. It will only emit events when the parent pointer has focus. To get a relative pointer object, use the get_relative_pointer request of the global wp_relative_pointer_manager

[PATCH weston v4 03/20] desktop-shell: Change switcher to track views

2015-11-17 Thread Jonas Ådahl
Preparation for future refactorings. Signed-off-by: Jonas Ådahl --- desktop-shell/shell.c | 22 +++--- 1 file changed, 11 insertions(+), 11 deletions(-) diff --git a/desktop-shell/shell.c b/desktop-shell/shell.c index bdabcbf..0f473f8 100644 ---

[PATCH weston v4 05/20] desktop-shell: Pass a flag bitmask instead of bool to activate()

2015-11-17 Thread Jonas Ådahl
Although it currently only has one available flag, but that'll change. Signed-off-by: Jonas Ådahl --- desktop-shell/exposay.c | 9 ++--- desktop-shell/shell.c | 34 ++ desktop-shell/shell.h | 2 +- src/compositor.h| 5 + 4

[PATCH weston v4 12/20] Implement pointer locking and confinement

2015-11-17 Thread Jonas Ådahl
This patch implements the wp_pointer_constraints protocol used for locking or confining a pointer. It consists of a new global object with two requests; one for locking the surface to a position, one for confining the pointer to a given region. In this patch, only the locking part is fully

[PATCH weston v4 09/20] input: Keep per client pointer resources in their own structs

2015-11-17 Thread Jonas Ådahl
Keep all per client wl_pointer resources in a new struct called 'weston_pointer_client'. When focus changes, instead of moving a list of resources between different lists, just change the focused pointer client. The intention with this is to make it easier to add wl_pointer extensions that share

[PATCH weston v4 18/20] window: Add API for manually set confine region

2015-11-17 Thread Jonas Ådahl
We can use this to test more complex confine regions. Signed-off-by: Jonas Ådahl --- clients/window.c | 69 clients/window.h | 11 + 2 files changed, 70 insertions(+), 10 deletions(-) diff --git

[PATCH weston v4 16/20] input: Support non-rectangular pointer confine regions

2015-11-17 Thread Jonas Ådahl
This patch adds support for when the resulting pointer confinement region is not a rectangle. Support for this is implemented by converting the rectangles of the region into the regions outer border. Pointer motions are then clamped to these borders in order to not escape the confinement region.

[PATCH weston v4 17/20] clients/clickdot: Reset motion lines on Backspace

2015-11-17 Thread Jonas Ådahl
Clear the white lines that is drawn by pointer motions. It makes it easier to debug pointer movements as one won't need to restart clickdot just to get a clean plate. Signed-off-by: Jonas Ådahl --- clients/clickdot.c | 6 ++ 1 file changed, 6 insertions(+) diff --git

[PATCH weston v4 20/20] clients/clickdot: Toggle maximized state with 'm'

2015-11-17 Thread Jonas Ådahl
In order to test wapring when pointer confinemen region changes, add key binding to the maximized state without using the mouse. Signed-off-by: Jonas Ådahl Reviewed-by: Bryce Harrington --- clients/clickdot.c | 14 +- 1 file changed, 13

[PATCH weston v4 15/20] clients/clickdot: Use pointer confinement to confine drawed line

2015-11-17 Thread Jonas Ådahl
Use pointer confinement to make the line drawing not go outside the drawing area. It is toggled with the right pointer button. Signed-off-by: Jonas Ådahl --- clients/clickdot.c | 33 +++-- 1 file changed, 31 insertions(+), 2 deletions(-) diff --git

[PATCH weston v4 04/20] desktop-shell: Make activate() take a view instead of surface

2015-11-17 Thread Jonas Ådahl
In preparation for further refactorings. Signed-off-by: Jonas Ådahl --- desktop-shell/exposay.c | 6 +++--- desktop-shell/shell.c | 20 +++- desktop-shell/shell.h | 2 +- 3 files changed, 15 insertions(+), 13 deletions(-) diff --git

[PATCH weston v4 06/20] compositor: Keep track of what views were activated by clicking

2015-11-17 Thread Jonas Ådahl
Adds a weston_view_activate() that can be passed an additional active flag WESTON_ACTIVATE_CLICKED, that the shell passes when a view was activated by clicking. This allows shell independent components implement heuristics depending on how a view was activated. Signed-off-by: Jonas Ådahl

[PATCH weston v4 19/20] clients/clickdot: Add option for using a more complex confine region

2015-11-17 Thread Jonas Ådahl
By passing --complex-confine-region clickdot will draw an area looking like a strange H in half transparent gray. This region will act as the confine region when pointer confinement is activated (by right clicking). Signed-off-by: Jonas Ådahl --- clients/clickdot.c | 133

[PATCH wayland-protocols 2/2] Introduce pointer locking and confinement protocol

2015-11-17 Thread Jonas Ådahl
This patch introduces a new protocol for locking and confining a pointer. It consists of a new global object with two requests; one for locking the surface to a position, one for confining the pointer to a given region. Signed-off-by: Jonas Ådahl --- Changes since last version

[PATCH wayland-protocols 1/2] Introduce wp_relative_pointer interface

2015-11-17 Thread Jonas Ådahl
The wp_relative_pointer interface is an extension to the wl_pointer interface created from wl_seat. It has the same focus, but adds the functionality of sending relative pointer motions unhindered by constraints such as monitor edges or other barriers. It also contains unaccelerated pointer motion

[PATCH weston v2 4/9] Use input method protocol from wayland-protocols

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl Reviewed-by: Mariusz Ceier Reviewed-by: Jan Arne Petersen --- Makefile.am | 17 ++- clients/keyboard.c | 174 +- clients/weston-simple-im.c | 130

[PATCH weston v2 1/9] Use fullscreen-shell.xml from wayland-protocols

2015-11-17 Thread Jonas Ådahl
Use the fullscreen-shell protocol XML from the wayland-protocols installation, and remove the one we provide ourself. Signed-off-by: Jonas Ådahl Reviewed-by: Mariusz Ceier Acked-by: Jason Ekstrand --- Makefile.am

[PATCH weston v2 5/9] Makefile.am: Make the external xml scanning rule version generic

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl Reviewed-by: Mariusz Ceier --- Makefile.am | 14 +++--- 1 file changed, 11 insertions(+), 3 deletions(-) diff --git a/Makefile.am b/Makefile.am index 4c70559..0435702 100644 --- a/Makefile.am +++ b/Makefile.am @@

[PATCH weston v2 2/9] Use linux-dmabuf protocol from wayland-protocols

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl Reviewed-by: Mariusz Ceier Acked-by: Pekka Paalanen --- Makefile.am | 13 +-- clients/simple-dmabuf.c | 60 +- protocol/linux-dmabuf.xml | 274

[PATCH weston v2 9/9] Remove workspaces protocol

2015-11-17 Thread Jonas Ådahl
It doesn't fill a useful function and is not intended to be continued. If there is need for workspace manipulation from clients a protocol based on those future needs need to be properly designed. workspaces.xml is probably not very relevant since it did the bare minimum. Signed-off-by: Jonas

[PATCH weston v2 7/9] desktop-shell: Rename protocol weston_desktop_shell

2015-11-17 Thread Jonas Ådahl
In the effort of going away from generic names of protocols only relevant for weston, rename the weston desktop shell weston_desktop_shell. This also resets the version to 1, as there will be no prior versions to weston_desktop_shell. Signed-off-by: Jonas Ådahl Reviewed-by:

[PATCH weston v2 0/9] weston wayland-protocols migration

2015-11-17 Thread Jonas Ådahl
Hi again, This is the second version of the weston wayland-protocols migration patch series. Overall, it's pretty much the same, but here are the differences: Naming is updated to new naming (wl -> wp, N -> _vN). The presentation timing protocol is dropped. Pekka said he'd like to avoid the

[PATCH weston v2 6/9] Use xdg_shell protocol from wayland-protocols

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl Reviewed-by: Mariusz Ceier Acked-by: Pekka Paalanen Acked-by: Jasper St. Pierre --- Makefile.am | 29 ++- clients/simple-damage.c | 2 +-

[PATCH weston v2 3/9] Use text input protocol from wayland-protocols

2015-11-17 Thread Jonas Ådahl
Signed-off-by: Jonas Ådahl Reviewed-by: Mariusz Ceier Reviewed-by: Jan Arne Petersen --- Makefile.am| 21 ++- clients/editor.c | 119 + clients/keyboard.c | 12 +- protocol/text.xml | 374

[PATCH weston v2 8/9] Rename screenshooter protocol to weston_screenshooter

2015-11-17 Thread Jonas Ådahl
Due to the effort of moving a way from non-prefixed protocols, rename the weston specific screenshooter protocol to weston_screenshooter. Signed-off-by: Jonas Ådahl Reviewed-by: Mariusz Ceier Acked-by: Pekka Paalanen

[PATCH weston v4 14/20] clients/resizor: Use pointer locking for resizing window

2015-11-17 Thread Jonas Ådahl
Resizes the window using pointer locking when holding the left pointer button down. The pointer lock cursor position hint is used to warp the pointer to the same position relative to the bottom right corner. Signed-off-by: Jonas Ådahl --- clients/resizor.c | 159