Re: [PATCH weston v4] refactor x11-backend configuration API

2016-03-21 Thread Jan Engelhardt
On Monday 2016-03-21 22:58, Benoit Gschwind wrote: > struct x11_output { >@@ -130,6 +127,11 @@ struct window_delete_data { > > struct gl_renderer_interface *gl_renderer; > >+static void >+weston_x11_backend_config_init_default(struct weston_x11_backend_config * >ths) { >+ bzero(ths, sizeof

Re: [PATCH 4/5] compositor: Version the backend configuration structures

2016-03-21 Thread Benoit Gschwind
Hello, I think that struct_version and struct_size should not be belong compositor.h. I think those versioning should be back-end detail, and each back-end should provide a major version number through #define in the backend header. Otherwise the patch look good Best regards. Reviewed-by: Benoi

[PATCH weston v4] refactor x11-backend configuration API

2016-03-21 Thread Benoit Gschwind
Use a "well" defined structure to configure x11-backend and move configuration file parsing inside the weston compositor code. v4: add struct_version, and check for null pointer of the configuration structure. v3: properly check memory error for the memory allocation of the outputs array. v2: add

[PATCH 2/7] gl-renderer: Refactor gl_renderer_output_window_create()

2016-03-21 Thread Miguel A. Vico
In preparation for follow-on changes to support frame presentation through EGLDevice+EGLOutput, this change refactors gl_renderer_output_window_create() to separate out window surface creation code from output common creation code. Bonus: Fix EGLSurface leakage upon gl_renderer_setup() failure. S

[PATCH 3/7] gl-renderer: Implement & use check_extension

2016-03-21 Thread Miguel A. Vico
Using strstr(3) for checking for extensions is an error-prone mechanism as extension names can be prefixes of other extension names (see https://www.opengl.org/registry/doc/rules.html#using). This change implements the check_extension() function to properly check for an extension and replaces all

[PATCH 1/7] gl-renderer: Renaming of things and minor improvements

2016-03-21 Thread Miguel A. Vico
In preparation for follow-on changes to support frame presentation through EGLDevice+EGLOutput, this change includes the following: -Rename gl_renderer_output_create to gl_renderer_output_window_create -Add argument to gl_renderer_create -Rename argument for gl_renderer_create() and gl_r

[PATCH 4/7] gl-renderer: Add support for EGLDevice+EGLOutput

2016-03-21 Thread Miguel A. Vico
EGLDevice provides means to enumerate native devices, and then create an EGL display connection from them. Similarly, EGLOutput will provide means to access different portions of display control hardware associated with an EGLDevice. For instance, EGLOutputLayer represents a portion of display co

[PATCH 7/7] compositor-drm: Add support for EGLDevice+EGLOutput

2016-03-21 Thread Miguel A. Vico
As previously stated, EGLDevice and EGLOutput will provide means to access native device objects and different portions of display control hardware respectively. Whenever EGL_EXT_device_drm extension is present, EGLDevice can be used to enumerate and access DRM KMS devices, and EGLOutputLayer to e

[PATCH 5/7] compositor-drm: Gracefully handle vblank and flip invalid timestamps

2016-03-21 Thread Miguel A. Vico
Instant query for vblank timestamp may always fail, resulting in never scheduling a full repaint in drm_output_start_repaint_loop(). Additionally, timestamp provided in page_flip_handler() may also be invalid. This change makes both drm_output_start_repaint_loop() and page_flip_handler() to sched

[PATCH 6/7] compositor-drm: Renaming of things

2016-03-21 Thread Miguel A. Vico
In preparation for follow-on changes to support frame presentation through EGLDevice+EGLOutput, this change includes the following: - Rename drm_backend::format to gbm_format - Rename drm_output::formatto gbm_format - Rename drm_output::surface to gbm_surface - Rename drm_output::cu

Introduction and updates from NVIDIA

2016-03-21 Thread Miguel Angel Vico
Hi all, First of all, I'd like to introduce myself to the Wayland community: My name is Miguel A. Vico, and I've been working as a Software Engineer for NVIDIA for some time now, more specifically, in the Linux drivers team. Although I've never spoken before, I've been lately following the amazing

Re: [GSoC Application Review] Application Review for Wayland Project

2016-03-21 Thread Armin Krezović
On 21.3.2016 14:40, Pekka Paalanen wrote: On Mon, 21 Mar 2016 13:43:06 +0100 Armin Krezović wrote: On 21.3.2016 8:57, Pekka Paalanen wrote: On Sat, 19 Mar 2016 23:33:21 +0100 Armin Krezović wrote: On 13.03.2016 18:22, Armin Krezović wrote: Hello Pekka, Quentin and Kat (sorry, don't know

Re: [GSoC Application Review] Application Review for Wayland Project

2016-03-21 Thread Pekka Paalanen
On Mon, 21 Mar 2016 13:43:06 +0100 Armin Krezović wrote: > On 21.3.2016 8:57, Pekka Paalanen wrote: > > On Sat, 19 Mar 2016 23:33:21 +0100 > > Armin Krezović wrote: > > > >> On 13.03.2016 18:22, Armin Krezović wrote: > >>> Hello Pekka, Quentin and Kat (sorry, don't know the real name yet). >

Re: [GSoC Application Review] Application Review for Wayland Project

2016-03-21 Thread Armin Krezović
On 21.3.2016 8:57, Pekka Paalanen wrote: On Sat, 19 Mar 2016 23:33:21 +0100 Armin Krezović wrote: On 13.03.2016 18:22, Armin Krezović wrote: Hello Pekka, Quentin and Kat (sorry, don't know the real name yet). Pekka and Quentin have volounteered to review my GSoC application draft for the Way

[PATCH weston v3] input: use doubles in the interfaces to notify of input events

2016-03-21 Thread Giulio Camuffo
This patch is a further step in the wl_fixed_t internal sanitization. It changes the notify_* functions to take doubles instead of wl_fixed_t but does not change how these are stored in the various input structs yet, except for weston_pointer_axis_event. However this already allows to remove all wl

Re: Semantics of wl_subcompositor::get_subsurface

2016-03-21 Thread Pekka Paalanen
On Mon, 21 Mar 2016 08:36:59 +0100 Martin Graesslin wrote: > Hi Wayland-devs, > > while implementing sub-surface support in KWin I run into a small problem > regarding the get_subsurface request: > > When should the new subsurface be added to the parent surface? > > My interpretation was that

Re: [GSoC Application Review] Application Review for Wayland Project

2016-03-21 Thread Pekka Paalanen
On Sat, 19 Mar 2016 23:33:21 +0100 Armin Krezović wrote: > On 13.03.2016 18:22, Armin Krezović wrote: > > Hello Pekka, Quentin and Kat (sorry, don't know the real name yet). > > > > Pekka and Quentin have volounteered to review my GSoC application > > draft for the Wayland project. Pekka also su

Semantics of wl_subcompositor::get_subsurface

2016-03-21 Thread Martin Graesslin
Hi Wayland-devs, while implementing sub-surface support in KWin I run into a small problem regarding the get_subsurface request: When should the new subsurface be added to the parent surface? My interpretation was that the subsurface will only be added after the next commit on the parent surfa