Re: [PATCH weston v3 00/17] compositor-wayland: refactor the configuration API

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 22:45:38 +0200 Benoit Gschwind wrote: > v3: > - rebase to master > - heavy patches spliting to help review as suggested by Pekka > - fix typo. > - rename functions and variables as suggested by Pekka > > Benoit Gschwind (17): > compositor-wayland:

Re: [PATCH weston v3 09/17] compositor-wayland: refactor wayland_backend_config_add_new_output

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 22:45:47 +0200 Benoit Gschwind wrote: > Rename new_config to config in wayland_backend_config_add_new_output > function. > > Signed-off-by: Benoit Gschwind > --- > src/main.c | 12 ++-- > 1 file changed, 6 insertions(+),

Re: [PATCH weston v3 02/17] compositor-wayland: add versionning to config structure

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 22:45:40 +0200 Benoit Gschwind wrote: > Signed-off-by: Benoit Gschwind > --- > src/compositor-wayland.c | 27 --- > src/compositor-wayland.h | 3 +++ > 2 files changed, 27 insertions(+), 3 deletions(-) >

Re: [PATCH weston v3 05/17] compositor-wayland: move configuration parsing to main.c

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 22:45:43 +0200 Benoit Gschwind wrote: > Move function load_wayland_backend_config, > wayland_backend_config_add_new_output, wayland_backend_config_release, > wayland_output_config_init from compositor-wayland.c to main.c. > > Rename

Re: [PATCH weston v3 04/17] compositor-wayland: refactor wayland_output_config_init

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 22:45:42 +0200 Benoit Gschwind wrote: > Rename the missleading output to output_config. Hi, that is indeed the only thing this patch does, so that should be the summary (the email subject, the first line in git commit message). There is no refactoring

Re: [PATCH weston v3 08/17] compositor-wayland: refactor load_wayland_backend

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 22:45:46 +0200 Benoit Gschwind wrote: > Rename variable new_config to config in load_wayland_backend function. > > Signed-off-by: Benoit Gschwind > --- > src/main.c | 54 +++--- > 1

Re: [PATCH weston v3 01/17] compositor-wayland: fix misc. typo

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 22:45:39 +0200 Benoit Gschwind wrote: > Signed-off-by: Benoit Gschwind > --- > src/compositor-wayland.c | 6 -- > 1 file changed, 4 insertions(+), 2 deletions(-) > > diff --git a/src/compositor-wayland.c

Re: [PATCH weston v3 06/17] compositor-wayland: refactor load_wayland_backend

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 22:45:44 +0200 Benoit Gschwind wrote: > Rename compositor to c in load_wayland_backend function. > > Signed-off-by: Benoit Gschwind > --- > src/main.c | 8 > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff

Re: [PATCH weston v3 03/17] compositor-wayland: rename wayland_output_init_from_config

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 18:27:27 -0500 Yong Bakos wrote: > On May 5, 2016, at 6:12 PM, Yong Bakos wrote: > > > > Hi Benoit, > > > > On May 5, 2016, at 3:45 PM, Benoit Gschwind wrote: > >> > >> Rename

Re: [PATCH wayland v2] scanner: Add version argument to wayland-scanner

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 17:06:43 -0700 Bryce Harrington wrote: > On Thu, May 05, 2016 at 06:34:54PM -0500, Yong Bakos wrote: > > On May 5, 2016, at 10:27 AM, Armin Krezović > > wrote: > > > > > > This adds a command line argument to print

Re: Lack of tutorials and guides...

2016-05-06 Thread Yong Bakos
Hi Inhabitant, On Apr 30, 2016, at 1:37 PM, Cestarian Inhabitant wrote: > > I've been wanting for a while now to get started with developing my > own Wayland Compositor/Window Manager/Shell. And I honestly can't find > much in the way of "how tos" or "getting started with

Re: [PATCH wayland-protocols, weston v3 0/17] Stabilize wl_scaler as wp_viewporter

2016-05-06 Thread Pekka Paalanen
On Thu, 5 May 2016 15:46:46 -0700 Bryce Harrington wrote: > On Wed, May 04, 2016 at 05:33:10PM -0700, Bryce Harrington wrote: > > On Tue, Apr 26, 2016 at 03:50:52PM +0300, Pekka Paalanen wrote: > > > From: Pekka Paalanen > > > > > > Hi,

Re: [PATCH weston v3 14/17] compositor: check viewport source rect validity

2016-05-06 Thread Pekka Paalanen
On Wed, 4 May 2016 18:02:57 -0700 Bryce Harrington wrote: > On Tue, Apr 26, 2016 at 03:51:06PM +0300, Pekka Paalanen wrote: > > From: Pekka Paalanen > > > > wp_viewporter spec requires protocol errors when the viewport is outside > > the

Re: [PATCH weston v3 13/17] compositor: fix wp_viewport use after free

2016-05-06 Thread Pekka Paalanen
On Wed, 4 May 2016 17:57:59 -0700 Bryce Harrington wrote: > On Tue, Apr 26, 2016 at 03:51:05PM +0300, Pekka Paalanen wrote: > > From: Pekka Paalanen > > > > If a client destroyed the wl_surface before the wp_viewport, Weston core > > would

Re: [PATCH weston v3 07/17] compositor: refactor into convert_size_by_transform_scale()

2016-05-06 Thread Pekka Paalanen
On Wed, 4 May 2016 17:45:33 -0700 Bryce Harrington wrote: > On Tue, Apr 26, 2016 at 03:50:59PM +0300, Pekka Paalanen wrote: > > From: Pekka Paalanen > > > > There were two copies of code applying transform and scale to size. > > Refactor

Re: [ANNOUNCE] wayland 1.10.91

2016-05-06 Thread Pekka Paalanen
On Wed, 4 May 2016 11:46:23 -0700 Bryce Harrington wrote: > On Wed, May 04, 2016 at 12:55:16AM -0700, Bryce Harrington wrote: > > Here's the alpha for the upcoming 1.11 release. I'll summarize the > > major features for this release in the beta announcement, but see below

Re: [PATCH] client: "Ex" versions of constructors, alternative to proxy_wrapper

2016-05-06 Thread Bill Spitzak
On Mon, May 2, 2016 at 10:42 PM, wrote: > From: Bill Spitzak > > Scanner produces a xyz_create() for each object that wraps the > wl_proxy_create function. For each constructor request a new "Ex" version > is created that takes the created object. This

Re: [PATCH wayland v4] client: Introduce proxy wrappers

2016-05-06 Thread Bill Spitzak
On Fri, Apr 29, 2016 at 5:59 AM, Pekka Paalanen wrote: > > > + pthread_mutex_lock(_proxy->display->mutex); > > + > > + wrapper->object.interface = wrapped_proxy->object.interface; > > + wrapper->object.id = wrapped_proxy->object.id; > > + wrapper->version =

Lack of tutorials and guides...

2016-05-06 Thread Cestarian Inhabitant
I've been wanting for a while now to get started with developing my own Wayland Compositor/Window Manager/Shell. And I honestly can't find much in the way of "how tos" or "getting started with wayland development" or well, anything. The only "official" tutorial or educational material seems to be

Re: [PATCH wayland-web] building: Remove deprecated mesa autogen option

2016-05-06 Thread Bill Spitzak
Seems quite likely to be correct. Note that I got these instructions from some other Wayland build instructions and it is quite possible it worked without this switch even in old versions. On Wed, Apr 27, 2016 at 6:44 AM, Yong Bakos wrote: > From: Yong Bakos

Re: [PATCH weston v7 3/3] drm: Don't hang onto the backend config object post-backend_init

2016-05-06 Thread Benoit Gschwind
Hello Bryce, Ok I can live with this patches ;) Reviewed-by: Benoit Gschwind On 05/05/2016 00:24, Bryce Harrington wrote: > On Sat, Apr 30, 2016 at 11:41:15AM +0200, Benoit Gschwind wrote: >> Hello Bryce, >> >> I think my comments on previous patch apply here, while you