Regarding Wayland Integration to embedded arm64 platform

2017-07-24 Thread saikishore
Hi, I am trying to enable wayland to arm64 embedded platform and i use buildroot to build the rootfs and use kernel 4.1. I have builded wayland 1.7 & weston 1.7 packages using buildroot and enabled in rootfs and no kernel changes. Initially i want to run weston without any hardware changes. Is

Re: [PATCH weston v11 03/13] compositor-drm: Add DRM property cache

2017-07-24 Thread Daniel Stone
Hi Pekka, I've made a mental note to make as careful passes over the documentation as the code before I send for review ... On 19 July 2017 at 15:43, Pekka Paalanen wrote: > On Tue, 18 Jul 2017 14:14:25 +0100 > Daniel Stone wrote: >> + /*

Re: [PATCH weston v2 14/14] libweston: introduce weston_output_from_resource()

2017-07-24 Thread Armin Krezović
On 24.07.2017 17:08, Pekka Paalanen wrote: > From: Pekka Paalanen > > This is a simple wrapper for casting the user data of a wl_resource into > a struct weston_output pointer. Using the wrapper clearly marks all the > places where a wl_output protocol object is

Re: [PATCH weston v2 10/14] libweston: move output id into add/remove_output()

2017-07-24 Thread Armin Krezović
On 24.07.2017 17:08, Pekka Paalanen wrote: > From: Pekka Paalanen > > Move the output id management into weston_compositor_add_output() and > weston_compositor_remove_output(). This is a more logical place, and > works towards assimilating

Re: [PATCH weston v2 03/14] libweston: let add/remove_output handle the lists

2017-07-24 Thread Armin Krezović
On 24.07.2017 17:07, Pekka Paalanen wrote: > From: Pekka Paalanen > > A weston_output available to the compositor should always be either in > the list of pending outputs or the list of enabled outputs. Let > weston_compositor_add_output() and

RE: [PATCH weston v11 02/13] compositor-drm: Rename fb_plane to scanout_plane

2017-07-24 Thread Ucan, Emre (ADITG/ESB)
Hi, It is a simple renaming patch. Proposed name makes sense: Reviewed-by: Emre Ucan Best regards Emre Ucan Engineering Software Base (ADITG/ESB) Tel. +49 5121 49 6937 > -Original Message- > From: wayland-devel [mailto:wayland-devel- >

RE: [PATCH weston v11 01/13] compositor-drm: Refactor sprite create/destroy into helpers

2017-07-24 Thread Ucan, Emre (ADITG/ESB)
It looks good to me Reviewed-by: Emre Ucan Best regards Emre Ucan Engineering Software Base (ADITG/ESB) Tel. +49 5121 49 6937 > -Original Message- > From: wayland-devel [mailto:wayland-devel- > boun...@lists.freedesktop.org] On Behalf Of Daniel Stone > Sent:

[PATCH weston v2 14/14] libweston: introduce weston_output_from_resource()

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen This is a simple wrapper for casting the user data of a wl_resource into a struct weston_output pointer. Using the wrapper clearly marks all the places where a wl_output protocol object is used. Replace ALL wl_output related calls to

[PATCH weston v2 11/14] libweston: move globals to weston_compositor_add_output()

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen Move the wl_output global management into weston_compositor_add_output() and weston_compositor_remove_output(). If weston_output_enable() fails, there is no need to clean up the global and the clients will not see a wl_output come and go.

[PATCH weston v2 13/14] libweston: make weston_output::connection_internal a bool

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen It really is a boolean. Signed-off-by: Pekka Paalanen Reviewed-by: Armin Krezović --- libweston/compositor-drm.c | 2 +- libweston/compositor.h | 2 +- 2 files changed, 2

[PATCH weston v2 12/14] libweston: extend output->region lifetime

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen It's a little awkward to try to keep the weston_output::region and weston_output::previous_damage allocate exactly only when the output is enabled. There was also a leak: weston_output_move() was calling weston_output_init_geometry() on an

[PATCH weston v2 10/14] libweston: move output id into add/remove_output()

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen Move the output id management into weston_compositor_add_output() and weston_compositor_remove_output(). This is a more logical place, and works towards assimilating weston_output_enable_undo(). The output id is no longer available to the

[PATCH weston v2 08/14] libweston: specify weston_output::enabled

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen It was ambiguous what this flag meant - it did not mean whether the backend is considering this output to be enabled, because weston_output_destroy() unsets it while deliberately not calling the backend disable() vfunc. Perhaps the most clear

[PATCH weston v2 09/14] libweston: prevent double weston_output_enable()

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen Enabling an already enabled output is an error, at least with the current implementation. However, disabling an output that has not been enabled is ok. Cope with the first and document the second. Signed-off-by: Pekka Paalanen

[PATCH weston v2 06/14] libweston: unexport weston_output_update_matrix()

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen Only used internally in core. Needs to happen automatically when something changes, so there should no need to call it from outside. Signed-off-by: Pekka Paalanen Reviewed-by: Armin Krezović

[PATCH weston v2 05/14] libweston: unexport weston_compositor_add_output()

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen Only used by weston_output_enable(). Signed-off-by: Pekka Paalanen Reviewed-by: Armin Krezović --- libweston/compositor.c | 2 +- libweston/compositor.h | 3 --- 2 files changed, 1

[PATCH weston v2 07/14] libweston: move asserts to add_pending_output()

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen weston_compositor_add_pending_output() is the point through which all backends must go when creating a new output. The enable and disable vfuns are essential for anything to be done with the output, so it makes sense to check them here, rather

[PATCH weston v2 03/14] libweston: let add/remove_output handle the lists

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen A weston_output available to the compositor should always be either in the list of pending outputs or the list of enabled outputs. Let weston_compositor_add_output() and weston_compositor_remove_output() handle the moves between the lists.

[PATCH weston v2 04/14] libweston: two more weston_output docs

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen Document two more functions of the weston_output API. Exported functions marked internal are meant for backends only. Exported functions not marked internal are meant for libweston users. v2: talk about "list of enabled outputs".

[PATCH weston v2 01/14] libweston: untangle weston_compositor_remove_output doc

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen Trying to make it more readable. Things that happen in the same step are kept in the same paragraph. v2: talk about "list of enabled outputs" Signed-off-by: Pekka Paalanen --- libweston/compositor.c | 26

[PATCH weston v2 00/14] Output core cleanups

2017-07-24 Thread Pekka Paalanen
From: Pekka Paalanen Hi, this is the v2 of the series, only minor changes as listed in each patch plus rebase. While working on Weston core reactoring towards clone mode support: https://phabricator.freedesktop.org/T7727

RE: [PATCH weston 0/3] remove set_layer/surface_orientation APIs

2017-07-24 Thread Ucan, Emre (ADITG/ESB)
Hi Pekka, Genivi moved its wiki pages. This is the new link: https://at.projects.genivi.org/wiki/display/PROJ/Wayland+IVI+Extension+Design. We will send a patch to update this. Best regards Emre Ucan Engineering Software Base (ADITG/ESB) Tel. +49 5121 49 6937 > -Original Message- >

RE: [RFC weston 0/9] weston-debug protocol, API, and tool

2017-07-24 Thread Ucan, Emre (ADITG/ESB)
Hello Pekka, Honestly speaking, I did not have time to evaluate it yet. Because I was on vacation. I am planning to start this week. Hopefully, I can reply to you next week. Best regards Emre Ucan Engineering Software Base (ADITG/ESB) Tel. +49 5121 49 6937 > -Original Message- >

RE: [PATCH weston v3] ivi-shell: add_screen_remove_layer API

2017-07-24 Thread Ucan, Emre (ADITG/ESB)
Hi Pekka, We will implement a test for the API. No Problem. Best regards Emre Ucan Engineering Software Base (ADITG/ESB) Tel. +49 5121 49 6937 > -Original Message- > From: Pekka Paalanen [mailto:ppaala...@gmail.com] > Sent: Montag, 24. Juli 2017 12:40 > To: Ucan, Emre (ADITG/ESB) >

Re: [RFC weston 0/9] weston-debug protocol, API, and tool

2017-07-24 Thread Pekka Paalanen
On Fri, 9 Jun 2017 18:32:25 +0300 Pekka Paalanen wrote: > On Fri, 9 Jun 2017 14:10:56 + > "Ucan, Emre (ADITG/ESB)" wrote: > > > Hi Pekka, > > > > I like your idea with scope trees. I want to play around a little bit > > with the protocol next

Re: [PATCH weston 15/15] libweston: introduce weston_output_from_resource()

2017-07-24 Thread Pekka Paalanen
On Tue, 4 Apr 2017 22:19:55 +0200 Armin Krezović wrote: > On 04.04.2017 12:58, Pekka Paalanen wrote: > > From: Pekka Paalanen > > > > This is a simple wrapper for casting the user data of a wl_resource into > > a struct weston_output

Re: [PATCH weston 05/15] libweston: two more weston_output docs

2017-07-24 Thread Pekka Paalanen
On Tue, 4 Apr 2017 21:48:05 +0200 Armin Krezović wrote: > On 04.04.2017 12:58, Pekka Paalanen wrote: > > From: Pekka Paalanen > > > > Document two more functions of the weston_output API. > > > > Exported functions marked internal are

Re: [PATCH weston 04/15] libweston: let add/remove_output handle the lists

2017-07-24 Thread Pekka Paalanen
On Mon, 24 Jul 2017 16:08:49 +0300 Pekka Paalanen wrote: > On Fri, 7 Apr 2017 20:58:45 +0200 > Armin Krezović wrote: > > > On 04.04.2017 12:58, Pekka Paalanen wrote: > > > From: Pekka Paalanen > > > > > > A

Re: [PATCH weston 04/15] libweston: let add/remove_output handle the lists

2017-07-24 Thread Pekka Paalanen
On Fri, 7 Apr 2017 20:58:45 +0200 Armin Krezović wrote: > On 04.04.2017 12:58, Pekka Paalanen wrote: > > From: Pekka Paalanen > > > > A weston_output available to the compositor should always be either in > > the pending or the live

Re: [PATCH weston 2/2] compositor-drm: remove connector option

2017-07-24 Thread Pekka Paalanen
On Wed, 8 Mar 2017 15:43:18 + "Ucan, Emre (ADITG/SW1)" wrote: > Remove the option, because it is hard to use. > Drm connector ids are hard to reach for users, > and they can change when kernel or device tree > is modified. > > If someone wants to enable just one output

Re: [PATCH weston 1/2] Add option to disable unconfigured outputs

2017-07-24 Thread Pekka Paalanen
On Wed, 8 Mar 2017 15:43:17 + "Ucan, Emre (ADITG/SW1)" wrote: > In current implementation, there is no configuration > to disable unconfigured outputs. > > One can create an output section for a known output > in weston.ini file and set its mode to "off" to disable > a

Re: [PATCH wayland 3/3] tests: Add scanner symbol prefix test

2017-07-24 Thread Pekka Paalanen
On Mon, 3 Jul 2017 17:16:46 +0800 Jonas Ådahl wrote: > Test that it is possible to implement and use an interface with a > symbol prefix. > > Signed-off-by: Jonas Ådahl > --- > .gitignore| 5 ++ > Makefile.am

Re: [PATCH wayland 2/3] scanner: Allow adding a prefix to exported symbols

2017-07-24 Thread Pekka Paalanen
On Mon, 3 Jul 2017 17:16:45 +0800 Jonas Ådahl wrote: > Two different protocols may use interfaces with identical names. > Implementing support for both those protocols would result in symbol > clashes, as wayland-scanner generates symbols from the interface names. > > Make it

Re: [PATCH wayland 1/3] Pass input/output files as arguments to wayland-scanner

2017-07-24 Thread Pekka Paalanen
On Mon, 3 Jul 2017 17:16:44 +0800 Jonas Ådahl wrote: > When input/output files are passed as arguments to wayland-scanner, > instead of using stdin/stdout, warning and error messages will contain > the file name, together with line number, of the warning/error. Doing > this

Re: [PATCH weston 0/3] remove set_layer/surface_orientation APIs

2017-07-24 Thread Pekka Paalanen
On Fri, 3 Mar 2017 14:21:25 + "Ucan, Emre (ADITG/SW1)" wrote: > These APIs are used to rotate the contents of > application's buffer. But they are not needed > because an application can rotate its buffers > with set_buffer_transform request of > wl_surface interface. >

Re: [PATCH weston v3] ivi-shell: add_screen_remove_layer API

2017-07-24 Thread Pekka Paalanen
On Thu, 13 Apr 2017 17:15:51 +0200 Eugen Friedrich wrote: > 2017-03-02 9:47 GMT+01:00 Ucan, Emre (ADITG/SW1) : > > It is analagous to layer_remove_surface API. > > The API removes a layer from the render order > > of the screen. > > > > v3: > > add the