Title: [139991] trunk/Source/WebCore
Revision
139991
Author
commit-qu...@webkit.org
Date
2013-01-17 10:36:18 -0800 (Thu, 17 Jan 2013)

Log Message

Remove unnecessary public method TiledBackingStore::supportsAlpha()
https://bugs.webkit.org/show_bug.cgi?id=107067

Patch by Jae Hyun Park <jae.p...@company100.net> on 2013-01-17
Reviewed by Kentaro Hara.

This patch removes unnecessary public method TiledBackingStore::supportsAlpha()
because supportsAlpha() is never called from other classes.

No new tests, no change in behavior.

* platform/graphics/TiledBackingStore.cpp:
(WebCore::TiledBackingStore::setSupportsAlpha):
* platform/graphics/TiledBackingStore.h:
(TiledBackingStore):

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (139990 => 139991)


--- trunk/Source/WebCore/ChangeLog	2013-01-17 18:34:43 UTC (rev 139990)
+++ trunk/Source/WebCore/ChangeLog	2013-01-17 18:36:18 UTC (rev 139991)
@@ -1,3 +1,20 @@
+2013-01-17  Jae Hyun Park  <jae.p...@company100.net>
+
+        Remove unnecessary public method TiledBackingStore::supportsAlpha()
+        https://bugs.webkit.org/show_bug.cgi?id=107067
+
+        Reviewed by Kentaro Hara.
+
+        This patch removes unnecessary public method TiledBackingStore::supportsAlpha()
+        because supportsAlpha() is never called from other classes.
+
+        No new tests, no change in behavior.
+
+        * platform/graphics/TiledBackingStore.cpp:
+        (WebCore::TiledBackingStore::setSupportsAlpha):
+        * platform/graphics/TiledBackingStore.h:
+        (TiledBackingStore):
+
 2013-01-17  Peter Rybin  <peter.ry...@gmail.com>
 
         [V8] Remove a --es5_readonly flag from V8 initialization and address duplicated code

Modified: trunk/Source/WebCore/platform/graphics/TiledBackingStore.cpp (139990 => 139991)


--- trunk/Source/WebCore/platform/graphics/TiledBackingStore.cpp	2013-01-17 18:34:43 UTC (rev 139990)
+++ trunk/Source/WebCore/platform/graphics/TiledBackingStore.cpp	2013-01-17 18:36:18 UTC (rev 139991)
@@ -580,7 +580,7 @@
 
 void TiledBackingStore::setSupportsAlpha(bool a)
 {
-    if (a == supportsAlpha())
+    if (a == m_supportsAlpha)
         return;
     m_supportsAlpha = a;
     invalidate(m_rect);

Modified: trunk/Source/WebCore/platform/graphics/TiledBackingStore.h (139990 => 139991)


--- trunk/Source/WebCore/platform/graphics/TiledBackingStore.h	2013-01-17 18:34:43 UTC (rev 139990)
+++ trunk/Source/WebCore/platform/graphics/TiledBackingStore.h	2013-01-17 18:36:18 UTC (rev 139991)
@@ -79,7 +79,6 @@
     void removeAllNonVisibleTiles();
 
     void setSupportsAlpha(bool);
-    bool supportsAlpha() const { return m_supportsAlpha; }
 
 private:
     void startTileBufferUpdateTimer();
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to