Title: [142395] trunk
Revision
142395
Author
commit-qu...@webkit.org
Date
2013-02-10 03:23:23 -0800 (Sun, 10 Feb 2013)

Log Message

Rename ENABLE(GLIB_SUPPORT) to USE(GLIB)
https://bugs.webkit.org/show_bug.cgi?id=104266

Patch by Jae Hyun Park <jae.par...@gmail.com> on 2013-02-10
Reviewed by Philippe Normand.

Using USE(GLIB) instead of ENABLE(GLIB_SUPPORT) is more consistent with
the existing macro naming conventions.

>From Platform.h
USE() - use a particular third-party library or optional OS service
ENABLE() - turn on a specific feature of WebKit

.:

* Source/autotools/SetupAutoconfHeader.m4:
* Source/cmake/OptionsEfl.cmake:

Source/WebCore:

No new tests, no new functionality.

* WebCore.pri:

Source/WebKit/gtk:

* gyp/Configuration.gypi:

Source/WebKit/mac:

* WebView/WebView.mm:
(-[WebView _commonInitializationWithFrameName:groupName:]):
(-[WebView _close]):
* WebView/WebViewData.h:
* WebView/WebViewInternal.h:

Source/WTF:

* WTF.pri:
* wtf/Platform.h:
* wtf/gobject/GOwnPtr.cpp:
* wtf/gobject/GOwnPtr.h:
* wtf/gobject/GRefPtr.cpp:
* wtf/gobject/GRefPtr.h:

Modified Paths

Diff

Modified: trunk/ChangeLog (142394 => 142395)


--- trunk/ChangeLog	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/ChangeLog	2013-02-10 11:23:23 UTC (rev 142395)
@@ -1,3 +1,20 @@
+2013-02-10  Jae Hyun Park  <jae.par...@gmail.com>
+
+        Rename ENABLE(GLIB_SUPPORT) to USE(GLIB)
+        https://bugs.webkit.org/show_bug.cgi?id=104266
+
+        Reviewed by Philippe Normand.
+
+        Using USE(GLIB) instead of ENABLE(GLIB_SUPPORT) is more consistent with
+        the existing macro naming conventions.
+
+        From Platform.h
+        USE() - use a particular third-party library or optional OS service
+        ENABLE() - turn on a specific feature of WebKit
+
+        * Source/autotools/SetupAutoconfHeader.m4:
+        * Source/cmake/OptionsEfl.cmake:
+
 2013-02-09  Philippe Normand  <pnorm...@igalia.com>
 
         Unreviewed, another GTK+ build fix after r142343.

Modified: trunk/Source/WTF/ChangeLog (142394 => 142395)


--- trunk/Source/WTF/ChangeLog	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WTF/ChangeLog	2013-02-10 11:23:23 UTC (rev 142395)
@@ -1,3 +1,24 @@
+2013-02-10  Jae Hyun Park  <jae.par...@gmail.com>
+
+        Rename ENABLE(GLIB_SUPPORT) to USE(GLIB)
+        https://bugs.webkit.org/show_bug.cgi?id=104266
+
+        Reviewed by Philippe Normand.
+
+        Using USE(GLIB) instead of ENABLE(GLIB_SUPPORT) is more consistent with
+        the existing macro naming conventions.
+
+        From Platform.h
+        USE() - use a particular third-party library or optional OS service
+        ENABLE() - turn on a specific feature of WebKit
+
+        * WTF.pri:
+        * wtf/Platform.h:
+        * wtf/gobject/GOwnPtr.cpp:
+        * wtf/gobject/GOwnPtr.h:
+        * wtf/gobject/GRefPtr.cpp:
+        * wtf/gobject/GRefPtr.h:
+
 2013-02-08  Michael Saboff  <msab...@apple.com>
 
         ARM_NEON Inline Assembly for copyLCharsFromUCharSource() inefficient for aligned destinations

Modified: trunk/Source/WTF/WTF.pri (142394 => 142395)


--- trunk/Source/WTF/WTF.pri	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WTF/WTF.pri	2013-02-10 11:23:23 UTC (rev 142395)
@@ -21,7 +21,7 @@
 }
 
 linux-*:use?(GSTREAMER) {
-    DEFINES += ENABLE_GLIB_SUPPORT=1
+    DEFINES += WTF_USE_GLIB=1
     PKGCONFIG += glib-2.0 gio-2.0
 }
 

Modified: trunk/Source/WTF/wtf/Platform.h (142394 => 142395)


--- trunk/Source/WTF/wtf/Platform.h	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WTF/wtf/Platform.h	2013-02-10 11:23:23 UTC (rev 142395)
@@ -1121,7 +1121,7 @@
 #define ENABLE_THREADING_GENERIC 1
 #endif
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 #include <wtf/gobject/GTypedefs.h>
 #endif
 

Modified: trunk/Source/WTF/wtf/gobject/GOwnPtr.cpp (142394 => 142395)


--- trunk/Source/WTF/wtf/gobject/GOwnPtr.cpp	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WTF/wtf/gobject/GOwnPtr.cpp	2013-02-10 11:23:23 UTC (rev 142395)
@@ -19,7 +19,7 @@
 #include "config.h"
 #include "GOwnPtr.h"
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 
 #include <gio/gio.h>
 #include <glib.h>
@@ -68,4 +68,4 @@
 
 } // namespace WTF
 
-#endif // ENABLE(GLIB_SUPPORT)
+#endif // USE(GLIB)

Modified: trunk/Source/WTF/wtf/gobject/GOwnPtr.h (142394 => 142395)


--- trunk/Source/WTF/wtf/gobject/GOwnPtr.h	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WTF/wtf/gobject/GOwnPtr.h	2013-02-10 11:23:23 UTC (rev 142395)
@@ -22,7 +22,7 @@
 #ifndef GOwnPtr_h
 #define GOwnPtr_h
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 
 #include <algorithm>
 #include <wtf/Assertions.h>
@@ -138,7 +138,7 @@
 
 using WTF::GOwnPtr;
 
-#endif // ENABLE(GLIB_SUPPORT)
+#endif // USE(GLIB)
 
 #endif // GOwnPtr_h
 

Modified: trunk/Source/WTF/wtf/gobject/GRefPtr.cpp (142394 => 142395)


--- trunk/Source/WTF/wtf/gobject/GRefPtr.cpp	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WTF/wtf/gobject/GRefPtr.cpp	2013-02-10 11:23:23 UTC (rev 142395)
@@ -19,7 +19,7 @@
 #include "config.h"
 #include "GRefPtr.h"
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 
 #include <glib.h>
 
@@ -166,4 +166,4 @@
 
 } // namespace WTF
 
-#endif // ENABLE(GLIB_SUPPORT)
+#endif // USE(GLIB)

Modified: trunk/Source/WTF/wtf/gobject/GRefPtr.h (142394 => 142395)


--- trunk/Source/WTF/wtf/gobject/GRefPtr.h	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WTF/wtf/gobject/GRefPtr.h	2013-02-10 11:23:23 UTC (rev 142395)
@@ -23,7 +23,7 @@
 #ifndef WTF_GRefPtr_h
 #define WTF_GRefPtr_h
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 
 #include <wtf/AlwaysInline.h>
 #include <wtf/RefPtr.h>
@@ -233,6 +233,6 @@
 using WTF::GRefPtr;
 using WTF::adoptGRef;
 
-#endif // ENABLE(GLIB_SUPPORT)
+#endif // USE(GLIB)
 
 #endif // WTF_GRefPtr_h

Modified: trunk/Source/WebCore/ChangeLog (142394 => 142395)


--- trunk/Source/WebCore/ChangeLog	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WebCore/ChangeLog	2013-02-10 11:23:23 UTC (rev 142395)
@@ -1,3 +1,21 @@
+2013-02-10  Jae Hyun Park  <jae.par...@gmail.com>
+
+        Rename ENABLE(GLIB_SUPPORT) to USE(GLIB)
+        https://bugs.webkit.org/show_bug.cgi?id=104266
+
+        Reviewed by Philippe Normand.
+
+        Using USE(GLIB) instead of ENABLE(GLIB_SUPPORT) is more consistent with
+        the existing macro naming conventions.
+
+        From Platform.h
+        USE() - use a particular third-party library or optional OS service
+        ENABLE() - turn on a specific feature of WebKit
+
+        No new tests, no new functionality.
+
+        * WebCore.pri:
+
 2013-02-10  Zan Dobersek  <zdober...@igalia.com>
 
         [GTK] Build errors in TextureMapperShaderProgram.cpp when compiling with Clang

Modified: trunk/Source/WebCore/WebCore.pri (142394 => 142395)


--- trunk/Source/WebCore/WebCore.pri	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WebCore/WebCore.pri	2013-02-10 11:23:23 UTC (rev 142395)
@@ -169,7 +169,7 @@
 }
 
 use?(GSTREAMER) {
-    DEFINES += ENABLE_GLIB_SUPPORT=1
+    DEFINES += WTF_USE_GLIB=1
     PKGCONFIG += glib-2.0 gio-2.0 gstreamer-0.10 gstreamer-app-0.10 gstreamer-base-0.10 gstreamer-interfaces-0.10 gstreamer-pbutils-0.10 gstreamer-plugins-base-0.10 gstreamer-video-0.10
 }
 

Modified: trunk/Source/WebKit/gtk/ChangeLog (142394 => 142395)


--- trunk/Source/WebKit/gtk/ChangeLog	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WebKit/gtk/ChangeLog	2013-02-10 11:23:23 UTC (rev 142395)
@@ -1,3 +1,19 @@
+2013-02-10  Jae Hyun Park  <jae.par...@gmail.com>
+
+        Rename ENABLE(GLIB_SUPPORT) to USE(GLIB)
+        https://bugs.webkit.org/show_bug.cgi?id=104266
+
+        Reviewed by Philippe Normand.
+
+        Using USE(GLIB) instead of ENABLE(GLIB_SUPPORT) is more consistent with
+        the existing macro naming conventions.
+
+        From Platform.h
+        USE() - use a particular third-party library or optional OS service
+        ENABLE() - turn on a specific feature of WebKit
+
+        * gyp/Configuration.gypi:
+
 2013-02-08  Benjamin Poulain  <bpoul...@apple.com>
 
         Move workerThreadCount from TestRunner to WebCore Internals

Modified: trunk/Source/WebKit/gtk/gyp/Configuration.gypi (142394 => 142395)


--- trunk/Source/WebKit/gtk/gyp/Configuration.gypi	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WebKit/gtk/gyp/Configuration.gypi	2013-02-10 11:23:23 UTC (rev 142395)
@@ -5,7 +5,7 @@
     'library_version': '3.0',
     '_javascript_core_soname_version': '0.13.8',
     'default_defines': [
-      'ENABLE_GLIB_SUPPORT=1',
+      'WTF_USE_GLIB=1',
       'BUILDING_CAIRO__=1',
       'BUILDING_GTK__=1',
       'WTF_CHANGES',

Modified: trunk/Source/WebKit/mac/ChangeLog (142394 => 142395)


--- trunk/Source/WebKit/mac/ChangeLog	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WebKit/mac/ChangeLog	2013-02-10 11:23:23 UTC (rev 142395)
@@ -1,3 +1,23 @@
+2013-02-10  Jae Hyun Park  <jae.par...@gmail.com>
+
+        Rename ENABLE(GLIB_SUPPORT) to USE(GLIB)
+        https://bugs.webkit.org/show_bug.cgi?id=104266
+
+        Reviewed by Philippe Normand.
+
+        Using USE(GLIB) instead of ENABLE(GLIB_SUPPORT) is more consistent with
+        the existing macro naming conventions.
+
+        From Platform.h
+        USE() - use a particular third-party library or optional OS service
+        ENABLE() - turn on a specific feature of WebKit
+
+        * WebView/WebView.mm:
+        (-[WebView _commonInitializationWithFrameName:groupName:]):
+        (-[WebView _close]):
+        * WebView/WebViewData.h:
+        * WebView/WebViewInternal.h:
+
 2013-02-08  Benjamin Poulain  <bpoul...@apple.com>
 
         Move workerThreadCount from TestRunner to WebCore Internals

Modified: trunk/Source/WebKit/mac/WebView/WebView.mm (142394 => 142395)


--- trunk/Source/WebKit/mac/WebView/WebView.mm	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WebKit/mac/WebView/WebView.mm	2013-02-10 11:23:23 UTC (rev 142395)
@@ -200,7 +200,7 @@
 #import <WebKit/WebDashboardRegion.h>
 #endif
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 #import <glib.h>
 #endif
 
@@ -434,7 +434,7 @@
 + (void)_preflightSpellChecker;
 - (BOOL)_continuousCheckingAllowed;
 - (NSResponder *)_responderForResponderOperations;
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 - (void)_clearGlibLoopObserver;
 #endif
 @end
@@ -833,7 +833,7 @@
     if (!WebKitLinkedOnOrAfter(WEBKIT_FIRST_VERSION_WITHOUT_CONTENT_SNIFFING_FOR_FILE_URLS))
         ResourceHandle::forceContentSniffing();
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
     [self _scheduleGlibContextIterations];
 #endif
 
@@ -1148,7 +1148,7 @@
     }
 #endif
     
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
     [self _clearGlibLoopObserver];
 #endif
 
@@ -6205,7 +6205,7 @@
 #endif
 }
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 - (void)_clearGlibLoopObserver
 {
     if (!_private->glibRunLoopObserver)
@@ -6523,7 +6523,7 @@
 }
 #endif
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 
 static void glibContextIterationCallback(CFRunLoopObserverRef, CFRunLoopActivity, void*)
 {

Modified: trunk/Source/WebKit/mac/WebView/WebViewData.h (142394 => 142395)


--- trunk/Source/WebKit/mac/WebView/WebViewData.h	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WebKit/mac/WebView/WebViewData.h	2013-02-10 11:23:23 UTC (rev 142395)
@@ -188,7 +188,7 @@
     WebFullScreenController *newFullscreenController;
 #endif
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
     CFRunLoopObserverRef glibRunLoopObserver;
 #endif
     id<WebGeolocationProvider> _geolocationProvider;

Modified: trunk/Source/WebKit/mac/WebView/WebViewInternal.h (142394 => 142395)


--- trunk/Source/WebKit/mac/WebView/WebViewInternal.h	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/WebKit/mac/WebView/WebViewInternal.h	2013-02-10 11:23:23 UTC (rev 142395)
@@ -105,7 +105,7 @@
 - (void)_scheduleCompositingLayerFlush;
 #endif
 
-#if ENABLE(GLIB_SUPPORT)
+#if USE(GLIB)
 - (void)_scheduleGlibContextIterations;
 #endif
 

Modified: trunk/Source/autotools/SetupAutoconfHeader.m4 (142394 => 142395)


--- trunk/Source/autotools/SetupAutoconfHeader.m4	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/autotools/SetupAutoconfHeader.m4	2013-02-10 11:23:23 UTC (rev 142395)
@@ -1,5 +1,5 @@
 # Configuration flags that are used throughout WebKitGTK+.
-AC_DEFINE([ENABLE_GLIB_SUPPORT], [1], [ ])
+AC_DEFINE([WTF_USE_GLIB], [1], [ ])
 AC_DEFINE([WTF_USE_FREETYPE], [1], [ ])
 AC_DEFINE([WTF_USE_HARFBUZZ], [1], [ ])
 AC_DEFINE([WTF_USE_SOUP], [1], [ ])

Modified: trunk/Source/cmake/OptionsEfl.cmake (142394 => 142395)


--- trunk/Source/cmake/OptionsEfl.cmake	2013-02-10 10:44:48 UTC (rev 142394)
+++ trunk/Source/cmake/OptionsEfl.cmake	2013-02-10 11:23:23 UTC (rev 142395)
@@ -29,7 +29,7 @@
 
 set(WTF_USE_SOUP 1)
 
-add_definitions(-DENABLE_GLIB_SUPPORT=1)
+add_definitions(-DWTF_USE_GLIB=1)
 add_definitions(-DWTF_USE_SOUP=1)
 add_definitions(-DWTF_USE_PTHREADS=1)
 add_definitions(-DWTF_USE_ICU_UNICODE=1)
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to