Title: [145079] trunk/Source/WebCore
Revision
145079
Author
commit-qu...@webkit.org
Date
2013-03-07 07:54:34 -0800 (Thu, 07 Mar 2013)

Log Message

OpenGLShims: fix check for ANGLE GLES2 extensions
https://bugs.webkit.org/show_bug.cgi?id=111656

Patch by Sergio Correia <sergio.corr...@openbossa.org> on 2013-03-07
Reviewed by Simon Hausmann.

The check for ANGLE GLES2 extensions is currently being overriden
with checks for APPLE extensions in lookupOpenGLFunctionAddress().

No new tests. No user visible behavior changed.

* platform/graphics/OpenGLShims.cpp:
(WebCore::lookupOpenGLFunctionAddress):

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (145078 => 145079)


--- trunk/Source/WebCore/ChangeLog	2013-03-07 15:43:16 UTC (rev 145078)
+++ trunk/Source/WebCore/ChangeLog	2013-03-07 15:54:34 UTC (rev 145079)
@@ -1,3 +1,18 @@
+2013-03-07  Sergio Correia  <sergio.corr...@openbossa.org>
+
+        OpenGLShims: fix check for ANGLE GLES2 extensions
+        https://bugs.webkit.org/show_bug.cgi?id=111656
+
+        Reviewed by Simon Hausmann.
+
+        The check for ANGLE GLES2 extensions is currently being overriden
+        with checks for APPLE extensions in lookupOpenGLFunctionAddress().
+
+        No new tests. No user visible behavior changed.
+
+        * platform/graphics/OpenGLShims.cpp:
+        (WebCore::lookupOpenGLFunctionAddress):
+
 2013-03-07  David Kilzer  <ddkil...@apple.com>
 
         Rename visible_units.h to VisibleUnits.h in WebCore.vcxproj.filters

Modified: trunk/Source/WebCore/platform/graphics/OpenGLShims.cpp (145078 => 145079)


--- trunk/Source/WebCore/platform/graphics/OpenGLShims.cpp	2013-03-07 15:43:16 UTC (rev 145078)
+++ trunk/Source/WebCore/platform/graphics/OpenGLShims.cpp	2013-03-07 15:54:34 UTC (rev 145079)
@@ -84,6 +84,8 @@
     fullFunctionName = functionName;
     fullFunctionName.append("ANGLE");
     target = getProcAddress(fullFunctionName.utf8().data());
+    if (target)
+        return target;
 
     fullFunctionName = functionName;
     fullFunctionName.append("APPLE");
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to