Title: [192000] trunk/Source/_javascript_Core
Revision
192000
Author
mark....@apple.com
Date
2015-11-03 17:00:39 -0800 (Tue, 03 Nov 2015)

Log Message

Rename DFG's compileAdd to compileArithAdd.
https://bugs.webkit.org/show_bug.cgi?id=150866

Reviewed by Benjamin Poulain.

The function is only supposed to generate code to do arithmetic addition on
numeric types.  Naming it compileArithAdd() is more accurate, and is consistent
with the name of the node it emits code for (i.e. ArithAdd) as well as other
compiler functions for analogous operations e.g. compileArithSub.

* dfg/DFGSpeculativeJIT.cpp:
(JSC::DFG::SpeculativeJIT::compileInstanceOf):
(JSC::DFG::SpeculativeJIT::compileArithAdd):
(JSC::DFG::SpeculativeJIT::compileAdd): Deleted.
* dfg/DFGSpeculativeJIT.h:
* dfg/DFGSpeculativeJIT32_64.cpp:
(JSC::DFG::SpeculativeJIT::compile):
* dfg/DFGSpeculativeJIT64.cpp:
(JSC::DFG::SpeculativeJIT::compile):

Modified Paths

Diff

Modified: trunk/Source/_javascript_Core/ChangeLog (191999 => 192000)


--- trunk/Source/_javascript_Core/ChangeLog	2015-11-04 00:58:56 UTC (rev 191999)
+++ trunk/Source/_javascript_Core/ChangeLog	2015-11-04 01:00:39 UTC (rev 192000)
@@ -1,3 +1,25 @@
+2015-11-03  Mark Lam  <mark....@apple.com>
+
+        Rename DFG's compileAdd to compileArithAdd.
+        https://bugs.webkit.org/show_bug.cgi?id=150866
+
+        Reviewed by Benjamin Poulain.
+
+        The function is only supposed to generate code to do arithmetic addition on
+        numeric types.  Naming it compileArithAdd() is more accurate, and is consistent
+        with the name of the node it emits code for (i.e. ArithAdd) as well as other
+        compiler functions for analogous operations e.g. compileArithSub.
+
+        * dfg/DFGSpeculativeJIT.cpp:
+        (JSC::DFG::SpeculativeJIT::compileInstanceOf):
+        (JSC::DFG::SpeculativeJIT::compileArithAdd):
+        (JSC::DFG::SpeculativeJIT::compileAdd): Deleted.
+        * dfg/DFGSpeculativeJIT.h:
+        * dfg/DFGSpeculativeJIT32_64.cpp:
+        (JSC::DFG::SpeculativeJIT::compile):
+        * dfg/DFGSpeculativeJIT64.cpp:
+        (JSC::DFG::SpeculativeJIT::compile):
+
 2015-11-03  Joseph Pecoraro  <pecor...@apple.com>
 
         Web Inspector: Remove duplication among ScriptDebugServer subclasses

Modified: trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT.cpp (191999 => 192000)


--- trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT.cpp	2015-11-04 00:58:56 UTC (rev 191999)
+++ trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT.cpp	2015-11-04 01:00:39 UTC (rev 192000)
@@ -2782,7 +2782,7 @@
     blessedBooleanResult(scratchReg, node);
 }
 
-void SpeculativeJIT::compileAdd(Node* node)
+void SpeculativeJIT::compileArithAdd(Node* node)
 {
     switch (node->binaryUseKind()) {
     case Int32Use: {

Modified: trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT.h (191999 => 192000)


--- trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT.h	2015-11-04 00:58:56 UTC (rev 191999)
+++ trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT.h	2015-11-04 01:00:39 UTC (rev 192000)
@@ -2207,7 +2207,7 @@
     void compileValueToInt32(Node*);
     void compileUInt32ToNumber(Node*);
     void compileDoubleAsInt32(Node*);
-    void compileAdd(Node*);
+    void compileArithAdd(Node*);
     void compileMakeRope(Node*);
     void compileArithClz32(Node*);
     void compileArithSub(Node*);

Modified: trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT32_64.cpp (191999 => 192000)


--- trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT32_64.cpp	2015-11-04 00:58:56 UTC (rev 191999)
+++ trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT32_64.cpp	2015-11-04 01:00:39 UTC (rev 192000)
@@ -2191,7 +2191,7 @@
     }
 
     case ArithAdd:
-        compileAdd(node);
+        compileArithAdd(node);
         break;
 
     case ArithClz32:

Modified: trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT64.cpp (191999 => 192000)


--- trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT64.cpp	2015-11-04 00:58:56 UTC (rev 191999)
+++ trunk/Source/_javascript_Core/dfg/DFGSpeculativeJIT64.cpp	2015-11-04 01:00:39 UTC (rev 192000)
@@ -2318,7 +2318,7 @@
     }
 
     case ArithAdd:
-        compileAdd(node);
+        compileArithAdd(node);
         break;
 
     case ArithClz32:
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to