Title: [198756] trunk/Source/WebCore
Revision
198756
Author
toniki...@webkit.org
Date
2016-03-28 13:58:05 -0700 (Mon, 28 Mar 2016)

Log Message

Rename PlatformWheelEvent::isEndGesture to isEndOfMomentumScroll.
https://bugs.webkit.org/show_bug.cgi?id=155940

Reviewed by Simon Fraser.

No new tests needed.

The new name better reflects its purpose. Also it is a preparation to fix bug 155746.

* platform/PlatformWheelEvent.h:
(WebCore::PlatformWheelEvent::shouldResetLatching):
(WebCore::PlatformWheelEvent::isEndOfMomentumScroll: Renamed; Formally isEndGesture.
* platform/mac/ScrollAnimatorMac.mm:
(WebCore::gestureShouldBeginSnap):

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (198755 => 198756)


--- trunk/Source/WebCore/ChangeLog	2016-03-28 20:32:56 UTC (rev 198755)
+++ trunk/Source/WebCore/ChangeLog	2016-03-28 20:58:05 UTC (rev 198756)
@@ -1,3 +1,20 @@
+2016-03-28  Antonio Gomes  <toniki...@webkit.org>
+
+        Rename PlatformWheelEvent::isEndGesture to isEndOfMomentumScroll.
+        https://bugs.webkit.org/show_bug.cgi?id=155940
+
+        Reviewed by Simon Fraser.
+
+        No new tests needed.
+
+        The new name better reflects its purpose. Also it is a preparation to fix bug 155746.
+
+        * platform/PlatformWheelEvent.h:
+        (WebCore::PlatformWheelEvent::shouldResetLatching):
+        (WebCore::PlatformWheelEvent::isEndOfMomentumScroll: Renamed; Formally isEndGesture.
+        * platform/mac/ScrollAnimatorMac.mm:
+        (WebCore::gestureShouldBeginSnap):
+
 2016-03-28  Zalan Bujtas  <za...@apple.com>
 
         Setup cloned continuation renderer properly.

Modified: trunk/Source/WebCore/platform/PlatformWheelEvent.h (198755 => 198756)


--- trunk/Source/WebCore/platform/PlatformWheelEvent.h	2016-03-28 20:32:56 UTC (rev 198755)
+++ trunk/Source/WebCore/platform/PlatformWheelEvent.h	2016-03-28 20:58:05 UTC (rev 198756)
@@ -159,7 +159,7 @@
         bool useLatchedEventElement() const;
         bool shouldConsiderLatching() const;
         bool shouldResetLatching() const;
-        bool isEndGesture() const;
+        bool isEndOfMomentumScroll() const;
 #else
         bool useLatchedEventElement() const { return false; }
 #endif
@@ -203,10 +203,10 @@
     
     inline bool PlatformWheelEvent::shouldResetLatching() const
     {
-        return m_phase == PlatformWheelEventPhaseCancelled || m_phase == PlatformWheelEventPhaseMayBegin || isEndGesture();
+        return m_phase == PlatformWheelEventPhaseCancelled || m_phase == PlatformWheelEventPhaseMayBegin || isEndOfMomentumScroll();
     }
-    
-    inline bool PlatformWheelEvent::isEndGesture() const
+
+    inline bool PlatformWheelEvent::isEndOfMomentumScroll() const
     {
         return m_phase == PlatformWheelEventPhaseNone && m_momentumPhase == PlatformWheelEventPhaseEnded;
     }

Modified: trunk/Source/WebCore/platform/mac/ScrollAnimatorMac.mm (198755 => 198756)


--- trunk/Source/WebCore/platform/mac/ScrollAnimatorMac.mm	2016-03-28 20:32:56 UTC (rev 198755)
+++ trunk/Source/WebCore/platform/mac/ScrollAnimatorMac.mm	2016-03-28 20:58:05 UTC (rev 198756)
@@ -1180,7 +1180,7 @@
     if (!snapOffsets)
         return false;
     
-    if (wheelEvent.phase() != PlatformWheelEventPhaseEnded && !wheelEvent.isEndGesture())
+    if (wheelEvent.phase() != PlatformWheelEventPhaseEnded && !wheelEvent.isEndOfMomentumScroll())
         return false;
 
     return true;
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to