Diff
Modified: trunk/Source/WebCore/ChangeLog (270005 => 270006)
--- trunk/Source/WebCore/ChangeLog 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebCore/ChangeLog 2020-11-19 02:53:43 UTC (rev 270006)
@@ -1,5 +1,34 @@
2020-11-18 Wenson Hsieh <wenson_hs...@apple.com>
+ Rename MetaCommandSwitchTo to MetaCommandSwitchToItemBuffer
+ https://bugs.webkit.org/show_bug.cgi?id=219130
+
+ Reviewed by Tim Horton.
+
+ Rename MetaCommandSwitchTo to MetaCommandSwitchToItemBuffer. The new name helps to clarify that this item is
+ about changing or swapping between display list item buffers, rather than image buffers.
+
+ * platform/graphics/displaylists/DisplayList.cpp:
+ (WebCore::DisplayList::DisplayList::append):
+ * platform/graphics/displaylists/DisplayListItemBuffer.cpp:
+ (WebCore::DisplayList::ItemHandle::apply):
+ (WebCore::DisplayList::ItemHandle::destroy):
+ (WebCore::DisplayList::ItemHandle::copyTo const):
+ (WebCore::DisplayList::ItemBuffer::swapWritableBufferIfNeeded):
+ * platform/graphics/displaylists/DisplayListItemType.cpp:
+ (WebCore::DisplayList::sizeOfItemInBytes):
+ (WebCore::DisplayList::isDrawingItem):
+ (WebCore::DisplayList::isInlineItem):
+ * platform/graphics/displaylists/DisplayListItemType.h:
+ * platform/graphics/displaylists/DisplayListItems.cpp:
+ (WebCore::DisplayList::operator<<):
+ * platform/graphics/displaylists/DisplayListItems.h:
+ (WebCore::DisplayList::MetaCommandSwitchToItemBuffer::MetaCommandSwitchToItemBuffer):
+ (WebCore::DisplayList::MetaCommandSwitchTo::MetaCommandSwitchTo): Deleted.
+ (WebCore::DisplayList::MetaCommandSwitchTo::identifier const): Deleted.
+
+2020-11-18 Wenson Hsieh <wenson_hs...@apple.com>
+
[Concurrent display lists] Add a way for display lists to partially replay
https://bugs.webkit.org/show_bug.cgi?id=219067
Modified: trunk/Source/WebCore/platform/graphics/displaylists/DisplayList.cpp (270005 => 270006)
--- trunk/Source/WebCore/platform/graphics/displaylists/DisplayList.cpp 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebCore/platform/graphics/displaylists/DisplayList.cpp 2020-11-19 02:53:43 UTC (rev 270006)
@@ -278,8 +278,8 @@
return append<FillEllipse>(item.get<FillEllipse>());
case ItemType::FlushContext:
return append<FlushContext>(item.get<FlushContext>());
- case ItemType::MetaCommandSwitchTo:
- return append<MetaCommandSwitchTo>(item.get<MetaCommandSwitchTo>());
+ case ItemType::MetaCommandSwitchToItemBuffer:
+ return append<MetaCommandSwitchToItemBuffer>(item.get<MetaCommandSwitchToItemBuffer>());
case ItemType::PutImageData:
return append<PutImageData>(item.get<PutImageData>());
case ItemType::PaintFrameForMedia:
Modified: trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemBuffer.cpp (270005 => 270006)
--- trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemBuffer.cpp 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemBuffer.cpp 2020-11-19 02:53:43 UTC (rev 270006)
@@ -226,7 +226,7 @@
get<FlushContext>().apply(context);
return;
}
- case ItemType::MetaCommandSwitchTo:
+ case ItemType::MetaCommandSwitchToItemBuffer:
return;
case ItemType::PutImageData: {
get<PutImageData>().apply(context);
@@ -454,8 +454,8 @@
static_assert(std::is_trivially_destructible<FlushContext>::value);
return;
}
- case ItemType::MetaCommandSwitchTo: {
- static_assert(std::is_trivially_destructible<MetaCommandSwitchTo>::value);
+ case ItemType::MetaCommandSwitchToItemBuffer: {
+ static_assert(std::is_trivially_destructible<MetaCommandSwitchToItemBuffer>::value);
return;
}
case ItemType::PaintFrameForMedia: {
@@ -705,8 +705,8 @@
new (itemOffset) FlushContext(get<FlushContext>());
return;
}
- case ItemType::MetaCommandSwitchTo: {
- new (itemOffset) MetaCommandSwitchTo(get<MetaCommandSwitchTo>());
+ case ItemType::MetaCommandSwitchToItemBuffer: {
+ new (itemOffset) MetaCommandSwitchToItemBuffer(get<MetaCommandSwitchToItemBuffer>());
return;
}
case ItemType::PaintFrameForMedia: {
@@ -860,7 +860,7 @@
void ItemBuffer::swapWritableBufferIfNeeded(size_t numberOfBytes)
{
- auto sizeForBufferSwitchItem = paddedSizeOfTypeAndItemInBytes(ItemType::MetaCommandSwitchTo);
+ auto sizeForBufferSwitchItem = paddedSizeOfTypeAndItemInBytes(ItemType::MetaCommandSwitchToItemBuffer);
if (m_writtenNumberOfBytes + numberOfBytes + sizeForBufferSwitchItem <= m_writableBuffer.capacity)
return;
@@ -867,7 +867,7 @@
auto nextBuffer = createItemBuffer(numberOfBytes + sizeForBufferSwitchItem);
bool hadPreviousBuffer = m_writableBuffer;
if (hadPreviousBuffer)
- uncheckedAppend<MetaCommandSwitchTo>(nextBuffer.identifier);
+ uncheckedAppend<MetaCommandSwitchToItemBuffer>(nextBuffer.identifier);
auto previousBuffer = std::exchange(m_writableBuffer, { });
previousBuffer.capacity = std::exchange(m_writtenNumberOfBytes, 0);
if (hadPreviousBuffer)
Modified: trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemType.cpp (270005 => 270006)
--- trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemType.cpp 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemType.cpp 2020-11-19 02:53:43 UTC (rev 270006)
@@ -126,8 +126,8 @@
return sizeof(FillEllipse);
case ItemType::FlushContext:
return sizeof(FlushContext);
- case ItemType::MetaCommandSwitchTo:
- return sizeof(MetaCommandSwitchTo);
+ case ItemType::MetaCommandSwitchToItemBuffer:
+ return sizeof(MetaCommandSwitchToItemBuffer);
case ItemType::PutImageData:
return sizeof(PutImageData);
case ItemType::PaintFrameForMedia:
@@ -180,7 +180,7 @@
case ItemType::ClipToDrawingCommands:
case ItemType::ConcatenateCTM:
case ItemType::FlushContext:
- case ItemType::MetaCommandSwitchTo:
+ case ItemType::MetaCommandSwitchToItemBuffer:
case ItemType::Restore:
case ItemType::Rotate:
case ItemType::Save:
@@ -291,7 +291,7 @@
#endif
case ItemType::FillRect:
case ItemType::FlushContext:
- case ItemType::MetaCommandSwitchTo:
+ case ItemType::MetaCommandSwitchToItemBuffer:
case ItemType::PaintFrameForMedia:
case ItemType::Restore:
case ItemType::Rotate:
Modified: trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemType.h (270005 => 270006)
--- trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemType.h 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItemType.h 2020-11-19 02:53:43 UTC (rev 270006)
@@ -76,7 +76,7 @@
FillPath,
FillEllipse,
FlushContext,
- MetaCommandSwitchTo,
+ MetaCommandSwitchToItemBuffer,
PutImageData,
PaintFrameForMedia,
StrokeRect,
Modified: trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItems.cpp (270005 => 270006)
--- trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItems.cpp 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItems.cpp 2020-11-19 02:53:43 UTC (rev 270006)
@@ -1002,7 +1002,7 @@
return ts;
}
-static TextStream& operator<<(TextStream& ts, const MetaCommandSwitchTo& item)
+static TextStream& operator<<(TextStream& ts, const MetaCommandSwitchToItemBuffer& item)
{
ts.dumpProperty("identifier", item.identifier());
return ts;
@@ -1057,7 +1057,7 @@
case ItemType::FillPath: ts << "fill-path"; break;
case ItemType::FillEllipse: ts << "fill-ellipse"; break;
case ItemType::FlushContext: ts << "flush-context"; break;
- case ItemType::MetaCommandSwitchTo: ts << "meta-command-switch-to"; break;
+ case ItemType::MetaCommandSwitchToItemBuffer: ts << "meta-command-switch-to-item-buffer"; break;
case ItemType::PutImageData: ts << "put-image-data"; break;
case ItemType::PaintFrameForMedia: ts << "paint-frame-for-media"; break;
case ItemType::StrokeRect: ts << "stroke-rect"; break;
@@ -1213,8 +1213,8 @@
case ItemType::FlushContext:
ts << item.get<FlushContext>();
break;
- case ItemType::MetaCommandSwitchTo:
- ts << item.get<MetaCommandSwitchTo>();
+ case ItemType::MetaCommandSwitchToItemBuffer:
+ ts << item.get<MetaCommandSwitchToItemBuffer>();
break;
case ItemType::PutImageData:
ts << item.get<PutImageData>();
Modified: trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItems.h (270005 => 270006)
--- trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItems.h 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebCore/platform/graphics/displaylists/DisplayListItems.h 2020-11-19 02:53:43 UTC (rev 270006)
@@ -2233,13 +2233,13 @@
// FIXME: This should be refactored so that the command to "switch to the next item buffer"
// is not itself a drawing item.
-class MetaCommandSwitchTo {
+class MetaCommandSwitchToItemBuffer {
public:
- static constexpr ItemType itemType = ItemType::MetaCommandSwitchTo;
+ static constexpr ItemType itemType = ItemType::MetaCommandSwitchToItemBuffer;
static constexpr bool isInlineItem = true;
static constexpr bool isDrawingItem = false;
- MetaCommandSwitchTo(ItemBufferIdentifier identifier)
+ MetaCommandSwitchToItemBuffer(ItemBufferIdentifier identifier)
: m_identifier(identifier)
{
}
@@ -2307,7 +2307,7 @@
WebCore::DisplayList::ItemType::FillPath,
WebCore::DisplayList::ItemType::FillEllipse,
WebCore::DisplayList::ItemType::FlushContext,
- WebCore::DisplayList::ItemType::MetaCommandSwitchTo,
+ WebCore::DisplayList::ItemType::MetaCommandSwitchToItemBuffer,
WebCore::DisplayList::ItemType::PutImageData,
WebCore::DisplayList::ItemType::PaintFrameForMedia,
WebCore::DisplayList::ItemType::StrokeRect,
Modified: trunk/Source/WebKit/ChangeLog (270005 => 270006)
--- trunk/Source/WebKit/ChangeLog 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebKit/ChangeLog 2020-11-19 02:53:43 UTC (rev 270006)
@@ -1,5 +1,17 @@
2020-11-18 Wenson Hsieh <wenson_hs...@apple.com>
+ Rename MetaCommandSwitchTo to MetaCommandSwitchToItemBuffer
+ https://bugs.webkit.org/show_bug.cgi?id=219130
+
+ Reviewed by Tim Horton.
+
+ * GPUProcess/graphics/RemoteImageBuffer.h:
+ * GPUProcess/graphics/RemoteRenderingBackend.cpp:
+ (WebKit::RemoteRenderingBackend::decodeItem):
+ * WebProcess/GPU/graphics/RemoteImageBufferProxy.h:
+
+2020-11-18 Wenson Hsieh <wenson_hs...@apple.com>
+
[Concurrent display lists] Add a way for display lists to partially replay
https://bugs.webkit.org/show_bug.cgi?id=219067
Modified: trunk/Source/WebKit/GPUProcess/graphics/RemoteImageBuffer.h (270005 => 270006)
--- trunk/Source/WebKit/GPUProcess/graphics/RemoteImageBuffer.h 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebKit/GPUProcess/graphics/RemoteImageBuffer.h 2020-11-19 02:53:43 UTC (rev 270006)
@@ -92,8 +92,8 @@
return true;
}
- if (item.is<WebCore::DisplayList::MetaCommandSwitchTo>()) {
- auto nextBufferIdentifier = item.get<WebCore::DisplayList::MetaCommandSwitchTo>().identifier();
+ if (item.is<WebCore::DisplayList::MetaCommandSwitchToItemBuffer>()) {
+ auto nextBufferIdentifier = item.get<WebCore::DisplayList::MetaCommandSwitchToItemBuffer>().identifier();
m_remoteRenderingBackend.setNextItemBufferToRead(nextBufferIdentifier);
return true;
}
Modified: trunk/Source/WebKit/GPUProcess/graphics/RemoteRenderingBackend.cpp (270005 => 270006)
--- trunk/Source/WebKit/GPUProcess/graphics/RemoteRenderingBackend.cpp 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebKit/GPUProcess/graphics/RemoteRenderingBackend.cpp 2020-11-19 02:53:43 UTC (rev 270006)
@@ -315,7 +315,7 @@
#endif
case DisplayList::ItemType::FillRect:
case DisplayList::ItemType::FlushContext:
- case DisplayList::ItemType::MetaCommandSwitchTo:
+ case DisplayList::ItemType::MetaCommandSwitchToItemBuffer:
case DisplayList::ItemType::PaintFrameForMedia:
case DisplayList::ItemType::Restore:
case DisplayList::ItemType::Rotate:
Modified: trunk/Source/WebKit/WebProcess/GPU/graphics/RemoteImageBufferProxy.h (270005 => 270006)
--- trunk/Source/WebKit/WebProcess/GPU/graphics/RemoteImageBufferProxy.h 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Source/WebKit/WebProcess/GPU/graphics/RemoteImageBufferProxy.h 2020-11-19 02:53:43 UTC (rev 270006)
@@ -305,7 +305,7 @@
#endif
case WebCore::DisplayList::ItemType::FillRect:
case WebCore::DisplayList::ItemType::FlushContext:
- case WebCore::DisplayList::ItemType::MetaCommandSwitchTo:
+ case WebCore::DisplayList::ItemType::MetaCommandSwitchToItemBuffer:
case WebCore::DisplayList::ItemType::PaintFrameForMedia:
case WebCore::DisplayList::ItemType::Restore:
case WebCore::DisplayList::ItemType::Rotate:
Modified: trunk/Tools/ChangeLog (270005 => 270006)
--- trunk/Tools/ChangeLog 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Tools/ChangeLog 2020-11-19 02:53:43 UTC (rev 270006)
@@ -1,3 +1,13 @@
+2020-11-18 Wenson Hsieh <wenson_hs...@apple.com>
+
+ Rename MetaCommandSwitchTo to MetaCommandSwitchToItemBuffer
+ https://bugs.webkit.org/show_bug.cgi?id=219130
+
+ Reviewed by Tim Horton.
+
+ * TestWebKitAPI/Tests/WebCore/DisplayListTests.cpp:
+ (TestWebKitAPI::TEST):
+
2020-11-18 Jonathan Bedard <jbed...@apple.com>
[webitscmpy] Branch point incorrect for Git checkouts
Modified: trunk/Tools/TestWebKitAPI/Tests/WebCore/DisplayListTests.cpp (270005 => 270006)
--- trunk/Tools/TestWebKitAPI/Tests/WebCore/DisplayListTests.cpp 2020-11-19 02:32:56 UTC (rev 270005)
+++ trunk/Tools/TestWebKitAPI/Tests/WebCore/DisplayListTests.cpp 2020-11-19 02:53:43 UTC (rev 270006)
@@ -121,7 +121,7 @@
break;
}
#endif
- case ItemType::MetaCommandSwitchTo:
+ case ItemType::MetaCommandSwitchToItemBuffer:
break;
default: {
observedUnexpectedItem = true;