Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-15 Thread Hajime Morrita
One concern is that Platform is too generic to put in global namespace and it might conflict existing symbols from platform SDK or something. But because we already have generic names like ASSERT() and it works, this concern is just a theoretical thing. So if it works with existing platforms, I

[webkit-dev] JavaScriptCore and ES6

2011-12-15 Thread Andy Wingo
Hello all, As you probably know, the ECMA TC39 committee is slowly approaching consensus on a new revision of the ECMAScript language. The interim results of this process have gone under various names: Harmony, ES.next, and ES6. They are the same thing. This mail is intended to open the

Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-15 Thread Joe Mason
The BlackBerry port uses BlackBerry::Platform for its system libraries - it wouldn't surprise me if some of our files in the platform dirs have using BlackBerry so they can just use Platform::symbol instead of BlackBerry::Platform::symbol in the source. Shouldn't be hard to sort out, though.

Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-15 Thread Darin Adler
The namespace name Platform is OK. I’m concerned that this is over-use of namespace and will make WebCore code overall harder to read. One of the notable features of the classes in the platform directory is that they fit in smoothly and are easy to use in WebCore. Being in the same namespace

[webkit-dev] Is Harmony a new WebKit project?

2011-12-15 Thread Darin Adler
I see some work in JavaScriptCore on something named Harmony. Is adding this a WebKit project? If so, then I’d like to see the customary webkit-dev message announcing the new project so we can discuss it. -- Darin ___ webkit-dev mailing list

Re: [webkit-dev] Is Harmony a new WebKit project?

2011-12-15 Thread Peter Beverloo
An e-mail was sent to webkit-dev about this four hours ago, titled: [webkit-dev] JavaScriptCore and ES6 Peter On Thu, Dec 15, 2011 at 16:24, Darin Adler da...@apple.com wrote: I see some work in JavaScriptCore on something named Harmony. Is adding this a WebKit project? If so, then I’d like

[webkit-dev] How to use ASSERT_NO_EXCEPTION

2011-12-15 Thread Darin Adler
Here’s my first draft of a note about ASSERT_NO_EXCEPTION. We might want to add this to the WebCore website; not sure. Many core DOM functions in classes in WebCore serve a dual purpose. They are used to implement DOM API that can be called from JavaScript. This often means that they will

Re: [webkit-dev] How to use ASSERT_NO_EXCEPTION

2011-12-15 Thread Joe Mason
-Original Message- From: webkit-dev-boun...@lists.webkit.org [mailto:webkit-dev- boun...@lists.webkit.org] On Behalf Of Darin Adler Sent: Thursday, December 15, 2011 11:37 AM To: WebKit Development Subject: [webkit-dev] How to use ASSERT_NO_EXCEPTION Those same functions are often

Re: [webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

2011-12-15 Thread Adam Barth
On Thu, Dec 15, 2011 at 8:22 AM, Darin Adler da...@apple.com wrote: The namespace name Platform is OK. I’m concerned that this is over-use of namespace and will make WebCore code overall harder to read. One of the notable features of the classes in the platform directory is that they fit in

Re: [webkit-dev] JavaScriptCore and ES6

2011-12-15 Thread Adam Barth
The versioning issues in ECMAScript are tough. We ran into these same problems when we were working with TC39 to formulate a versioning plan for what became ES5. None of the alternatives are really that great, but you likely need to pick one to make progress. I would caution you about adding

Re: [webkit-dev] How to use ASSERT_NO_EXCEPTION

2011-12-15 Thread Antti Koivisto
On Thu, Dec 15, 2011 at 8:36 AM, Darin Adler da...@apple.com wrote: ExceptionCode ec; appendChild(newChild, ec); ASSERT(!ec); Often code like this indicates misuse of DOM API functions for internal purposes. This is inefficient (due to exception related checking and other spec

Re: [webkit-dev] JavaScriptCore and ES6

2011-12-15 Thread Andy Wingo
On Thu, 2011-12-15 at 10:36 -0800, Adam Barth wrote: I would caution you about adding more modes to ECMAScript. I agree. You probably know this, but I just realized that my original mail could have implied that I'm on TC39, which is not the case. Just making that particular point clear. :)

Re: [webkit-dev] JavaScriptCore and ES6

2011-12-15 Thread Brendan Eich
As you probably know, the ECMA TC39 committee is slowly approaching consensus on a new revision of the ECMAScript language. The interim results of this process have gone under various names: Harmony, ES.next, and ES6. They are the same thing. Hi Andy, one nit to pick: Harmony is the full

[webkit-dev] sheriffbot needs a kick

2011-12-15 Thread Kenneth Russell
The sheriffbot has been failing to handle rollout commands for a few days now. The failures reported are: sheriffbot: Exception executing command: Failed to run ['Tools/Scripts/update-webkit'] exit_code: 9 Looks to me like the workspace on the machine running sheriffbot needs to be blown away.

Re: [webkit-dev] sheriffbot needs a kick

2011-12-15 Thread Adam Barth
I'll take a look. Sorry for the disruption. Adam On Thu, Dec 15, 2011 at 4:24 PM, Kenneth Russell k...@google.com wrote: The sheriffbot has been failing to handle rollout commands for a few days now. The failures reported are: sheriffbot: Exception executing command: Failed to run

Re: [webkit-dev] sheriffbot needs a kick

2011-12-15 Thread Adam Barth
I believe this is cleared up now. In the future, you can send sheriffbot the restart command, which can often clear up these sorts of issues: sheriffbot: restart I've just now made that command beefier so that it should be able to fix more problems. Adam On Thu, Dec 15, 2011 at 4:26 PM, Adam

Re: [webkit-dev] sheriffbot needs a kick

2011-12-15 Thread Kenneth Russell
Great, thanks. I vaguely recall seeing somebody restart it on IRC but it seemed to not fix this particular problem. BTW, thanks for writing and maintaining it; it's a very useful tool as evidenced by how many people were trying and failing to use it recently. :) -Ken On Thu, Dec 15, 2011 at

Re: [webkit-dev] sheriffbot needs a kick

2011-12-15 Thread Adam Barth
Yes, before the changes I made just now, the restart command wasn't powerful enough to clear out the problem. Hopefully the new beefier restart will work better in the future. (Mostly I mentioned the restart command so that more folks would know about it and give it a try when they run into