Re: remove check on previous child in MarkupContainer#replace

2007-04-01 Thread Eelco Hillenius
It makes sense when you look at a component as a holder of a set of components. However, I don't think put makes much sense when you think about building a component tree. Technically, put may be right, but I would say it's a little bit late in the game to change add to put isn't it? And personal

Re: remove check on previous child in MarkupContainer#replace

2007-04-01 Thread Martijn Dashorst
To join in on the 3 letter lingo [1]: put() would be more accurate, as it resembles the contract for a Set. Martijn [1] http://en.wikipedia.org/wiki/Lingo_(game_show) -- Learn Wicket at ApacheCon Europe: http://apachecon.com Join the wicket community at irc.freenode.net: ##wicket Wicket 1.2.5 w

Re: remove check on previous child in MarkupContainer#replace

2007-03-31 Thread Igor Vaynberg
then it would be more of a set() :) -igor On 3/31/07, Johan Compagner <[EMAIL PROTECTED]> wrote: if it was me just add() and should just replace if there is already one with that id if not then add. (and don't throw an error) thats how 2.0 really worked. (and for example Swing also) johan

Re: remove check on previous child in MarkupContainer#replace

2007-03-31 Thread Johan Compagner
if it was me just add() and should just replace if there is already one with that id if not then add. (and don't throw an error) thats how 2.0 really worked. (and for example Swing also) johan On 4/1/07, Igor Vaynberg <[EMAIL PROTECTED]> wrote: should actually be called addOrReplace() :) -

Re: remove check on previous child in MarkupContainer#replace

2007-03-31 Thread Igor Vaynberg
should actually be called addOrReplace() :) -igor On 3/31/07, Matej Knopp <[EMAIL PROTECTED]> wrote: I'm fine with either too. -Matej On 3/31/07, Eelco Hillenius <[EMAIL PROTECTED]> wrote: > That's an idea too. It's an extra method (not so nice) but more pricise (nice). > > I'm fine with ei

Re: remove check on previous child in MarkupContainer#replace

2007-03-31 Thread Matej Knopp
I'm fine with either too. -Matej On 3/31/07, Eelco Hillenius <[EMAIL PROTECTED]> wrote: That's an idea too. It's an extra method (not so nice) but more pricise (nice). I'm fine with either. What do others think? Eelco On 3/31/07, Igor Vaynberg <[EMAIL PROTECTED]> wrote: > or add a replaceOr

Re: remove check on previous child in MarkupContainer#replace

2007-03-31 Thread Eelco Hillenius
That's an idea too. It's an extra method (not so nice) but more pricise (nice). I'm fine with either. What do others think? Eelco On 3/31/07, Igor Vaynberg <[EMAIL PROTECTED]> wrote: or add a replaceOrAdd() method -igor On 3/31/07, Eelco Hillenius <[EMAIL PROTECTED]> wrote: > > I'm backpor

Re: remove check on previous child in MarkupContainer#replace

2007-03-31 Thread Igor Vaynberg
or add a replaceOrAdd() method -igor On 3/31/07, Eelco Hillenius <[EMAIL PROTECTED]> wrote: I'm backporting Wicket In Action's code currently, and stumbled upon something I really liked to be able to do in 2.0 which I can't do in the same way in 1.3. Consider this: void setContentPanel()

remove check on previous child in MarkupContainer#replace

2007-03-31 Thread Eelco Hillenius
I'm backporting Wicket In Action's code currently, and stumbled upon something I really liked to be able to do in 2.0 which I can't do in the same way in 1.3. Consider this: void setContentPanel() { if (inEditMode) { new DiscountsEditList(this, "content"); } else { new Discounts