Re: [crypt32] CryptProtectData/CryptUnprotectData helper functions

2005-05-18 Thread Dimi Paun
On Wed, 2005-05-18 at 22:57 +0100, Mike Hearn wrote: > > if (TRACE_ON(crypt)) > MESSAGE("foo\n"); There's no reason to use this, ever. Just use the regular FIXME/ERR/WARN/TRACE() as appropriate. -- Dimi Paun <[EMAIL PROTECTED]> Lattica, Inc.

Re: [crypt32] CryptProtectData/CryptUnprotectData helper functions

2005-05-18 Thread Mike Hearn
On Wed, 18 May 2005 13:34:39 -0700, Kees Cook wrote: > Ah-ha, yeah. I should use MESSAGE for that. It's only going to appear > if peopl have already turned on trace/warn, or immediately following a > FIXME that includes a path. I just want to use it for the readability > of the structure. Ac

Re: [crypt32] CryptProtectData/CryptUnprotectData helper functions

2005-05-18 Thread Alexandre Julliard
Kees Cook <[EMAIL PROTECTED]> writes: > FIXME is sane for the "announce_bad_opaque_data", but I'd still like to > use something that doesn't prefix the hexdumps with the function name > for easier readability in the crypt_report_func_input, since there is > already a TRACE/FIXME call being made pr

Re: [crypt32] CryptProtectData/CryptUnprotectData helper functions

2005-05-18 Thread Kees Cook
On Wed, May 18, 2005 at 12:29:58PM -0700, Kees Cook wrote: > Take two. Ignore... this patch is broken, and I need to do an update of wine_dbg_printf() -> MESSAGE() -- Kees Cook@outflux.net

Re: [crypt32] CryptProtectData/CryptUnprotectData helper functions

2005-05-18 Thread Kees Cook
On Wed, May 18, 2005 at 08:44:17PM +0100, Mike Hearn wrote: > It's usually OK to use MESSAGE for that, but if it's a message users might > be seeing often it's best to keep it as a WARN or TRACE. Ah-ha, yeah. I should use MESSAGE for that. It's only going to appear if peopl have already turned

Re: [crypt32] CryptProtectData/CryptUnprotectData helper functions

2005-05-18 Thread Mike Hearn
On Wed, 18 May 2005 12:08:35 -0700, Kees Cook wrote: > FIXME is sane for the "announce_bad_opaque_data", but I'd still like to > use something that doesn't prefix the hexdumps with the function name > for easier readability in the crypt_report_func_input, since there is > already a TRACE/FIXME call

Re: [crypt32] CryptProtectData/CryptUnprotectData helper functions

2005-05-18 Thread Kees Cook
On Wed, May 18, 2005 at 07:31:03PM +0200, Alexandre Julliard wrote: > > +wine_dbg_printf("%s\n",report); > > You should use wine_dbg_sprintf here and return a string. Okay. > > +static > > +void serialize_dword(DWORD value,BYTE ** ptr) > > +{ > > +/*TRACE("called\n");*/ > > + > > +*(

Re: [crypt32] CryptProtectData/CryptUnprotectData helper functions

2005-05-18 Thread Alexandre Julliard
Kees Cook <[EMAIL PROTECTED]> writes: > +static int > +hexprint(const char *s, unsigned char *p, int n) > +{ > +char report[80]; > +int r=-1; > +snprintf(report,16,"%14s:", s); > +while (--n >= 0) > +{ > +if (r++ % 20 == 19) > +{ > +wine_dbg_printf("