Re: [PATCH] Basic WINGs theming

2013-11-08 Thread Christophe
- Douglas Torrance dtorra...@monmouthcollege.edu a écrit : On 11/05/2013 05:58 PM, Christophe wrote: Although I do like the idea brought by the patch, there are a few things in this implementation that I would suggest to do differently: Absolutely! I'm a mathematician, not a

[PATCH 0/6] Changed libXpm detection to follow other formats

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr Hello, This series of patch take care of the last image format detection that were previously changed for GIF, PNG, ... It also proposes a little bit of cleanup around this which I let you judge. Regards, Christophe. configure.ac

[PATCH 4/6] wrlib: Use a Conditional for XPM in the makefile instead of #if in source

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr Now that the builtin XPM loading is separated from the saving code, the use of the conditionals provided by autotools provides a better result as it avoids unnecessary compilation. Signed-off-by: Christophe CURIS christophe.cu...@free.fr ---

[PATCH 3/6] wrlib: separated the code to save to XPM from the builtin XPM loading

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr Big files are harder to work with, so split load and save, which happen to already be independent anyway. Signed-off-by: Christophe CURIS christophe.cu...@free.fr --- wrlib/Makefile.am | 1 + wrlib/nxpm.c | 232

[PATCH 1/6] wrlib: Moved configure's detection of XPM support to a dedicated macro

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr The original check was not compliant with autoconf's syntax, did not have a very good behaviour for user and was not easy to make evolve. The new macro: - uses as much as possible autoconf macros for portability and code consistency; - provides a

[PATCH 5/6] wrlib: Marked args as unused for compiler

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr The two functions require an argument which is used when the libXpm is used, which means having the same argument list for the builtin code to be permutable. This patch adds the appropriate stuff to avoid a false report from the compiler.

RE: [PATCH] Basic WINGs theming

2013-11-08 Thread Torrance, Douglas
From: Christophe [mailto:christophe.cu...@free.fr] [snip] Thanks, Christophe! I really appreciate all the comments and ideas. I hope to submit a new version of the patch with lots of improvements in the next week or so. Doug

[PATCH 0/5] New macro to replace sizeof(array)/sizeof(array[0])

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr Hello, This series of patch introduces a new macro 'wlengthof' to make the code more concise, and thus easier to read (and thus, to maintain). Regards, Christophe. WINGs/WINGs/WUtil.h| 31 +++

[PATCH 2/5] WINGs: Use the macro 'wlengthof' to get the number of element in an array

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr The new macro 'wlengthof' from WUtil makes code easier to read than the previous [sizeof() / sizeof([0]) ] construct. Signed-off-by: Christophe CURIS christophe.cu...@free.fr --- WINGs/menuparser.c| 2 +- WINGs/menuparser_macros.c | 2 +-

[PATCH 1/5] WUtil: New macro 'wlengthof' in the public API to get number of elements in an array

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr The new macro 'wlengthof' returns the number of elements for which a local array have been defined, which makes code easier to read than the previous [sizeof() / sizeof([0]) ] construct. The macro includes a static assertion to stop compilation if

[PATCH 3/5] wmaker: Use the macro 'wlengthof' to get the number of element in an array

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr The new macro 'wlengthof' from WUtil makes code easier to read than the previous [sizeof() / sizeof([0]) ] construct. Signed-off-by: Christophe CURIS christophe.cu...@free.fr --- src/defaults.c | 8 src/startup.c| 6 +++---

[PATCH 5/5] util: Use the macro 'wlengthof' to get the number of element in an array

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr The new macro 'wlengthof' from WUtil makes code easier to read than the previous [sizeof() / sizeof([0]) ] construct. Signed-off-by: Christophe CURIS christophe.cu...@free.fr --- util/fontconv.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH 4/5] WPrefs: Use the macro 'wlengthof' to get the number of element in an array

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr The new macro 'wlengthof' from WUtil makes code easier to read than the previous [sizeof() / sizeof([0]) ] construct. Signed-off-by: Christophe CURIS christophe.cu...@free.fr --- WPrefs.app/Appearance.c| 2 +- WPrefs.app/Expert.c

[PATCH 0/3] More updates for configure script

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr Hello, These patchs are minor updates aiming at having a better configure script. Christophe. configure.ac | 21 +++-- m4/wm_prog_cc_c11.m4 | 48 2 files changed, 67

[PATCH 3/3] configure: Added a check to try to enable STD C11 if possible

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr Some compiler support C11 standard by default, some need an explicit option, and some don't support at all; this new macro only tries to enable support if possible, the actual feature support being done by other checks on case-by-case

[PATCH 1/3] configure: Less intrusive CFLAGS change when --enable-debug is chosen

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr The previous code made a dumb change to CFLAGS which would cause user supplied CFLAGS to be ignored, and possible compiler compatibility issues. The new code does the same changes in a smoother way, so we do not totally drop user specified or

[PATCH 2/3] configure: Do not keep assertion if debug was not enabled

2013-11-08 Thread Christophe
From: Christophe CURIS christophe.cu...@free.fr Signed-off-by: Christophe CURIS christophe.cu...@free.fr --- configure.ac | 4 1 file changed, 4 insertions(+) diff --git a/configure.ac b/configure.ac index 0415bbc..8f65979 100644 --- a/configure.ac +++ b/configure.ac @@ -95,6 +95,10 @@