[Xen-devel] [PATCH v7 15/16] tools: implement new generic set value interface and MBA set value command

2017-10-13 Thread Yi Sun
This patch implements new generic set value interfaces in libxc and libxl. These interfaces are suitable for all allocation features. It also adds a new MBA set value command in xl. Signed-off-by: Yi Sun Reviewed-by: Roger Pau Monné Acked-by: Wei

[Xen-devel] [PATCH v7 14/16] tools: implement new generic get value interface and MBA get value command

2017-10-13 Thread Yi Sun
This patch implements generic get value interfaces in libxc and libxl. It also refactors the get value flow in xl to make it be suitable for all allocation features. Based on that, a new MBA get value command is added in xl. Signed-off-by: Yi Sun Acked-by: Wei Liu

[Xen-devel] [PATCH v7 09/16] tools: create general interfaces to support psr allocation features

2017-10-13 Thread Yi Sun
This patch creates general interfaces in libxl to support all psr allocation features. Add 'LIBXL_HAVE_PSR_GENERIC' to indicate interface change. Please note, the functionality cannot work until later patches are applied. Signed-off-by: Yi Sun Reviewed-by: Roger Pau

[Xen-devel] [PATCH v7 10/16] tools: implement the new libxc get hw info interface

2017-10-13 Thread Yi Sun
This patch implements a new libxc get hw info interface and corresponding data structures. It also changes libxl_psr.c to call this new interface. Signed-off-by: Yi Sun Reviewed-by: Roger Pau Monné Acked-by: Wei Liu --- CC:

Re: [Xen-devel] [PATCH 3/3] x86/dom0: simplify dom0_compute_nr_pages

2017-10-13 Thread Jan Beulich
>>> On 29.09.17 at 13:25, wrote: > Remove the loop in dom0_compute_nr_pages. > > This is a non-functional change for PV domains, that would always have > need_paging set to false, and thus only did a single loop iteration. > > For a PVH Dom0 the loop is not needed anymore,

[Xen-devel] [PATCH v7 04/16] x86: a few optimizations to psr codes

2017-10-13 Thread Yi Sun
This patch refines psr codes: 1. Change type of 'cat_init_feature' to 'bool' to remove the pointless returning of error code. 2. Move printk in 'cat_init_feature' to reduce a return path. 3. Define a local variable 'feat_mask' in 'psr_cpu_init' to reduce calling of 'cpuid_count_leaf()'. 4.

[Xen-devel] [PATCH v7 11/16] tools: implement the new libxl get hw info interface

2017-10-13 Thread Yi Sun
This patch implements the new libxl get hw info interface, 'libxl_psr_get_hw_info', which is suitable to all psr allocation features. It also implements corresponding list free function, 'libxl_psr_hw_info_list_free' and makes 'libxl_psr_cat_get_info' call 'libxl_psr_get_hw_info' to avoid

[Xen-devel] [PATCH v7 05/16] x86: implement data structure and CPU init flow for MBA

2017-10-13 Thread Yi Sun
This patch implements main data structures of MBA. Like CAT features, MBA HW info has cos_max which means the max thrtl register number, and thrtl_max which means the max throttle value (delay value). It also has a flag to represent if the throttle value is linear or non-linear. One thrtl

[Xen-devel] [PATCH v7 12/16] tools: implement the new xl get hw info interface

2017-10-13 Thread Yi Sun
This patch implements a new xl get HW info interface. A new argument is added for psr-hwinfo command to get and show MBA HW info. Signed-off-by: Yi Sun Reviewed-by: Roger Pau Monné Acked-by: Wei Liu --- CC: Wei Liu

[Xen-devel] [PATCH v7 03/16] x86: rename 'cbm_type' to 'psr_type' to make it general

2017-10-13 Thread Yi Sun
This patch renames 'cbm_type' to 'psr_type' to generalize it. Then, we can reuse this for all psr allocation features. Signed-off-by: Yi Sun Reviewed-by: Wei Liu Reviewed-by: Roger Pau Monné Acked-by: Jan Beulich

[Xen-devel] [PATCH v7 00/16] Enable Memory Bandwidth Allocation in Xen

2017-10-13 Thread Yi Sun
Hi, all, We plan to bring a new PSR (Platform Shared Resource) feature called Intel Memory Bandwidth Allocation (MBA) to Xen. Besides the MBA enabling, we change some interfaces to make them more general but not only for CAT. Any comments are welcome! You can find this series at:

[Xen-devel] [PATCH v7 02/16] Rename PSR sysctl/domctl interfaces and xsm policy to make them be general

2017-10-13 Thread Yi Sun
This patch renames PSR sysctl/domctl interfaces and related xsm policy to make them be general for all resource allocation features but not only for CAT. Then, we can resuse the interfaces for all allocation features. Basically, it changes 'psr_cat_op' to 'psr_alloc', and remove 'CAT_' from some

Re: [Xen-devel] [PATCH 3/8] xen: defer call to xen_restrict until just before os_setup_post

2017-10-13 Thread Andrew Cooper
On 13/10/2017 09:37, Ross Lagerwall wrote: > On 10/09/2017 05:01 PM, Ian Jackson wrote: >> We need to restrict *all* the control fds that qemu opens.  Looking in >> /proc/PID/fd shows there are many; their allocation seems scattered >> throughout Xen support code in qemu. >> >> We must postpone

[Xen-devel] [PATCH for-4.10] fuzz/x86_emulate: Fix afl-harness batch mode file pointer leak

2017-10-13 Thread George Dunlap
Changeset introduced "batch mode" to afl-harness, which allowed the handling of several inputs in sequence. Unfortunately, it introduced a file pointer leak when the file was larger than the maximum size. Restructure the code to always close fp if we opened it. Signed-off-by: George Dunlap

Re: [Xen-devel] [PATCH 2/3] x86/pvh: use max_pdx to calculate the paging memory usage

2017-10-13 Thread Jan Beulich
>>> On 13.10.17 at 10:49, wrote: On 29.09.17 at 13:25, wrote: >> nr_pages doesn't take into account holes or MMIO regions, and >> underestimates the amount of memory needed for paging. Be on the safe >> side and use max_pdx instead. >> >> Note that

Re: [Xen-devel] [PATCH 2/3] x86/pvh: use max_pdx to calculate the paging memory usage

2017-10-13 Thread Jan Beulich
>>> On 29.09.17 at 13:25, wrote: > nr_pages doesn't take into account holes or MMIO regions, and > underestimates the amount of memory needed for paging. Be on the safe > side and use max_pdx instead. > > Note that both cases are just approximations, but using max_pdx

[Xen-devel] [qemu-upstream-unstable test] 114400: regressions - FAIL

2017-10-13 Thread osstest service owner
flight 114400 qemu-upstream-unstable real [real] http://logs.test-lab.xenproject.org/osstest/logs/114400/ Regressions :-( Tests which did not succeed and are blocking, including tests which could not be run: test-armhf-armhf-xl-cubietruckbroken in 114327

Re: [Xen-devel] [Qemu-devel] [RFC QEMU PATCH v3 00/10] Implement vNVDIMM for Xen HVM guest

2017-10-13 Thread Igor Mammedov
On Fri, 13 Oct 2017 15:53:26 +0800 Haozhong Zhang wrote: > On 10/12/17 17:45 +0200, Paolo Bonzini wrote: > > On 12/10/2017 14:45, Haozhong Zhang wrote: > > > Basically, QEMU builds two ROMs for guest, /rom@etc/acpi/tables and > > > /rom@etc/table-loader. The former is

Re: [Xen-devel] [PATCH 1/3] x86/dom0: use dom0_paging_pages to account for the memory used by IOMMU pt

2017-10-13 Thread Jan Beulich
>>> On 29.09.17 at 13:25, wrote: > Instead of open coding a calculation for it. But how well do the two calculation results match up? In particular I doubt the IOMMU page table reservation needs is vCPU count dependent. > --- a/xen/arch/x86/dom0_build.c > +++

Re: [Xen-devel] [PATCH 3/8] xen: defer call to xen_restrict until just before os_setup_post

2017-10-13 Thread Ross Lagerwall
On 10/09/2017 05:01 PM, Ian Jackson wrote: We need to restrict *all* the control fds that qemu opens. Looking in /proc/PID/fd shows there are many; their allocation seems scattered throughout Xen support code in qemu. We must postpone the restrict call until roughly the same time as qemu

Re: [Xen-devel] [PATCH] x86/vpt: fix a bug in pt_update_irq()

2017-10-13 Thread Jan Beulich
>>> On 09.10.17 at 23:32, wrote: First of all - please use a better subject. If someone finds another bug in this function in, say, half a year's time, how will we tell apart the two patches from looking at just the list of titles several years later? > pt_update_irq() is

[Xen-devel] [distros-debian-jessie test] 72232: tolerable trouble: blocked/broken/pass

2017-10-13 Thread Platform Team regression test user
flight 72232 distros-debian-jessie real [real] http://osstest.xs.citrite.net/~osstest/testlogs/logs/72232/ Failures :-/ but no regressions. Tests which did not succeed, but are not blocking: test-arm64-arm64-armhf-jessie-netboot-pygrub 1 build-check(1) blocked n/a build-arm64-pvops

Re: [Xen-devel] [Xen-users] UEFI Secure Boot Xen 4.9

2017-10-13 Thread Daniel Kiper
On Thu, Oct 12, 2017 at 05:03:13PM +, Bill Jacobs (billjac) wrote: > Hi > What is the status of creating a shim to abstract secure boot > signing for Xen (to leverage MSFT 3rd party, e.g)? xen.efi works with shim itself out of the box. If you wish to use shim and GRUB2 to load Xen you have to

Re: [Xen-devel] [Qemu-devel] [RFC QEMU PATCH v3 00/10] Implement vNVDIMM for Xen HVM guest

2017-10-13 Thread Haozhong Zhang
On 10/12/17 13:39 -0400, Konrad Rzeszutek Wilk wrote: > On Thu, Oct 12, 2017 at 08:45:44PM +0800, Haozhong Zhang wrote: > > On 10/10/17 12:05 -0400, Konrad Rzeszutek Wilk wrote: > > > On Tue, Sep 12, 2017 at 11:15:09AM +0800, Haozhong Zhang wrote: > > > > On 09/11/17 11:52 -0700, Stefano

Re: [Xen-devel] [Qemu-devel] [RFC QEMU PATCH v3 00/10] Implement vNVDIMM for Xen HVM guest

2017-10-13 Thread Haozhong Zhang
On 10/12/17 17:45 +0200, Paolo Bonzini wrote: > On 12/10/2017 14:45, Haozhong Zhang wrote: > > Basically, QEMU builds two ROMs for guest, /rom@etc/acpi/tables and > > /rom@etc/table-loader. The former is unstructured to guest, and > > contains all data of guest ACPI. The latter is a

Re: [Xen-devel] [PATCH 2/2] x86/boot: rename send_chr to print_err

2017-10-13 Thread Jan Beulich
>>> On 12.10.17 at 22:56, wrote: > On 12/10/2017 21:50, Doug Goldstein wrote: >> From: David Esler >> >> The send_chr function sends an entire C-string and not one character and >> doesn't necessarily just send it over the serial UART anymore so

Re: [Xen-devel] preparations for 4.9.1 and 4.7.4

2017-10-13 Thread Jan Beulich
>>> On 12.10.17 at 19:08, wrote: > for 4.9.1 the XSA status is > > XSA 226 : Some patches not applied => check > There is an extra chunk in the tree: see xsa226.png I see there are outdated patches for this XSA still in xsa.git, which I've now removed. I can't seem to be

Re: [Xen-devel] [PATCH v6 08/16] x86: implement set value flow for MBA

2017-10-13 Thread Jan Beulich
>>> On 13.10.17 at 04:02, wrote: > On 17-10-12 03:43:26, Jan Beulich wrote: >> >>> On 12.10.17 at 06:33, wrote: >> > On 17-10-11 07:38:52, Jan Beulich wrote: >> >> >>> On 08.10.17 at 09:23, wrote: >> >> > ---

Re: [Xen-devel] [PATCH for-next 2/3] xen/x86: Introduce static inline wrappers for l{idt, gdt, ldt, tr}()

2017-10-13 Thread Jan Beulich
>>> On 12.10.17 at 18:06, wrote: > On 12/10/17 16:53, Jan Beulich wrote: > On 02.10.17 at 18:13, wrote: >>> The triple-fault reboot method stays as is, to avoid the int3 possibly >>> getting >>> moved relative to the lidt. >> Aren't asm

[Xen-devel] [xen-4.8-testing test] 114384: FAIL

2017-10-13 Thread osstest service owner
flight 114384 xen-4.8-testing real [real] http://logs.test-lab.xenproject.org/osstest/logs/114384/ Failures and problems with tests :-( Tests which did not succeed and are blocking, including tests which could not be run: test-armhf-armhf-xl-multivcpu broken in 114313 Tests

Re: [Xen-devel] [alsa-devel] [PATCH RESEND1 00/12] ALSA: vsnd: Add Xen para-virtualized frontend driver

2017-10-13 Thread Oleksandr Andrushchenko
ping On 10/04/2017 09:50 AM, Oleksandr Andrushchenko wrote: gentle reminder On 09/26/2017 02:35 PM, Oleksandr Andrushchenko wrote: Clemens, Sakamoto-san, could you please review the below if you by chance have a minute? Thank you, Oleksandr On 09/19/2017 11:57 AM, Oleksandr Andrushchenko

[Xen-devel] [GIT PULL] xen: fixes for 4.14 rc5

2017-10-13 Thread Juergen Gross
Linus, Please git pull the following tag: git://git.kernel.org/pub/scm/linux/kernel/git/xen/tip.git for-linus-4.14c-rc5-tag xen: fixes for 4.14 rc5 It contains a minor fix correcting the cpu hotplug name for Xen guests. Thanks. Juergen arch/x86/xen/enlighten.c | 4 ++-- 1 file changed, 2

<    1   2