This patch series is an attempt to move (most) of the monitor vm-events code to
the common-side.

Patches summary:

1. Minor file-comment fix

2. Merge almost identical functions hvm_event_int3 + hvm_event_single_step ->
hvm_event_breakpoint.

3. Add Kconfigs:
    HAS_VM_EVENT_WRITE_CTRLREG, HAS_VM_EVENT_SINGLESTEP,
    HAS_VM_EVENT_SOFTWARE_BREAKPOINT, HAS_VM_EVENT_GUEST_REQUEST
and move monitor_domctl to common-side. Used the Kconfigs to selectively
activate implemented monitor vm-events code for each architecture.

4. Minor file renames. Read (*) below.

5. Move hvm_event_traps, hvm_event_cr, hvm_event_guest_request,
hvm_event_breakpoint functions to common-side. (note: arch_hvm_event_fill_regs
on ARM-side will be implemented in a separate patch)

6. Minor file renames + comment fixes. Read (*) below.

7. Move arch_domain.monitor bitfield members to struct domain (common-side).
   Moved bits: single-step, software-breakpoint and guest-request.
(note: write_ctrlreg_* were left on the arch-side, since control-registers
number can vary across architectures)

(*) was only necessary to avoid git seeing a file as being modified, rather than
moved (would have made the diff unnecessarily bulky).

---
Changed since v1:
  Major:
    * not moving arch/arm/hvm.c to arch/arm/hvm/hvm.c anymore
    * hvm_event_software_breakpoint renamed to hvm_event_breakpoint
    * hvm_event_breakpoint single_step param replaced by enum
  Minor:
    * formatting & comment fixes: e.g. removed blank lines around #if/#endif
    * improved code readability (used switch/case instead of if in some places)

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to