flight 55349 libvirt real [real] http://logs.test-lab.xenproject.org/osstest/logs/55349/
Regressions :-( Tests which did not succeed and are blocking, including tests which could not be run: test-amd64-amd64-libvirt 11 guest-start fail REGR. vs. 53854 Tests which did not succeed, but are not blocking: test-amd64-i386-libvirt-xsm 11 guest-start fail never pass test-amd64-amd64-libvirt-xsm 11 guest-start fail never pass test-armhf-armhf-libvirt-xsm 6 xen-boot fail never pass test-amd64-i386-libvirt 12 migrate-support-check fail never pass test-armhf-armhf-libvirt 12 migrate-support-check fail never pass version targeted for testing: libvirt e27c5c8fcb290abf89beebeadc541b81977ad839 baseline version: libvirt fd74e231751334b64af0934b680c5cc62f652453 ------------------------------------------------------------ People who touched revisions under test: Cole Robinson <crobi...@redhat.com> Ján Tomko <jto...@redhat.com> Laine Stump <la...@laine.org> Luyao Huang <lhu...@redhat.com> Peter Krempa <pkre...@redhat.com> Roman Bogorodskiy <bogorods...@gmail.com> ------------------------------------------------------------ jobs: build-amd64-xsm pass build-armhf-xsm pass build-i386-xsm pass build-amd64 pass build-armhf pass build-i386 pass build-amd64-libvirt pass build-armhf-libvirt pass build-i386-libvirt pass build-amd64-pvops pass build-armhf-pvops pass build-i386-pvops pass test-amd64-amd64-libvirt-xsm fail test-armhf-armhf-libvirt-xsm fail test-amd64-i386-libvirt-xsm fail test-amd64-amd64-libvirt fail test-armhf-armhf-libvirt pass test-amd64-i386-libvirt pass ------------------------------------------------------------ sg-report-flight on osstest.test-lab.xenproject.org logs: /home/osstest/pub/logs images: /home/osstest/pub/images Logs, config files, etc. are available at http://logs.test-lab.xenproject.org/osstest/logs Test harness code can be found at http://xenbits.xen.org/gitweb?p=osstest.git;a=summary Not pushing. ------------------------------------------------------------ commit e27c5c8fcb290abf89beebeadc541b81977ad839 Author: Laine Stump <la...@laine.org> Date: Thu Apr 30 12:51:51 2015 -0400 qemu: eliminate duplicated code in qemuBuildDriveDevStr() The code to add device type to the commandline was identical for lsi and other models of SCSI controllers, but was duplicated (with the exception of a minor ordering difference of the if-else clauses) for the two cases. This patch replaces those two with a single instance of the code just before the if(). commit da558e72c4999d21d279ff2ab15f0b2446436c46 Author: Laine Stump <la...@laine.org> Date: Wed Apr 29 12:23:02 2015 -0400 qemu: use qemuDomainMachineIsI440FX() in appropriate place This patch makes qemuValideDevicePCISlotsChipsets() more consistent in appearance by replacing several clauses of an if with the equivalent call to qemuDomainMachineIsI440FX. The if was checking exactly the same items, just in a slightly different order. commit 97e70a593589e8f0432a748b4b93c3cdc18b9e5a Author: Roman Bogorodskiy <bogorods...@gmail.com> Date: Sat May 9 19:06:36 2015 +0300 maint: extend PIE support check GCC installed from FreeBSD ports doesn't support building PIE executables and fails with: /usr/local/bin/ld: /usr/lib/crt1.o: relocation R_X86_64_32 against `_DYNAMIC' can not be used when making a shared object; recompile with -fPIC /usr/lib/crt1.o: error adding symbols: Bad value collect2: error: ld returned 1 exit status However, the configure check for '-fPIC -DPIC' doesn't catch that. In order to catch this case, add '-pie' to CFLAGS in m4/virt-compile-pie.m4 so it could detect lack of PIE support on configure time and don't fail the build. commit 846cc14c4d38169936a7165c4a4cb77b84d53bf6 Author: Roman Bogorodskiy <bogorods...@gmail.com> Date: Sat May 9 18:10:50 2015 +0300 bhyve: fix bhyvexml2argvtest build with gcc gcc5 reports an error like this: bhyvexml2argvtest.c: In function 'testCompareXMLToArgvFiles': bhyvexml2argvtest.c:24:18: error: variable 'vm' set but not used [-Werror=unused-but-set-variable] virDomainObj vm; ^ cc1: all warnings being treated as errors Fix by dropping this variable. commit c49b9032a212538ff28786d1b9922ebf549ea5ca Author: Luyao Huang <lhu...@redhat.com> Date: Mon May 11 20:59:37 2015 +0800 conf: Report error for unknown shmem ioeventfd value https://bugzilla.redhat.com/show_bug.cgi?id=1220265 Passing the return value to an enum directly is not safe. Fix this by comparing the true integer result of virTristateSwitchTypeFromString(). Signed-off-by: Luyao Huang <lhu...@redhat.com> commit 076dd379958ff55ef7e39d7f6a7a1c9efded2a77 Author: Ján Tomko <jto...@redhat.com> Date: Tue Apr 28 17:07:20 2015 +0200 Ignore bridge template names with multiple printf conversions For some reason, we allow a bridge name with %d in it, which we replace with an unsigned integer to form a bridge name that does not yet exist on the host. Do not blindly pass it to virAsprintf if it's not the only conversion, to prevent crashing on input like: <network> <name>test</name> <forward mode='none'/> <bridge name='virbr%d%s%s%s%s%s%s%s%s%s%s%s%s%s%s%s%s'/> </network> Ignore any template strings that do not have exactly one %d conversion, like we do in various drivers before calling virNetDevTapCreateInBridgePort. commit 2f37362e44400d91f51c9e147f71e98a4eca42c0 Author: Peter Krempa <pkre...@redhat.com> Date: Thu Apr 30 18:03:41 2015 +0200 qemu: Fix balloon size handling with memory hot(un)plug Since libvirt doesn't call to update the new balloon size in qemu add code that will handle tweaking of the size of the current balloon statistic until qemu reports the new size using the event. commit de03b1dddee50f3f9718f03102697e7066af7f64 Author: Peter Krempa <pkre...@redhat.com> Date: Thu Apr 30 17:43:53 2015 +0200 conf: Fix up balloon size after removing a memory device from def To avoid having the ballooned memory size larger than the actual physical memory size, truncate the ballooned size if it overflows. commit fccc2c331311422d89a6f87b64f82672bc3f3f75 Author: Peter Krempa <pkre...@redhat.com> Date: Thu Apr 30 17:33:41 2015 +0200 conf: Always truncate balloon size to maximum memory size Specifying a balloon size more than the memory size of a guest isn't something that should be rejected when parsing the XML. Truncate the size to the maximum memory size. commit 85d8ede9eb1da870e553f43dea215606ec47d190 Author: Peter Krempa <pkre...@redhat.com> Date: Wed Apr 29 16:41:20 2015 +0200 qemu: Convert qemuConnectGetAllDomainStats to use new helpers Use the new domain list collection helpers to avoid going through virDomainPtrs. This additionally implements filter capability when called through the api that accepts domain list filters. commit 83726a14d294c8cacf1e0decf5e55f84fba1c1c8 Author: Peter Krempa <pkre...@redhat.com> Date: Wed Apr 29 16:15:53 2015 +0200 conf: Add helper to convert list of virDomains to a list of virDomainObjs Add virDomainObjListConvert that will take a list of virDomains, apply filters and return a list of virDomainObjs. commit cbe7bbf722a4c5b276238d4cc50c2ac5d407f800 Author: Peter Krempa <pkre...@redhat.com> Date: Wed Apr 29 14:11:09 2015 +0200 conf: Refactor domain list collection critical section Until now the virDomainListAllDomains API would lock the domain list and then every single domain object to access and filter it. This would potentially allow a unresponsive VM to block the whole daemon if a *listAllDomains call would get stuck. To avoid this problem this patch collects a list of referenced domain objects first from the list and then unlocks it right away. The expensive operation requiring locking of the domain object is executed after the list lock is dropped. While a single blocked domain will still lock up a listAllDomains call, the domain list won't be held locked and thus other APIs won't be blocked. Additionally this patch also fixes the lookup code, where we'd ignore the vm->removing flag and thus potentially return domain objects that would be deleted very soon so calling any API wouldn't make sense. As other clients also could benefit from operating on a list of domain objects rather than the public domain descriptors a new intermediate API - virDomainObjListCollect - is introduced by this patch. Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1181074 commit 7906d5fbbba1229f10777f581f91a30063d48847 Author: Peter Krempa <pkre...@redhat.com> Date: Wed Apr 29 15:25:34 2015 +0200 conf: Rename virDomainObjListFilter type to virDomainObjListACLFilter The passed function is meant to filter domains according to ACL match. commit 684675c33b1a7c9322e2d6d5db8ba87b4d81bac4 Author: Peter Krempa <pkre...@redhat.com> Date: Wed Apr 29 13:18:37 2015 +0200 conf: Extract code to filter domain list into a separate function Separate the code to simplify future refactors. commit a5e89ae16e8098e9b77a98517f2d10a5d60e7737 Author: Peter Krempa <pkre...@redhat.com> Date: Wed Apr 29 11:54:58 2015 +0200 util: Make the virDomainListFree helper more universal Extend it to a universal helper used for clearing lists of any objects. Note that the argument type is specifically void * to allow implicit typecasting. Additionally add a helper that works on non-NULL terminated arrays once we know the length. commit 8910e063dbafc09695b2100c80213be569abb7ef Author: Cole Robinson <crobi...@redhat.com> Date: Wed May 6 18:32:05 2015 -0400 caps: Fix regression defaulting to host arch My commit 747761a79 (v1.2.15 only) dropped this bit of logic when filling in a default arch in the XML: - /* First try to find one matching host arch */ - for (i = 0; i < caps->nguests; i++) { - if (caps->guests[i]->ostype == ostype) { - for (j = 0; j < caps->guests[i]->arch.ndomains; j++) { - if (caps->guests[i]->arch.domains[j]->type == domain && - caps->guests[i]->arch.id == caps->host.arch) - return caps->guests[i]->arch.id; - } - } - } That attempt to match host.arch is important, otherwise we end up defaulting to i686 on x86_64 host for KVM, which is not intended. Duplicate it in the centralized CapsLookup function. Additionally add some testcases that would have caught this. https://bugzilla.redhat.com/show_bug.cgi?id=1219191
_______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org http://lists.xen.org/xen-devel