Re: [Xen-devel] [PATCH V5 1/9] block: add a helper function to read nr_setcs

2019-08-21 Thread Bart Van Assche
On 8/20/19 11:14 PM, Chaitanya Kulkarni wrote: This patch introduces helper function to read the number of sectors from struct block_device->bd_part member. For more details Please refer to the comment in the include/linux/genhd.h for part_nr_sects_read(). Reviewed-by: Minwoo Im Reviewed-by: Ma

Re: [Xen-devel] [PATCH V5 0/9] block: use right accessor to read nr_sects

2019-08-21 Thread Bart Van Assche
ent in the in include/linux/genhd.h which should be used to read the bdev->hd_part->nr_sects. For the entire series: Reviewed-by: Bart Van Assche ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/

Re: [Xen-devel] [PATCH V3 1/9] block: add a helper function to read nr_setcs

2019-07-03 Thread Bart Van Assche
On 7/2/19 10:42 AM, Chaitanya Kulkarni wrote: +/* Helper function to read the bdev->bd_part->nr_sects */ +static inline sector_t bdev_nr_sects(struct block_device *bdev) +{ + return part_nr_sects_read(bdev->bd_part); +} Is the comment above bdev_nr_sects() really useful or should it be le

Re: Report in downstream Debian: mpt3sas broken with xen dom0 with update to 5.10.149 in 5.10.y.

2022-10-22 Thread Bart Van Assche
On 10/21/22 02:22, Salvatore Bonaccorso wrote: We got the following report in Debian after an update from 5.10.140 to the current 5.10.149. Full quoting below (from https://bugs.debian.org/1022126). Does this ring some bell about known regressions? Only three mpt3sas changes are new in v5.10.14

Re: [PATCH 01/32] block: Provide blkdev_get_handle_* functions

2023-07-04 Thread Bart Van Assche
On 7/4/23 05:21, Jan Kara wrote: +struct bdev_handle { + struct block_device *bdev; + void *holder; +}; Please explain in the patch description why a holder pointer is introduced in struct bdev_handle and how it relates to the bd_holder pointer in struct block_device. Is one of th

Re: [PATCH 01/32] block: Provide blkdev_get_handle_* functions

2023-07-05 Thread Bart Van Assche
On 7/4/23 09:14, Matthew Wilcox wrote: On Tue, Jul 04, 2023 at 07:06:26AM -0700, Bart Van Assche wrote: On 7/4/23 05:21, Jan Kara wrote: +struct bdev_handle { + struct block_device *bdev; + void *holder; +}; Please explain in the patch description why a holder pointer is

Re: [PATCH 07/12] sd: factor out a sd_discard_mode helper

2024-05-29 Thread Bart Van Assche
On 5/28/24 22:04, Christoph Hellwig wrote: Split the logic to pick the right discard mode into a little helper to prepare for further changes. Reviewed-by: Bart Van Assche

Re: [PATCH 01/12] ubd: untagle discard vs write zeroes not support handling

2024-05-30 Thread Bart Van Assche
actually failed. Reviewed-by: Bart Van Assche

Re: [PATCH 02/12] block: take io_opt and io_min into account for max_sectors

2024-05-30 Thread Bart Van Assche
^^ rbd? user max_sectors value, so this is a bit of a behavior change that could use careful review from people familiar with rbd. Anyway: Reviewed-by: Bart Van Assche

Re: [PATCH 03/12] sd: simplify the ZBC case in provisioning_mode_store

2024-05-30 Thread Bart Van Assche
code has probably been around for far too long to change this now. If Damien's feedback gets addressed, feel free to add: Reviewed-by: Bart Van Assche

Re: [PATCH 04/12] sd: add a sd_disable_discard helper

2024-05-30 Thread Bart Van Assche
queue limits API. Reviewed-by: Bart Van Assche

Re: [PATCH 05/12] sd: add a sd_disable_write_same helper

2024-05-30 Thread Bart Van Assche
atomic queue limits API. Reviewed-by: Bart Van Assche

Re: [PATCH 06/12] sd: simplify the disable case in sd_config_discard

2024-05-30 Thread Bart Van Assche
On 5/28/24 22:04, Christoph Hellwig wrote: Fall through to the main call to blk_queue_max_discard_sectors given that max_blocks has been initialized to zero above instead of duplicating the call. Reviewed-by: Bart Van Assche

Re: [PATCH 08/12] sd: cleanup zoned queue limits initialization

2024-05-30 Thread Bart Van Assche
. Reviewed-by: Bart Van Assche

Re: [PATCH 11/12] block: remove unused queue limits API

2024-05-30 Thread Bart Van Assche
On 5/28/24 22:04, Christoph Hellwig wrote: Remove all APIs that are unused now that sd and sr have been converted to the atomic queue limits API. Reviewed-by: Bart Van Assche

Re: [PATCH 12/12] block: add special APIs for run-time disabling of discard and friends

2024-05-30 Thread Bart Van Assche
se the I/O completion handlers can't take sleeping locks or freezer the queue. Keep the existing clearing of the relevant field to zero, but replace the old blk_queue_max_* APIs with new disable APIs that force the value to 0. Reviewed-by: Bart Van Assche

Re: [PATCH 01/26] sd: fix sd_is_zoned

2024-06-11 Thread Bart Van Assche
On 6/10/24 10:19 PM, Christoph Hellwig wrote: Since commit 7437bb73f087 ("block: remove support for the host aware zone model"), only ZBC devices expose a zoned access model. sd_is_zoned is used to check for that and thus return false for host aware devices. Reviewed-by: Bart Van Assche

Re: [PATCH 03/26] loop: stop using loop_reconfigure_limits in __loop_clr_fd

2024-06-11 Thread Bart Van Assche
On 6/10/24 10:19 PM, Christoph Hellwig wrote: __loop_clr_fd wants to clear all settings on the device. Prepare for moving more settings into the block limits by open coding loop_reconfigure_limits. If Damien's comment is addressed, feel free to add: Reviewed-by: Bart Van Assche

Re: [PATCH 04/26] loop: always update discard settings in loop_reconfigure_limits

2024-06-11 Thread Bart Van Assche
On 6/10/24 10:19 PM, Christoph Hellwig wrote: Simplify loop_reconfigure_limits by always updating the discard limits. This adds a little more work to loop_set_block_size, but doesn't change the outcome as the discard flag won't change. Reviewed-by: Bart Van Assche

Re: [PATCH 05/26] loop: regularize upgrading the lock size for direct I/O

2024-06-11 Thread Bart Van Assche
-by: Bart Van Assche

Re: [PATCH 06/26] loop: also use the default block size from an underlying block device

2024-06-11 Thread Bart Van Assche
Van Assche

Re: [PATCH 07/26] loop: fold loop_update_rotational into loop_reconfigure_limits

2024-06-11 Thread Bart Van Assche
On 6/10/24 10:19 PM, Christoph Hellwig wrote: This prepares for moving the rotational flag into the queue_limits and also fixes it for the case where the loop device is backed by a block device. Reviewed-by: Bart Van Assche

Re: [PATCH 08/26] virtio_blk: remove virtblk_update_cache_mode

2024-06-11 Thread Bart Van Assche
On 6/10/24 10:19 PM, Christoph Hellwig wrote: virtblk_update_cache_mode boils down to a single call to blk_queue_write_cache. Remove it in preparation for moving the cache control flags into the queue_limits. Reviewed-by: Bart Van Assche

Re: [PATCH 09/26] nbd: move setting the cache control flags to __nbd_set_size

2024-06-11 Thread Bart Van Assche
On 6/10/24 10:19 PM, Christoph Hellwig wrote: Move setting the cache control flags in nbd in preparation for moving these flags into the queue_limits structure. Reviewed-by: Bart Van Assche

Re: [PATCH 11/26] block: freeze the queue in queue_attr_store

2024-06-11 Thread Bart Van Assche
On 6/10/24 10:19 PM, Christoph Hellwig wrote: queue_attr_store updates attributes used to control generating I/O, and can cause malformed bios if changed with I/O in flight. Freeze the queue in common code instead of adding it to almost every attribute. Reviewed-by: Bart Van Assche

Re: [PATCH 12/26] block: remove blk_flush_policy

2024-06-11 Thread Bart Van Assche
On 6/10/24 10:19 PM, Christoph Hellwig wrote: Fold blk_flush_policy into the only caller to prepare for pending changes to it. Reviewed-by: Bart Van Assche

Re: [PATCH -next RFC 01/14] block: add some bdev apis

2023-12-05 Thread Bart Van Assche
On 12/5/23 04:37, Yu Kuai wrote: +static inline u8 block_bits(struct block_device *bdev) +{ + return bdev->bd_inode->i_blkbits; +} This function needs a name that's more descriptive. Thanks, Bart.