Re: [PATCH 26/27] block: decouple REQ_OP_SECURE_ERASE from REQ_OP_DISCARD

2022-04-09 Thread Coly Li
. Petersen Acked-by: Christoph Böhmwalder [drbd] Acked-by: Ryusuke Konishi [nifs2] Acked-by: Coly Li [drbd] Hi Christoph, My ACK is for bcache, not drbd here. Thanks. Coly Li Acked-by: David Sterba [btrfs]

Re: [PATCH 22/27] block: refactor discard bio size limiting

2022-04-07 Thread Coly Li
On 4/6/22 2:05 PM, Christoph Hellwig wrote: Move all the logic to limit the discard bio size into a common helper so that it is better documented. Signed-off-by: Christoph Hellwig Acked-by: Coly Li Thanks for the change. Coly Li --- block/blk-lib.c | 59

Re: [PATCH 26/27] block: uncouple REQ_OP_SECURE_ERASE from REQ_OP_DISCARD

2022-04-07 Thread Coly Li
, Acked-by: Coly Li Thanks. Coly Li --- block/blk-core.c| 2 +- block/blk-lib.c | 64 - block/blk-mq-debugfs.c | 1 - block/blk-settings.c| 16 +++- block/fops.c

Re: [PATCH 25/27] block: remove QUEUE_FLAG_DISCARD

2022-04-06 Thread Coly Li
, even if the default stacking rules would allow for it. Signed-off-by: Christoph Hellwig For the bcache part, Acked-by: Coly Li Thanks. Coly Li --- arch/um/drivers/ubd_kern.c| 2 -- block/blk-mq-debugfs.c| 1 - drivers/block/drbd/drbd_nl.c | 15

Re: [PATCH 23/27] block: add a bdev_max_discard_sectors helper

2022-04-06 Thread Coly Li
is done e.g. for write zeroes as well. Signed-off-by: Christoph Hellwig For the bcache part, Acked-by: Coly Li Thanks. Coly Li --- block/blk-core.c| 2 +- block/blk-lib.c | 2 +- block/ioctl.c | 3 +-- drivers/block/drbd

Re: [PATCH 02/10] bcache: add error handling support for add_disk()

2021-08-29 Thread Coly Li
that tradition. Signed-off-by: Luis Chamberlain Acked-by: Coly Li Thanks. --- drivers/md/bcache/super.c | 17 - 1 file changed, 12 insertions(+), 5 deletions(-) diff --git a/drivers/md/bcache/super.c b/drivers/md/bcache/super.c index f2874c77ff79..f0c32cdd6594 100644 --- a/drivers

Re: [PATCH 13/45] block: add a bdev_kobj helper

2020-11-24 Thread Coly Li
On 11/24/20 9:27 PM, Christoph Hellwig wrote: > Add a little helper to find the kobject for a struct block_device. > > Signed-off-by: Christoph Hellwig > Reviewed-by: Greg Kroah-Hartman > Reviewed-by: Jan Kara > Reviewed-by: Johannes Thumshirn For the bcache part, Acked-by

Re: [PATCH 23/45] block: remove i_bdev

2020-11-24 Thread Coly Li
ra reference in the inode and can generally > simplify handling of struct block_device to keep the lookups contained > in the core block layer code. > > Signed-off-by: Christoph Hellwig For the bcache part, Acked-by: Coly Li Thanks. Coly Li > --- > block/ioctl.c

Re: [PATCH 30/45] block: remove the nr_sects field in struct hd_struct

2020-11-24 Thread Coly Li
for torn writes. By only using the block_device field > this problem also gets fixed. > > Signed-off-by: Christoph Hellwig > Reviewed-by: Greg Kroah-Hartman For the bcache part, Acked-by: Coly Li Thanks. Coly Li > --- > block/bio.c| 4 +- > blo

Re: [PATCH 38/45] block: switch partition lookup to use struct block_device

2020-11-24 Thread Coly Li
the bcache part, Acked-by: Coly Li > --- > block/bio.c| 4 +- > block/blk-core.c | 66 ++ > block/blk-flush.c | 2 +- > block/blk-mq.c | 9 ++-- > block/blk-mq.h

Re: [PATCH 19/20] bcache: remove a superflous lookup_bdev all

2020-11-18 Thread Coly Li
On 11/18/20 5:10 PM, Greg KH wrote: > On Wed, Nov 18, 2020 at 04:54:51PM +0800, Coly Li wrote: >> On 11/18/20 4:47 PM, Christoph Hellwig wrote: >>> Don't bother to call lookup_bdev for just a slightly different error >>> message without any functional change. >&

Re: [PATCH 19/20] bcache: remove a superflous lookup_bdev all

2020-11-18 Thread Coly Li
and observed, and distinct a busy device and an already registered device is important (the first one is critical error and second one is not). Remove such error message will be a functional regression. Coly Li > --- > drivers/md/bcache/super.c | 44 +-- > 1 file

Re: [PATCH RFC PKS/PMEM 48/58] drivers/md: Utilize new kmap_thread()

2020-10-12 Thread Coly Li
On 2020/10/12 13:28, Ira Weiny wrote: > On Sat, Oct 10, 2020 at 10:20:34AM +0800, Coly Li wrote: >> On 2020/10/10 03:50, ira.we...@intel.com wrote: >>> From: Ira Weiny >>> >>> These kmap() calls are localized to a single thread. To avoid the over >>

Re: [PATCH RFC PKS/PMEM 48/58] drivers/md: Utilize new kmap_thread()

2020-10-09 Thread Coly Li
ive to option 2) introduce a flag to kmap(), then we won't forget the new thread-localized kmap method, and people won't ask why a _thread() function is called but no kthread created. Thanks. Coly Li > Cc: Coly Li (maintainer:BCACHE (BLOCK LAYER CACHE)) > Cc: Kent Overstreet (maintainer:B

Re: [Xen-devel] [PATCH v3] block: refactor duplicated macros

2020-03-11 Thread Coly Li
with "PAGE_SECTORS_SHIFT" too > and rename SECTOR_MASK to PAGE_SECTORS_MASK. > > Signed-off-by: Matteo Croce Hi Matteo, For the bcache part, it looks good to me. Acked-by: Coly Li > --- > v3: > As Guoqing Jiang suggested, replace "PAGE_SHIFT - 9"