Re: [PATCH v2 4/4] bus: Make remove callback return void

2021-07-06 Thread Cornelia Huck
| 4 +--- > drivers/s390/cio/scm.c| 4 +--- > drivers/s390/crypto/ap_bus.c | 4 +--- > drivers/vfio/mdev/mdev_driver.c | 4 +--- For drivers/s390 and drivers/vfio: Reviewed-by: Cornelia Huck

Re: [PATCH] bus: Make remove callback return void

2021-07-06 Thread Cornelia Huck
On Tue, Jul 06 2021, Cornelia Huck wrote: > On Tue, Jul 06 2021, Uwe Kleine-König wrote: > >> The driver core ignores the return value of this callback because there >> is only little it can do when a device disappears. >> >> This is the final bit of a long lasti

Re: [PATCH] bus: Make remove callback return void

2021-07-06 Thread Cornelia Huck
On Tue, Jul 06 2021, Uwe Kleine-König wrote: > The driver core ignores the return value of this callback because there > is only little it can do when a device disappears. > > This is the final bit of a long lasting cleanup quest where several > buses were converted to also return void from their

Re: [PATCH v2 01/11] accel/kvm: Check MachineClass kvm_type() return value

2021-02-23 Thread Cornelia Huck
On Tue, 23 Feb 2021 10:37:01 +1100 David Gibson wrote: > On Tue, Feb 23, 2021 at 10:33:55AM +1100, David Gibson wrote: > > On Mon, Feb 22, 2021 at 06:50:44PM +0100, Cornelia Huck wrote: > > > On Mon, 22 Feb 2021 18:41:07 +0100 > > > Philippe Mathieu-Daudé wrote: &g

Re: [PATCH v2 02/11] hw/boards: Introduce machine_class_valid_for_accelerator()

2021-02-22 Thread Cornelia Huck
On Mon, 22 Feb 2021 18:46:15 +0100 Philippe Mathieu-Daudé wrote: > On 2/22/21 6:34 PM, Cornelia Huck wrote: > > On Fri, 19 Feb 2021 18:38:38 +0100 > > Philippe Mathieu-Daudé wrote: > > > >> Introduce the valid_accelerators[] field to express the list > >

Re: [PATCH v2 01/11] accel/kvm: Check MachineClass kvm_type() return value

2021-02-22 Thread Cornelia Huck
On Mon, 22 Feb 2021 18:41:07 +0100 Philippe Mathieu-Daudé wrote: > On 2/22/21 6:24 PM, Cornelia Huck wrote: > > On Fri, 19 Feb 2021 18:38:37 +0100 > > Philippe Mathieu-Daudé wrote: > > > >> MachineClass::kvm_type() can return -1 on failure. > >> D

Re: [PATCH v2 11/11] softmmu/vl: Exit gracefully when accelerator is not supported

2021-02-22 Thread Cornelia Huck
On Fri, 19 Feb 2021 18:38:47 +0100 Philippe Mathieu-Daudé wrote: > Before configuring an accelerator, check it is valid for > the current machine. Doing so we can return a simple error > message instead of criptic one. s/criptic/cryptic/ > > Before: > > $ qemu-system-arm -M raspi2b -enable-

Re: [PATCH v2 03/11] hw/core: Restrict 'query-machines' to those supported by current accel

2021-02-22 Thread Cornelia Huck
y_machines(Error **errp) > MachineClass *mc = el->data; > MachineInfo *info; > > +if (!machine_class_valid_for_current_accelerator(mc)) { > +continue; > +} > + > info = g_malloc0(sizeof(*info)); > if (mc

Re: [PATCH v2 07/11] hw/s390x: Explicit the s390-ccw-virtio machines support TCG and KVM

2021-02-22 Thread Cornelia Huck
PE_NAME("qemu"); > +mc->valid_accelerators = valid_accels; > hc->plug = s390_machine_device_plug; > hc->unplug_request = s390_machine_device_unplug_request; > nc->nmi_monitor_handler = s390_nmi; Reviewed-by: Cornelia Huck

Re: [PATCH v2 02/11] hw/boards: Introduce machine_class_valid_for_accelerator()

2021-02-22 Thread Cornelia Huck
On Fri, 19 Feb 2021 18:38:38 +0100 Philippe Mathieu-Daudé wrote: > Introduce the valid_accelerators[] field to express the list > of valid accelators a machine can use, and add the > machine_class_valid_for_current_accelerator() and > machine_class_valid_for_accelerator() methods. > > Signed-off

Re: [PATCH v2 01/11] accel/kvm: Check MachineClass kvm_type() return value

2021-02-22 Thread Cornelia Huck
On Fri, 19 Feb 2021 18:38:37 +0100 Philippe Mathieu-Daudé wrote: > MachineClass::kvm_type() can return -1 on failure. > Document it, and add a check in kvm_init(). > > Signed-off-by: Philippe Mathieu-Daudé > --- > include/hw/boards.h | 3 ++- > accel/kvm/kvm-all.c | 6 ++ > 2 files changed

Re: [PATCH v4 30/32] qdev: Rename qdev_get_prop_ptr() to object_field_prop_ptr()

2020-12-14 Thread Cornelia Huck
field_prop_ptr() instead of object_static_prop_ptr() > --- > Cc: Stefan Berger > Cc: Stefano Stabellini > Cc: Anthony Perard > Cc: Paul Durrant > Cc: Kevin Wolf > Cc: Max Reitz > Cc: Paolo Bonzini > Cc: "Daniel P. Berrangé" > Cc: Eduardo Habkost

Re: [PATCH v4 23/32] qdev: Move dev->realized check to qdev_property_set()

2020-12-14 Thread Cornelia Huck
> --- > Cc: Stefan Berger > Cc: Stefano Stabellini > Cc: Anthony Perard > Cc: Paul Durrant > Cc: Kevin Wolf > Cc: Max Reitz > Cc: Paolo Bonzini > Cc: "Daniel P. Berrangé" > Cc: Eduardo Habkost > Cc: Cornelia Huck > Cc: Halil Pasic >

Re: [PATCH v2 4/6] xen: Delete xen_available() function

2020-11-27 Thread Cornelia Huck
gt; Cc: Paul Durrant > Cc: xen-devel@lists.xenproject.org > Cc: Richard Henderson > Cc: Claudio Fontana > Cc: Roman Bolshakov > --- > include/sysemu/arch_init.h | 2 -- > softmmu/arch_init.c| 9 - > softmmu/vl.c | 6 +++--- > 3 files changed, 3 insertions(+), 14 deletions(-) Reviewed-by: Cornelia Huck

Re: [PATCH v3 09/53] qdev: Make qdev_get_prop_ptr() get Object* arg

2020-11-13 Thread Cornelia Huck
the liberty of keeping the Reviewed-by line from > Marc-André as the build fix is a trivial one line change > --- > Cc: Stefan Berger > Cc: Stefano Stabellini > Cc: Anthony Perard > Cc: Paul Durrant > Cc: Kevin Wolf > Cc: Max Reitz > Cc: Paolo Bonzini > Cc: "D

Re: [PATCH 6/7] qom: Add FIELD_PTR, a type-safe wrapper for object_field_prop_ptr()

2020-11-09 Thread Cornelia Huck
Berger > Cc: Stefano Stabellini > Cc: Anthony Perard > Cc: Paul Durrant > Cc: Kevin Wolf > Cc: Max Reitz > Cc: Paolo Bonzini > Cc: "Daniel P. Berrangé" > Cc: Eduardo Habkost > Cc: Cornelia Huck > Cc: Thomas Huth > Cc: Halil Pasic > Cc: Chri

Re: [PATCH 4/7] qom: Replace void* parameter with Property* on field getters/setters

2020-11-09 Thread Cornelia Huck
; --- > Cc: Stefan Berger > Cc: Stefano Stabellini > Cc: Anthony Perard > Cc: Paul Durrant > Cc: Kevin Wolf > Cc: Max Reitz > Cc: Paolo Bonzini > Cc: "Daniel P. Berrangé" > Cc: Eduardo Habkost > Cc: Richard Henderson > Cc: David Hildenbrand &g

Re: [PATCH 3/5] qom: Remove module_obj_name parameter from OBJECT_DECLARE* macros

2020-09-17 Thread Cornelia Huck
; UPPERCASE); > > Signed-off-by: Eduardo Habkost Acked-by: Cornelia Huck

Re: [PATCH-for-5.1 2/3] various: Remove unnecessary OBJECT() cast

2020-04-14 Thread Cornelia Huck
icroblaze/petalogix_ml605_mmu.c | 8 > hw/s390x/sclp.c | 2 +- > monitor/misc.c | 3 +-- > qom/object.c| 4 ++-- > 7 files changed, 11 insertions(+), 12 deletions(-) > s390x part: Acked-by: Cornelia Huck

Re: [Xen-devel] [PATCH v3 19/20] Let cpu_[physical]_memory() calls pass a boolean 'is_write' argument

2020-02-21 Thread Cornelia Huck
l_memory_map(addr, &len, true); > if (!sa) { > return -EFAULT; > } > @@ -298,7 +298,7 @@ int s390_store_adtl_status(S390CPU *cpu, hwaddr addr, > hwaddr len) > hwaddr save = len; > int i; > > -sa = cpu_physical_memory_map(addr, &save, 1); > +sa = cpu_physical_memory_map(addr, &save, true); > if (!sa) { > return -EFAULT; > } s390 parts Acked-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH v3 08/20] Remove unnecessary cast when using the address_space API

2020-02-21 Thread Cornelia Huck
390XState *env, > hwaddr gaddr, > * We treat them as absolute addresses and don't wrap them. > */ > if (unlikely(address_space_read(cs->as, gaddr, MEMTXATTRS_UNSPECIFIED, > - (uint8_t *)entry, sizeof(*entry)) != > +

Re: [Xen-devel] [RFC v5 026/126] python: add commit-per-subsystem.py

2019-11-12 Thread Cornelia Huck
On Fri, 11 Oct 2019 19:04:12 +0300 Vladimir Sementsov-Ogievskiy wrote: > Add script to automatically commit tree-wide changes per-subsystem. > > Signed-off-by: Vladimir Sementsov-Ogievskiy > --- I think this still needs some notes as to the supposed usage. ___

Re: [Xen-devel] [RFC v5 000/126] error: auto propagated local_err

2019-11-12 Thread Cornelia Huck
On Fri, 8 Nov 2019 22:57:25 +0400 Marc-André Lureau wrote: > Hi > > On Fri, Nov 8, 2019 at 7:31 PM Vladimir Sementsov-Ogievskiy > wrote: > > > > Finally, what is the plan? > > > > Markus what do you think? > > > > Now a lot of patches are reviewed, but a lot of are not. > > > > Is there any hop

Re: [Xen-devel] [Qemu-devel] [PATCH v6 12/26] hw/s390x: Hard code size with MO_{8|16|32|64}

2019-08-08 Thread Cornelia Huck
with "Now that size_memop has been implemented properly, again hard code the size but with..." > MO_{8|16|32|64}. This is more expressive and avoid size_memop calls. s/avoid/avoids/ > > Signed-off-by: Tony Nguyen > --- > hw/s390x/s390-pci-inst.c | 3 +-- > 1 file chan

Re: [Xen-devel] [Qemu-devel] [PATCH v6 08/26] hw/vfio: Access MemoryRegion with MemOp

2019-08-08 Thread Cornelia Huck
erson > --- > hw/vfio/pci-quirks.c | 6 -- > 1 file changed, 4 insertions(+), 2 deletions(-) Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [Qemu-devel] [PATCH v6 07/26] hw/virtio: Access MemoryRegion with MemOp

2019-08-08 Thread Cornelia Huck
on > --- > hw/virtio/virtio-pci.c | 7 +-- > 1 file changed, 5 insertions(+), 2 deletions(-) Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [Qemu-devel] [PATCH v6 05/26] hw/s390x: Access MemoryRegion with MemOp

2019-08-08 Thread Cornelia Huck
Henderson > --- > hw/s390x/s390-pci-inst.c | 8 +++++--- > 1 file changed, 5 insertions(+), 3 deletions(-) Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [Qemu-devel] [PATCH v6 02/26] tcg: TCGMemOp is now accelerator independent MemOp

2019-08-08 Thread Cornelia Huck
; tcg/tcg-op.h| 86 ++--- > tcg/tcg.c | 2 +- > tcg/tcg.h | 101 ++-- > trace/mem-internal.h| 4 +- > trace/mem.h

Re: [Xen-devel] [Qemu-devel] [PATCH v6 01/26] configure: Define TARGET_ALIGNED_ONLY

2019-08-08 Thread Cornelia Huck
gt; 11 files changed, 17 insertions(+), 17 deletions(-) Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH v3 00/25] chardev: Convert qemu_chr_write() to take a size_t argument

2019-02-20 Thread Cornelia Huck
On Wed, 20 Feb 2019 11:53:42 +0100 Marc-André Lureau wrote: > Hi > > On Wed, Feb 20, 2019 at 2:02 AM Philippe Mathieu-Daudé > wrote: > > > > Hi, > > > > This series convert the chardev::qemu_chr_write() to take unsigned > > length argument. To do so I went through all caller and checked if > >

Re: [Xen-devel] [PATCH v3 21/25] s390x/sclp: Use size_t in process_mdb()

2019-02-20 Thread Cornelia Huck
file changed, 2 insertions(+), 1 deletion(-) Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH v3 22/25] s390x/sclp: Let write_console_data() take a size_t

2019-02-20 Thread Cornelia Huck
deletion(-) Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH v3 20/25] s390x/sclp: Use a const variable to improve readability

2019-02-20 Thread Cornelia Huck
gt; + sizeof(mdbo->mto.alarm_control) > + sizeof(mdbo->mto._reserved); > > +len = be16_to_cpu(mdbo->length); > +len -= hlen; > assert(len <= SIZE_BUFFER); > > /* convert EBCDIC SCLP c

Re: [Xen-devel] [PATCH v3 19/25] s390/ebcdic: Use size_t to iterate over arrays

2019-02-20 Thread Cornelia Huck
ed len parameter a size_t makes sense; but using a size_t as an array iterator looks a bit unidiomatic... it's not wrong, though. Acked-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH v3 18/25] s390x/3270: Let insert_IAC_escape_char() use size_t

2019-02-20 Thread Cornelia Huck
On Wed, 20 Feb 2019 02:02:25 +0100 Philippe Mathieu-Daudé wrote: > This function takes size_t argument and return a size_t. > > Signed-off-by: Philippe Mathieu-Daudé > --- > hw/char/terminal3270.c | 7 --- > 1 file changed, 4 insertions(+), 3 deletions(-) Reviewed

Re: [Xen-devel] [PATCH 3/3] machine: Use shorter format for GlobalProperty arrays

2019-01-08 Thread Cornelia Huck
gt; -}, > +{ TYPE_S390_IPL, "iplbext_migration", "off", }, > + { TYPE_VIRTUAL_CSS_BRIDGE, "css_dev_path", "off", }, The indentation looks off here. > }; > > s390mc->ri_allowed = false; (...) With or without alignment: Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [Qemu-devel] [PATCH 3/3] machine: Use shorter format for GlobalProperty arrays

2019-01-08 Thread Cornelia Huck
On Tue, 8 Jan 2019 07:45:43 +0100 Gerd Hoffmann wrote: > Hi, > > > +{ "migration", "decompress-error-check", "off" }, > > +{ "hda-audio", "use-timer", "false" }, > > +{ "cirrus-vga", "global-vmstate", "true" }, > > +{ "VGA", "global-vmstate", "true" }, > > +{ "vmware-svga",

Re: [Xen-devel] [PATCH 2/3] machine: Eliminate unnecessary stringify() usage

2019-01-08 Thread Cornelia Huck
; hw/ppc/spapr.c| 2 +- > 4 files changed, 67 insertions(+), 67 deletions(-) Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH 1/3] spapr: Eliminate SPAPR_PCI_2_7_MMIO_WIN_SIZE macro

2019-01-08 Thread Cornelia Huck
st/spapr.h | 1 - > hw/ppc/spapr.c | 2 +- > 2 files changed, 1 insertion(+), 2 deletions(-) Reviewed-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH 00/22] QOM'ify SysBusDeviceClass->init

2018-11-19 Thread Cornelia Huck
On Mon, 19 Nov 2018 20:07:58 +0800 Mao Zhongyi wrote: > The SysBusDeviceClass::init() interface is considered > as a legacy interface and there are currently some > efforts going on to get rid of it. Thus convert > SysBusDeviceClass::init to DeviceClass::realize. In case my comment to the s390

Re: [Xen-devel] [PATCH] KVM: Start populating /sys/hypervisor with KVM entries

2018-10-09 Thread Cornelia Huck
On Tue, 9 Oct 2018 12:21:46 -0400 Boris Ostrovsky wrote: > On 10/9/18 6:41 AM, Christian Borntraeger wrote: > > > > > > On 10/09/2018 11:54 AM, Filippo Sironi wrote: > >> Start populating /sys/hypervisor with KVM entries when we're running on > >> KVM. This is to replicate functionality that'

Re: [Xen-devel] [PATCH v4 12/21] hw: Do not include "sysemu/block-backend.h" if it is not necessary

2018-05-29 Thread Cornelia Huck
| 1 - > hw/virtio/virtio-pci.c | 1 - > hw/xen/xen_devconfig.c | 1 - > hw/xtensa/xtfpga.c | 1 - > 38 files changed, 39 deletions(-) Acked-by: Cornelia Huck ___ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel

Re: [Xen-devel] [PATCH v4 14/21] hw: Do not include "sysemu/blockdev.h" if it is not necessary

2018-05-29 Thread Cornelia Huck
k/m25p80.c | 1 - > hw/block/onenand.c | 1 - > hw/i386/xen/xen-mapcache.c | 1 - > hw/s390x/virtio-ccw.c | 1 - > hw/scsi/scsi-generic.c | 1 - > hw/sd/sdhci.c | 1 - > hw/usb/dev-storage.c | 1 - > monitor.c | 1 - >