Re: [PATCH 15/22] xen/pvcalls: Use alloc_ordered_workqueue() to create ordered workqueues

2023-05-08 Thread Tejun Heo
Applied to wq/for-6.5-cleanup-ordered. Thanks. -- tejun

[PATCH 15/22] xen/pvcalls: Use alloc_ordered_workqueue() to create ordered workqueues

2023-04-20 Thread Tejun Heo
tay exactly the same and we can always reconsider later. As there are follow-up workqueue core changes, I'd really appreciate if the patch can be routed through the workqueue tree w/ your acks. Thanks. Signed-off-by: Tejun Heo Cc: Juergen Gross Cc: Stefano Stabellini Cc: Oleksandr Tys

Re: [PATCH 25/45] block: reference struct block_device from struct hd_struct

2020-11-25 Thread Tejun Heo
Hello, On Wed, Nov 25, 2020 at 05:45:15PM +0100, Christoph Hellwig wrote: > On Tue, Nov 24, 2020 at 04:18:49PM -0500, Tejun Heo wrote: > > Hello, > > > > Please see lkml.kernel.org/r/x708btj5njtbc...@mtj.duckdns.org for a few nits > > on the previous version. >

Re: [PATCH 23/45] block: remove i_bdev

2020-11-25 Thread Tejun Heo
Hello, On Wed, Nov 25, 2020 at 05:29:26PM +0100, Christoph Hellwig wrote: > > I was wondering whether losing the stale bdev flushing in bd_acquire() would > > cause user-visible behavior changes but can't see how it would given that > > userland has no way of holding onto a specific instance of bl

Re: [PATCH 11/20] block: reference struct block_device from struct hd_struct

2020-11-25 Thread Tejun Heo
Hey, Jan, On Wed, Nov 25, 2020 at 12:40:44PM +0100, Jan Kara wrote: > > I don't think this is necessary now that the bdev and inode lifetimes are > > one. Before, punching out the association early was necessary because we > > could be in a situation where we can successfully look up a part from i

Re: [PATCH 29/45] block: initialize struct block_device in bdev_alloc

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:35PM +0100, Christoph Hellwig wrote: > Don't play tricks with slab constructors as bdev structures tends to not > get reused very much, and this makes the code a lot less error prone. > > Signed-off-by: Christoph Hellwig Acked-by: Tejun Heo -- tejun

Re: [PATCH 28/45] block: simplify part_to_disk

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:34PM +0100, Christoph Hellwig wrote: > Now that struct hd_struct has a block_device pointer use that to > find the disk. > > Signed-off-by: Christoph Hellwig Acked-by: Tejun Heo -- tejun

Re: [PATCH 27/45] block: simplify the block device claiming interface

2020-11-24 Thread Tejun Heo
iewed-by: Jan Kara Acked-by: Tejun Heo -- tejun

Re: [PATCH 26/45] block: remove ->bd_contains

2020-11-24 Thread Tejun Heo
; > Signed-off-by: Christoph Hellwig > Reviewed-by: Greg Kroah-Hartman > Reviewed-by: Jan Kara Acked-by: Tejun Heo -- tejun

Re: [PATCH 25/45] block: reference struct block_device from struct hd_struct

2020-11-24 Thread Tejun Heo
Hello, Please see lkml.kernel.org/r/x708btj5njtbc...@mtj.duckdns.org for a few nits on the previous version. On Tue, Nov 24, 2020 at 02:27:31PM +0100, Christoph Hellwig wrote: > To simplify block device lookup and a few other upcoming areas, make sure > that we always have a struct block_device a

Re: [PATCH 24/45] blk-cgroup: stop abusing get_gendisk

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:30PM +0100, Christoph Hellwig wrote: > Properly open the device instead of relying on deep internals by > using get_gendisk. Note that this uses FMODE_NDELAY without either > FMODE_READ or FMODE_WRITE, which is a special open mode to allow > for opening without media

Re: [PATCH 23/45] block: remove i_bdev

2020-11-24 Thread Tejun Heo
bdev, filp->f_mode, filp); > + return 0; > } I was wondering whether losing the stale bdev flushing in bd_acquire() would cause user-visible behavior changes but can't see how it would given that userland has no way of holding onto a specific instance of block inode. Maybe

Re: [PATCH 22/45] block: opencode devcgroup_inode_permission

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:28PM +0100, Christoph Hellwig wrote: > Just call devcgroup_check_permission to avoid various superflous checks > and a double conversion of the access flags. > > Signed-off-by: Christoph Hellwig Acked-by: Tejun Heo -- tejun

Re: [PATCH 21/45] block: refactor blkdev_get

2020-11-24 Thread Tejun Heo
to simplify the disk and module refcounting so that one > reference is held for each open, similar to what we do with normal > file operations. > > Signed-off-by: Christoph Hellwig Acked-by: Tejun Heo Thanks. -- tejun

Re: [PATCH 20/45] block: refactor __blkdev_put

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:26PM +0100, Christoph Hellwig wrote: > Reorder the code to have one big section for the last close, and to use > bdev_is_partition. > > Signed-off-by: Christoph Hellwig > Reviewed-by: Greg Kroah-Hartman > Reviewed-by: Jan Kara Acked-by: Tejun Heo -- tejun

Re: [PATCH 19/45] init: cleanup match_dev_by_uuid and match_dev_by_label

2020-11-24 Thread Tejun Heo
y: Johannes Thumshirn Acked-by: Tejun Heo -- tejun

Re: [PATCH 18/45] init: refactor devt_from_partuuid

2020-11-24 Thread Tejun Heo
an Kara Acked-by: Tejun Heo -- tejun

Re: [PATCH 17/45] init: refactor name_to_dev_t

2020-11-24 Thread Tejun Heo
f-by: Christoph Hellwig > Reviewed-by: Greg Kroah-Hartman > Reviewed-by: Jan Kara > Reviewed-by: Johannes Thumshirn Acked-by: Tejun Heo -- tejun

Re: [PATCH 16/45] block: change the hash used for looking up block devices

2020-11-24 Thread Tejun Heo
Greg Kroah-Hartman > Reviewed-by: Jan Kara Acked-by: Tejun Heo -- tejun

Re: [PATCH 15/45] block: use put_device in put_disk

2020-11-24 Thread Tejun Heo
y: Johannes Thumshirn Acked-by: Tejun Heo -- tejun

Re: [PATCH 14/45] block: use disk_part_iter_exit in disk_part_iter_next

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:20PM +0100, Christoph Hellwig wrote: > Call disk_part_iter_exit in disk_part_iter_next instead of duplicating > the functionality. Acked-by: Tejun Heo -- tejun

Re: [PATCH 13/45] block: add a bdev_kobj helper

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:19PM +0100, Christoph Hellwig wrote: > Add a little helper to find the kobject for a struct block_device. Acked-by: Tejun Heo -- tejun

Re: [PATCH 12/45] block: remove a superflous check in blkpg_do_ioctl

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:18PM +0100, Christoph Hellwig wrote: > sector_t is now always a u64, so this check is not needed. > > Signed-off-by: Christoph Hellwig Acked-by: Tejun Heo -- tejun

Re: [PATCH 11/45] block: remove a duplicate __disk_get_part prototype

2020-11-24 Thread Tejun Heo
On Tue, Nov 24, 2020 at 02:27:17PM +0100, Christoph Hellwig wrote: > Signed-off-by: Christoph Hellwig > Reviewed-by: Greg Kroah-Hartman > Reviewed-by: Jan Kara > Reviewed-by: Johannes Thumshirn Acked-by: Tejun Heo -- tejun

Re: [PATCH 11/20] block: reference struct block_device from struct hd_struct

2020-11-24 Thread Tejun Heo
Hello, This is great. So much simpler & better. Some nits below. > diff --git a/block/partitions/core.c b/block/partitions/core.c > index a02e224115943d..0ba0bf44b88af3 100644 > --- a/block/partitions/core.c > +++ b/block/partitions/core.c > @@ -340,12 +340,11 @@ void delete_partition(struct hd_s

Re: [PATCH 01/20] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats

2020-11-24 Thread Tejun Heo
On Wed, Nov 18, 2020 at 09:47:41AM +0100, Christoph Hellwig wrote: > disk_get_part needs to be paired with a disk_put_part. > > Fixes: ef45fe470e1 ("blk-cgroup: show global disk stats in root cgroup > io.stat") > Signed-off-by: Christoph Hellwig Acked-by: Tejun Heo Thanks. -- tejun