[RFC][PATCH] xf86-input-evdev: add pressure valuator

2009-01-07 Thread Matt Helsley
If it available report pressure as the third valuator. Signed-off-by: Matt Helsley --- I couldn't seem to get the third valuator from X with xf86-input-evdev master when I was testing this over the holidays. (tested using the GIMP) So I backported to an older version of evdev available

[PATCH] evdev: Array sizes and iterations off by one

2009-01-10 Thread Matt Helsley
ABS_CNT (and friends) need to be used in some places instead of ABS_MAX. Also "NBITS" seems misnamed -- it is really the number of longs needed to hold the specified number of bits. Signed-off-by: Matt Helsley --- src/evdev.c | 24 src/evde

[PATCH] evdev: Add presure valuator (v2)

2009-01-10 Thread Matt Helsley
If it's available report pressure. Signed-off-by: Matt Helsley --- Changes: Renamed pressure_valuator to has_pressure. Nested some code blocks rather than having separate nearly identical blocks. Use xf86PostMotionEventP instead of the varargs wr

Re: [PATCH] evdev: Array sizes and iterations off by one

2009-01-11 Thread Matt Helsley
On Mon, 2009-01-12 at 10:42 +1000, Peter Hutterer wrote: > On Sat, Jan 10, 2009 at 11:05:12PM -0800, Matt Helsley wrote: > > ABS_CNT (and friends) need to be used in some places instead of > > ABS_MAX. Also "NBITS" seems misnamed -- it is really the number of > > lon

[PATCH] rename NBITS to NLONGS to reflect its actual meaning

2009-01-11 Thread Matt Helsley
NBITS really convers the number of bits passed as its argument into a number of longs. This is somewhat atypical of many function-like-macro names. Rename it to NLONGS. Signed-off-by: Matt Helsley --- src/evdev.c | 16 src/evdev.h | 14 -- 2 files changed, 16

[PATCH] Fix FOO_MAX off-by-one

2009-01-11 Thread Matt Helsley
r use with Linux kernels which lack them. Use FOO_CNT whenever we need to know the number of bits needed -- usually to calculate the number of longs needed. When iterating over the values FOO_MAX still seems appropriate however the loop test should include FOO_MAX rather than skip it. Signed-off-by:

[RFC][PATCH] General axis valuator support

2009-01-11 Thread Matt Helsley
patches. For example, perhaps converting the REL axes should be a separate patch. Signed-off-by: Matt Helsley --- src/evdev.c | 189 +--- src/evdev.h |9 +- 2 files changed, 100 insertions(+), 98 deletions(-) Index

Re: [RFC][PATCH] General axis valuator support

2009-01-11 Thread Matt Helsley
On Sun, 2009-01-11 at 19:37 -0800, Matt Helsley wrote: > Currently X, Y, and PRESSURE are special case axes in xf86-input-evdev. > This patch supports axes in a more general way. There are a few open > questions and TODOs: > > TODO: > Add REL axes. Since we currently limi

Re: [RFC][PATCH] General axis valuator support

2009-01-14 Thread Matt Helsley
On Sun, Jan 11, 2009 at 8:01 PM, Peter Hutterer wrote: > Some comments purely related to your comments, not your code. I won't be > able to look at your code today. > > On Sun, Jan 11, 2009 at 07:37:49PM -0800, Matt Helsley wrote: >> Currently X, Y, and PRESSURE are sp

Re: Draft XI 2 protocol specification

2009-01-18 Thread Matt Helsley
XKM2. (And > fix the vmods problem at the same time.) > > > - still no subpixel precision, unless we decide to make the valuators 24.8, > > or > > provide 32+32 or something. > > Yeah, I reckon 32 + 32 would be cool. What do the Wacoms provide? I > imagin

Re: [PATCH] Xi: define a default range of axis labels.

2009-01-23 Thread Matt Helsley
2 X" > +#define AXIS_LABEL_PROP_ABS_HAT2Y "Abs Hat 2 Y" > +#define AXIS_LABEL_PROP_ABS_HAT3X "Abs Hat 3 X" > +#define AXIS_LABEL_PROP_ABS_HAT3Y "Abs Hat 3 Y" > +#define AXIS_LABEL_PROP_ABS_PRESSURE"Abs Pressure" > +#define AXIS_LABEL_PROP_ABS_DISTANCE"Abs Distance" > +#define AXIS_LABEL_PROP_ABS_TILT_X "Abs Tilt X" > +#define AXIS_LABEL_PROP_ABS_TILT_Y "Abs Tilt Y" > +#define AXIS_LABEL_PROP_ABS_TOOL_WIDTH "Abs Tool Width" > +#define AXIS_LABEL_PROP_ABS_VOLUME "Abs Volume" > +#define AXIS_LABEL_PROP_ABS_MISC"Abs Misc" > + > #endif A nit: "Rel" and "Abs" may be abbreviations end-users wouldn't recognize. Perhaps expanding them would be good. Cheers, -Matt Helsley ___ xorg mailing list xorg@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/xorg

Re: Pointer glide patch for Input/synaptics

2009-01-24 Thread Matt Helsley
ng */ else /* stopped */ If hw->millis value "overflows" then the pointer could still move in the opposite direction -- though it would take a specific set of circumstances and may not be very noticeable. Cheers, -Matt Helsley ___ xorg mailing list xorg@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/xorg