[PATCH v2] dix: add utility functions for double to/fro FP1616/FP3232 conversion

2011-10-05 Thread Peter Hutterer
Co-authored by Jeremy Huddleston jerem...@apple.com Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- Changes to v1: - works for negative numbers now too. oh, the features! - dropped the fabs(frac) 1 part, we should be able to rely on (foo - (int)foo) to give us something within 0..1 -

Re: [PATCH:libpciaccess] Solaris: Give better error on realloc failure

2011-10-05 Thread Dirk Wallenstein
On Tue, Oct 04, 2011 at 10:53:20PM -0700, Alan Coopersmith wrote: commit a18460b385ae03 converted from a fixed maximum number of devices to dynamically growing the list via realloc, but didn't update the error message shown on failure. Signed-off-by: Alan Coopersmith

Re: [PATCH xf86-video-vmware] Use dixLookupWindow instead of LookupWindow on Xorg 1.5 later

2011-10-05 Thread Thomas Hellstrom
On 10/01/2011 06:07 PM, Alan Coopersmith wrote: On 09/27/11 07:31 PM, Alan Coopersmith wrote: +static inline int +dixLookupWindow(WindowPtr *pWin, XID id, ClientPtr client, Mask access) +{ +*pWin = LookupWindow(stuff-window, client); Oops, just noticed that should be LookupWindow(id,

Re: [PULL] build fix, GC clipping cleanup

2011-10-05 Thread Michel Dänzer
On Die, 2011-10-04 at 12:47 -0700, Aaron Plattner wrote: On 10/04/2011 12:43 PM, Keith Packard wrote: * PGP Signed by an unknown key On Tue, 4 Oct 2011 12:37:59 -0700, Aaron Plattneraplatt...@nvidia.com wrote: With the old CreatePixmap API, drivers could override the width and

Re: [PATCH:libpciaccess] Solaris: Give better error on realloc failure

2011-10-05 Thread Mark Kettenis
From: Alan Coopersmith alan.coopersm...@oracle.com Date: Tue, 4 Oct 2011 22:53:20 -0700 commit a18460b385ae03 converted from a fixed maximum number of devices to dynamically growing the list via realloc, but didn't update the error message shown on failure. Hmm, I hate libraries that

Re: [PATCH 1/3] Move miTrapezoids() into fb as fbTrapezoids().

2011-10-05 Thread Michel Dänzer
On Die, 2011-10-04 at 15:52 -0700, Aaron Plattner wrote: This caused a performance regression because previously, miTrapezoids would render its mask image into a scratch pixmap and then perform the final composite using a possibly-accelerated RENDER Composite call. Now, fbTrapezoids does

Re: [PATCH v2] dix: add utility functions for double to/fro FP1616/FP3232 conversion

2011-10-05 Thread Michel Dänzer
On Mit, 2011-10-05 at 17:01 +1000, Peter Hutterer wrote: Co-authored by Jeremy Huddleston jerem...@apple.com Signed-off-by: Peter Hutterer peter.hutte...@who-t.net [...] +FP3232 +double_to_fp3232(double in) +{ +FP3232 ret; +int32_t integral; +double tmp; +uint32_t

Re: [Pixman] [PATCH 1/3] Move miTrapezoids() into fb as fbTrapezoids().

2011-10-05 Thread Søren Sandmann
Michel Dänzer mic...@daenzer.net writes: On Die, 2011-10-04 at 15:52 -0700, Aaron Plattner wrote: This caused a performance regression because previously, miTrapezoids would render its mask image into a scratch pixmap and then perform the final composite using a possibly-accelerated RENDER

Re: [RFC modular] Publish.sh: batch release and autotagging of modules

2011-10-05 Thread Gaetan Nadon
On Tue, 2011-10-04 at 18:03 -0700, Jeremy Huddleston wrote: I haven't reviewed yet, but this seems like a great idea. Thanks, I have a few days of testing and refinements still. I forgot to append some sample output. This is the output when invoking the script against the server in the

Re: [PULL] build fix, GC clipping cleanup

2011-10-05 Thread Jamey Sharp
Alright, the pixmap hooks have weird undocumented constraints, and maybe we'll figure out something clever someday. Meanwhile, would you please merge the other three commits? Thanks, Jamey On 10/3/11, Jamey Sharp ja...@minilop.net wrote: On Mon, Oct 03, 2011 at 12:01:23PM -0700, Keith Packard

Re: [PULL] build fix, GC clipping cleanup

2011-10-05 Thread Keith Packard
On Wed, 05 Oct 2011 10:07:17 +0200, Michel Dänzer mic...@daenzer.net wrote: That won't work for EXA/mixed, which only allocates devPrivate.ptr on demand. Use some magic value in devPrivate? Add a flag somewhere which indicates that the allocation has already been managed? --

[PATCH xwininfo 0/4] Cleanups and warning fixes

2011-10-05 Thread Guillem Jover
Hi! So, while the static variable in window_id_str() is not ideal, the other options seemed uglier, so I went with that as it does not matter at all in this case. regards, guillem Guillem Jover (4): Move leading : out from buffer to the error string printer Use format string literals

[PATCH xwininfo 1/4] Move leading : out from buffer to the error string printer

2011-10-05 Thread Guillem Jover
Besides slightly reducing the binary size, this will be helpful when/if i18n support is added to translate the strings. Signed-off-by: Guillem Jover guil...@hadrons.org --- dsimple.c | 38 +++--- 1 files changed, 19 insertions(+), 19 deletions(-) diff --git

[PATCH xwininfo 2/4] Use format string literals instead of variables to print window ids

2011-10-05 Thread Guillem Jover
This allows the compiler to check the format against the argument types. Signed-off-by: Guillem Jover guil...@hadrons.org --- xwininfo.c | 24 +--- 1 files changed, 17 insertions(+), 7 deletions(-) diff --git a/xwininfo.c b/xwininfo.c index ef8c720..a97a845 100644 ---

[PATCH xwininfo 4/4] Use format string literals instead of variables to print atom names

2011-10-05 Thread Guillem Jover
This allows the compiler to check the format against the argument types. Signed-off-by: Guillem Jover guil...@hadrons.org --- xwininfo.c | 41 - 1 files changed, 20 insertions(+), 21 deletions(-) diff --git a/xwininfo.c b/xwininfo.c index

[PATCH xwininfo 3/4] Refactor atom name printing into a new Display_Atom_Name function

2011-10-05 Thread Guillem Jover
Signed-off-by: Guillem Jover guil...@hadrons.org --- xwininfo.c | 38 -- 1 files changed, 16 insertions(+), 22 deletions(-) diff --git a/xwininfo.c b/xwininfo.c index a97a845..096ced0 100644 --- a/xwininfo.c +++ b/xwininfo.c @@ -1634,6 +1634,18 @@

Re: [PATCH xwininfo 0/4] Cleanups and warning fixes

2011-10-05 Thread Alan Coopersmith
On 10/ 5/11 02:22 PM, Guillem Jover wrote: Hi! So, while the static variable in window_id_str() is not ideal, the other options seemed uglier, so I went with that as it does not matter at all in this case. regards, guillem Guillem Jover (4): Move leading : out from buffer to the error

[PATCH v3] dix: add utility functions for double to/fro FP1616/FP3232 conversion

2011-10-05 Thread Jeremy Huddleston
Co-authored-by: Jeremy Huddleston jerem...@apple.com Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- Attached is a self-contained version of this called test.c Changes from v2: 1UUL instead of ldexp Cleanup to make style match in both cases Improved testing Fixed a bug with negatives

Re: [PATCH v3] dix: add utility functions for double to/fro FP1616/FP3232 conversion

2011-10-05 Thread Peter Hutterer
On Wed, Oct 05, 2011 at 03:02:52PM -0700, Jeremy Huddleston wrote: Co-authored-by: Jeremy Huddleston jerem...@apple.com Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- Attached is a self-contained version of this called test.c Changes from v2: 1UUL instead of ldexp Cleanup to

Re: [PULL] prep work for screen crossing fixes

2011-10-05 Thread Peter Hutterer
On Tue, Oct 04, 2011 at 04:26:29PM -0400, Peter Harris wrote: On 2011-10-04 01:35, Peter Hutterer wrote: On Mon, Oct 03, 2011 at 10:02:28PM -0700, Jamey Sharp wrote: On Tue, Oct 04, 2011 at 02:15:53PM +1000, Peter Hutterer wrote: On Mon, Oct 03, 2011 at 09:02:19PM -0700, Keith Packard

[PULL RESEND] prep work for screen crossing fixes, inverted button emulation fix

2011-10-05 Thread Peter Hutterer
Removed the top commit, replaced with Max' fix for emulated button events. Commit 765ef69295ddc473640c96f1b4f54e0b8bfc670e The following changes since commit 6378d0233d21088b6429755627b4253859892c72: Merge remote-tracking branch 'herrb/master' (2011-10-03 13:56:06 -0700) are available in the