Re: [PATCH 01/10] Replace 'pointer' type with 'void *'

2013-12-29 Thread Eric Anholt
Keith Packard kei...@keithp.com writes: This lets us stop using the 'pointer' typedef in Xdefs.h as 'pointer' is used throughout the X server for other things, and having duplicate names generates compiler warnings. Review to follow. I definitely don't want to read a v2. But a v2 ready to

Re: [PATCH 01/10] Replace 'pointer' type with 'void *'

2013-12-29 Thread Keith Packard
Eric Anholt e...@anholt.net writes: I don't think these comments wanted to change. Sorry for missing those. -free((pointer) pScreenPriv); +free((void *) pScreenPriv); Casting to void * to pass to a function taking void *? I guess cleanups of that can be left to a coccinelle patch

Re: [PATCH 01/10] Replace 'pointer' type with 'void *'

2013-12-29 Thread Keith Packard
here's the function prototype changes, split out from the pointer-void * changes. From 789e3d6934033d55a72e0f573d001df478f1ca20 Mon Sep 17 00:00:00 2001 From: Keith Packard kei...@keithp.com Date: Sun, 29 Dec 2013 15:18:28 -0800 Subject: [PATCH 02/11] Clean up a few function prototypes to not

Re: [PATCH 02/11] Clean up a few function prototypes to not place formals in /**/

2013-12-29 Thread Alan Coopersmith
From 789e3d6934033d55a72e0f573d001df478f1ca20 Mon Sep 17 00:00:00 2001 From: Keith Packard kei...@keithp.com Date: Sun, 29 Dec 2013 15:18:28 -0800 Subject: [PATCH 02/11] Clean up a few function prototypes to not place formals in /**/ This just removes the comment markers from around the formals

Re: [PATCH 01/14] composite: Fix -Wshadow warning

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Entirely redundant assignment, we're doing exactly the same thing in the containing block. Just nuke it. Signed-off-by: Adam Jackson a...@redhat.com Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpPCxgeLwkPy.pgp

Re: [PATCH 02/14] exa: Fix -Wshadow warning

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: There's an int ret in the containing scope. Its value never escapes the function, we're just using it to check return values from callees. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpUiX0URrW1U.pgp Description: PGP

Re: [PATCH 03/14] xephyr: Fix -Wshadow warning

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Just a junk variable, the one in containing scope is fine to reuse. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpU9fTEiH3WS.pgp Description: PGP signature ___

Re: [PATCH 04/14] kdrive: Fix -Wshadow warnings

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Rename the variables to make it clear what we're talking about. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpIgrw6v8dgH.pgp Description: PGP signature ___ xorg-devel@lists.x.org:

Re: [PATCH 00/14] -Wshadow warning fixes

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: These all fix shadowed declarations, where you have a variable in inner scope with the same name as another variable in outer scope. There are still a few left, because apparently gcc thinks it's cool to warn you when a variable name shadows a typedef

Re: [PATCH 06/14] x86emu: Fix -Wshadow warnings

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: The variable(s) being shadowed are u16 or u16 *. For the 32-bit paths, change the variable name too; for the 16-bit paths, just use the outer scope's variable. Sounds better than mine Reviewed-by: Keith Packard kei...@keithp.com --

Re: [PATCH 07/14] xfree86/parser: Fix -Wshadow warnings

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Did you know the parser defines a global named 'val'? Gross. I actually renamed it 'xf86_lex_val' instead of working around that. -- keith.pack...@intel.com pgp9j_eH45uFW.pgp Description: PGP signature ___

Re: [PATCH 08/14] xfree86/fbman: Fix -Wshadow warning

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Entirely redundant assignment, just nuke it. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpImzQNVX1b3.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development

Re: [PATCH 09/14] xfree86/configure: Fix -Wshadow warnings

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Signed-off-by: Adam Jackson a...@redhat.com Reviewed-by: Keith Packard kei...@keithp.com (my version of this patch also changes Pointer to pointer to avoid another -Wshadow warning) -- keith.pack...@intel.com pgp5BsgvAeQsd.pgp Description: PGP signature

Re: [PATCH 10/14] xfree86/dri1: Fix -Wshadow warnings

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Neither of these needs to exist, the containing scope variable is fine. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgptCEaL7wfIa.pgp Description: PGP signature ___

Re: [PATCH 11/14] xfree86/randr: Fix -Wshadow warnings

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Signed-off-by: Adam Jackson a...@redhat.com Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpMI6SrBGeHZ.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development

Re: [PATCH 12/14] xfree86: Fix -Wshadow warning

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Junk variable, just nuke it. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpI4KA6aeFHx.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development Archives:

Re: [PATCH 13/14] xnest: Fix -Wshadow warnings

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Just rename parameters to not clash with globals. I used 'screen_info' instead of 'screeninfo', otherwise identical patches :-) Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpO8KjOd4P8R.pgp Description: PGP signature

Re: [PATCH 14/14] os: Fix -Wshadow warnings

2013-12-29 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Signed-off-by: Adam Jackson a...@redhat.com static XdmClientAuthPtr XdmAuthorizationValidate(unsigned char *plain, int length, - XdmAuthKeyPtr rho, ClientPtr xclient, + XdmAuthKeyPtr _rho, ClientPtr

Re: [PATCH 02/11] Clean up a few function prototypes to not place formals in /**/

2013-12-29 Thread Keith Packard
Alan Coopersmith alan.coopersm...@oracle.com writes: Reviewed-by: Alan Coopersmith alan.coopersm...@oracle.com I've pushed out an updated version of my branch with the relevant reviewed-to tags added. -- keith.pack...@intel.com pgpITBiORqKAr.pgp Description: PGP signature