[PATCH 16/18] test/xi2: Clean up -Wshadow warnings

2014-01-13 Thread Keith Packard
protocol-common declares a bunch of pretty generic names; fix shadows of these names. Signed-off-by: Keith Packard kei...@keithp.com --- test/xi2/protocol-common.c | 66 - test/xi2/protocol-common.h | 2 +-

[PATCH 12/18] hw/vfb: Rename screenInfo parameter to screen_info

2014-01-13 Thread Keith Packard
Avoid shadowing the global screenInfo value. Signed-off-by: Keith Packard kei...@keithp.com --- hw/vfb/InitOutput.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/hw/vfb/InitOutput.c b/hw/vfb/InitOutput.c index d102722..2175ac6 100644 ---

Remaining X server warning fixes

2014-01-13 Thread Keith Packard
Here's 18 patches which clean up the remaining warnings (at least for me) in the X server. A couple of these are new as of this series, but the rest have been posted before Old patches, posted before Christmas: [PATCH 01/18] Warning fixes in glx [PATCH 02/18] pseudoramiX: Clean up

[PATCH 09/18] composite: Remove duplicate window pixmap fetch

2014-01-13 Thread Keith Packard
There's nothing between the previous fetch and this one that could cause the window pixmap to have changed. Signed-off-by: Keith Packard kei...@keithp.com --- composite/compwindow.c | 1 - 1 file changed, 1 deletion(-) diff --git a/composite/compwindow.c b/composite/compwindow.c index

[PATCH 01/18] Warning fixes in glx

2014-01-13 Thread Keith Packard
Signed-off-by: Keith Packard kei...@keithp.com --- glx/glxdri2.c| 2 +- glx/glxdricommon.c | 2 +- glx/indirect_dispatch_swap.c | 12 glx/indirect_program.c | 22 -- 4 files changed, 2 insertions(+), 36 deletions(-) diff --git

[PATCH 14/18] randr: Eliminate -Wshadow warnings

2014-01-13 Thread Keith Packard
Don't use rrScrPriv for nested screen private fetching. Eliminate a duplicate fetch of the randr screen private in rrCheckPixmapBounding. Signed-off-by: Keith Packard kei...@keithp.com --- randr/rrcrtc.c | 17 - 1 file changed, 8 insertions(+), 9 deletions(-) diff --git

[PATCH 04/18] Ignore a couple of format-nonliteral warnings

2014-01-13 Thread Keith Packard
These are generated in code which uses sprintf as a convenient way to construct strings from various pieces. Signed-off-by: Keith Packard kei...@keithp.com --- hw/xfree86/os-support/linux/lnx_init.c | 1 + os/log.c | 2 ++ 2 files changed, 3 insertions(+) diff

[PATCH 11/18] kdrive: Fix -Wshadow errors

2014-01-13 Thread Keith Packard
Just rename stuff to avoid conflicts. Signed-off-by: Keith Packard kei...@keithp.com --- hw/kdrive/src/kinput.c | 4 ++-- hw/kdrive/src/kxv.c| 4 ++-- 2 files changed, 4 insertions(+), 4 deletions(-) diff --git a/hw/kdrive/src/kinput.c b/hw/kdrive/src/kinput.c index 7d09e28..a539ca5 100644

[PATCH 10/18] exa: Fix -Wshadow warnings

2014-01-13 Thread Keith Packard
In exa_accel, there was a duplicate fetch of a pixmap private field. exa_render just had a regular shadowed value. Signed-off-by: Keith Packard kei...@keithp.com --- exa/exa_accel.c | 1 - exa/exa_render.c | 6 +++--- 2 files changed, 3 insertions(+), 4 deletions(-) diff --git

[PATCH 17/18] test/hashtabletest: Clean up -Wshadow errors

2014-01-13 Thread Keith Packard
Declare 'XID id' local to each scope it is used in, rather than having the first use be a function-wide declaration. Signed-off-by: Keith Packard kei...@keithp.com --- test/hashtabletest.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/test/hashtabletest.c

[PATCH 03/18] include: GetClientResolutions is declared in font.h

2014-01-13 Thread Keith Packard
No need to have a duplicate definition here. Signed-off-by: Keith Packard kei...@keithp.com --- include/dixfontstubs.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/include/dixfontstubs.h b/include/dixfontstubs.h index 0454ffa..535d312 100644 --- a/include/dixfontstubs.h +++

[PATCH 02/18] pseudoramiX: Clean up warnings. Only compile on XQUARTZ and XWIN

2014-01-13 Thread Keith Packard
Add _X_ATTRIBUTE_PRINTF attributes to debug functions. PseudoramiXExtensionInit() is not defined in extinit.h if it won't be used and we get a compiler warning when compiling the pseudoramiX code. Signed-off-by: Keith Packard kei...@keithp.com --- Makefile.am | 6 +-

[PATCH 06/18] os: Fix -Wshadow errors

2014-01-13 Thread Keith Packard
Rename variables to avoid shadowing globals Signed-off-by: Keith Packard kei...@keithp.com --- os/xdmauth.c | 18 +- os/xdmcp.c | 28 +--- 2 files changed, 22 insertions(+), 24 deletions(-) diff --git a/os/xdmauth.c b/os/xdmauth.c index 28584d2..f11cbb9

[PATCH 07/18] Xi: Use 'void *' instead of 'Pointer' (which is going away)

2014-01-13 Thread Keith Packard
There's no reason for XI to declare 'typedef char *Pointer' in a shared header file; assume it will eventually go away and stop using it here. Signed-off-by: Keith Packard kei...@keithp.com --- Xi/grabdev.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Xi/grabdev.c

[PATCH 18/18] test/signal-formatting: Ignore compiler warnings

2014-01-13 Thread Keith Packard
The signal formatting tests intentionally include code which generates warnings with the current X server warning flags. Turn the compiler warnings off Signed-off-by: Keith Packard kei...@keithp.com --- test/signal-logging.c | 8 ++-- 1 file changed, 6 insertions(+), 2 deletions(-) diff

[PATCH 05/18] Add 'FONT_PATH_NAME_ELEMENT_CONST' to dix-config.h and xorg-server.h

2014-01-13 Thread Keith Packard
This signals to the fontsproto code that the X server has been fixed to allow the name member in a FontPathElement struct to be declared const to eliminate piles of warnings when assigning string constants to them. Signed-off-by: Keith Packard kei...@keithp.com --- include/dix-config.h.in | 3

[PATCH 13/18] hw/xnest: Eliminate shadowed names

2014-01-13 Thread Keith Packard
Just rename stuff; nothing fancy here. Signed-off-by: Keith Packard kei...@keithp.com --- hw/xnest/Events.c | 6 +++--- hw/xnest/GCOps.c | 4 ++-- hw/xnest/Init.c | 22 +++--- hw/xnest/Window.c | 2 +- 4 files changed, 17 insertions(+), 17 deletions(-) diff --git

[PATCH 15/18] kdrive/ephyr: Remove extra 'i' variable in ProcXF86DRIGetDrawableInfo

2014-01-13 Thread Keith Packard
Just re-use the top-level one Signed-off-by: Keith Packard kei...@keithp.com --- hw/kdrive/ephyr/ephyrdriext.c | 1 - 1 file changed, 1 deletion(-) diff --git a/hw/kdrive/ephyr/ephyrdriext.c b/hw/kdrive/ephyr/ephyrdriext.c index e2b33db..8368d12 100644 --- a/hw/kdrive/ephyr/ephyrdriext.c +++

Re: [PATCH 1/1] randr: make RROutputChanged change the main protocol screen not the gpu screen

2014-01-13 Thread Alberto Milone
On 16/12/13 09:52, Alberto Milone wrote: On 12/12/13 10:00, Alberto Milone wrote: We only set changes on the main protocol screen as, for example in RRSetChanged() and RRTellChanged(), therefore we should follow the same logic when reporting that an output changed in RROutputChanged(). This

Re: [PATCH 00/37] Warning fixes (post 1.15 proposed changes)

2014-01-13 Thread Colin Harrison
PS Also some protos don't now work, for me, when compiling xserver now we have lost the 'pointer' type --- save_Xdefs.h2013-07-08 16:18:17.466538543 +0100 +++ Xdefs.h 2014-01-13 17:13:09.440775586 + @@ -101,8 +101,8 @@ typedef FSID AccContext; typedef struct timeval

Re: [PATCH 00/37] Warning fixes (post 1.15 proposed changes)

2014-01-13 Thread Colin Harrison
Hi, This message was sent before the last one? (maybe Biff the dog ran off and buried it!) Apologies if it now appears twice! Some const GC funcs and ops were missed in rootless... --- ./miext/rootless/save_rootlessGC.c 2014-01-13 08:09:28.124320860 + +++ ./miext/rootless/rootlessGC.c

[PATCH] os: restrict display names to digits

2014-01-13 Thread Peter Hutterer
We call atoi() on the server's display to get the socket but otherwise use the unmodified display for log file name, xkb paths, etc. This results in Xorg :banana being the equivalent of Xorg :0, except for the log files being in /var/log/Xorg.banana.log. I'm not sure there's a good use-case for

[PATCH] Replace 'pointer' with explicit 'void *'

2014-01-13 Thread Keith Packard
To get rid of the 'pointer' typedef, stop using it locally. That way, when _XTYPEDEF_POINTER is defined before Xdefs.h is included, it won't get defined and Xdefs.h will still compile. Signed-off-by: Keith Packard kei...@keithp.com --- Xdefs.h | 4 ++-- 1 file changed, 2 insertions(+), 2

[PATCH:x11proto] Add more comments on connection setup to Xproto.h

2014-01-13 Thread Alan Coopersmith
Some of the bits I forget and have to dig out of the protocol spec every few years when I need to know again. Signed-off-by: Alan Coopersmith alan.coopersm...@oracle.com --- Xproto.h | 17 +++-- 1 file changed, 15 insertions(+), 2 deletions(-) diff --git a/Xproto.h b/Xproto.h

Re: [PATCH 00/37] Warning fixes (post 1.15 proposed changes)

2014-01-13 Thread Colin Harrison
Hi, Some const GC funcs and ops were missed in rootless... --- ./miext/rootless/save_rootlessGC.c 2014-01-13 08:09:28.124320860 + +++ ./miext/rootless/rootlessGC.c 2014-01-13 18:31:27.668467154 + @@ -403,7 +403,7 @@ #define GCOP_UNWRAP(pGC) \ RootlessGCRec *gcrec =

Re: [PATCH] Replace 'pointer' with explicit 'void *'

2014-01-13 Thread Alan Coopersmith
On 01/13/14 04:19 PM, Keith Packard wrote: To get rid of the 'pointer' typedef, stop using it locally. That way, when _XTYPEDEF_POINTER is defined before Xdefs.h is included, it won't get defined and Xdefs.h will still compile. Signed-off-by: Keith Packard kei...@keithp.com --- Xdefs.h | 4

Re: [PATCH] Replace 'pointer' with explicit 'void *'

2014-01-13 Thread Keith Packard
Alan Coopersmith alan.coopersm...@oracle.com writes: Does this need to be #ifdef'ed to avoid breaking people building 1.15.x earlier releases? No. 'pointer' was just a typedef for 'void *'. -- keith.pack...@intel.com pgpmehAuRqc8T.pgp Description: PGP signature

[PATCH 2/4] fb: Clear invalid plane mask bits in GetImage

2014-01-13 Thread Keith Packard
Anything outside of the depth should not end up in the resulting image. Signed-off-by: Keith Packard kei...@keithp.com --- fb/fbimage.c | 1 + 1 file changed, 1 insertion(+) diff --git a/fb/fbimage.c b/fb/fbimage.c index 59daa21..75e38c2 100644 --- a/fb/fbimage.c +++ b/fb/fbimage.c @@ -260,6

[PATCH 4/4] ephyr: Add -bitmap8 flag to specify 8 bpp for bitmaps

2014-01-13 Thread Keith Packard
This provides a way to test fb support for 8bpp bitmaps. Signed-off-by: Keith Packard kei...@keithp.com --- hw/kdrive/ephyr/ephyr.c | 3 +++ hw/kdrive/ephyr/ephyrinit.c | 5 + 2 files changed, 8 insertions(+) diff --git a/hw/kdrive/ephyr/ephyr.c b/hw/kdrive/ephyr/ephyr.c index

[PATCH 0/4] fb support for 8bpp bitmaps

2014-01-13 Thread Keith Packard
Here's a fun sequence of patches. What it does is make fb support bitmaps (depth 1 pixmaps) that are stored in 8 bits per pixel. Why would you want to do this, you ask? Well, Glamor wants to use GL for all rendering, and GL has no support for 1bpp surfaces. Making fb support bitmaps in 8bpp means

[PATCH 3/4] fb: Add support for 8-bpp pixmaps

2014-01-13 Thread Keith Packard
This allows the driver to ask for depth-1 pixmaps to be stored with 8 bits per pixel, keeping all 8 bits of each pixel either 0 or 0xff. Images in Z-format remain 1bpp. Signed-off-by: Keith Packard kei...@keithp.com --- fb/fb.h| 107 +-

Re: Remaining X server warning fixes

2014-01-13 Thread Guillem Jover
On Mon, 2014-01-13 at 10:17:40 -0800, Keith Packard wrote: Here's 18 patches which clean up the remaining warnings (at least for me) in the X server. A couple of these are new as of this series, but the rest have been posted before Old patches, posted before Christmas: [PATCH 01/18]

Re: Remaining X server warning fixes

2014-01-13 Thread Keith Packard
Guillem Jover guil...@hadrons.org writes: Didn't Adam send several of those (days before you poster yours), which you also already reviewed? Yeah, I'll sort those out and figure out what to do. Still recovering From LCA today... -- keith.pack...@intel.com pgpJBWNcjZpAU.pgp Description: PGP

Re: [PATCH] os: restrict display names to digits

2014-01-13 Thread Keith Packard
Peter Hutterer peter.hutte...@who-t.net writes: We call atoi() on the server's display to get the socket but otherwise use the unmodified display for log file name, xkb paths, etc. This results in Xorg :banana being the equivalent of Xorg :0, except for the log files being in

Re: [PATCH 0/4] fb support for 8bpp bitmaps

2014-01-13 Thread Michel Dänzer
On Mon, 2014-01-13 at 18:00 -0800, Keith Packard wrote: Here's a fun sequence of patches. What it does is make fb support bitmaps (depth 1 pixmaps) that are stored in 8 bits per pixel. Why would you want to do this, you ask? Well, Glamor wants to use GL for all rendering, and GL has no support