Re: [PATCH driver/intel] Allow copy_front() to fail and clean up gracefully if it does

2014-09-23 Thread Chris Wilson
On Wed, Sep 24, 2014 at 08:17:59AM +0200, Egbert Eich wrote: > From: Egbert Eich > > copy_front() calls sna_pixmap_force_to_gpu() which may fail. If we pretend > to have been successful and continue the caller sna_mode_resize() may finish > successfully pretending a mode change has succeeded whic

Re: [PATCH libxtrans] Add TRANS(Listen) function to re-enable specific listen sockets

2014-09-23 Thread Alan Coopersmith
I'd started working on a similar patch series last year, but never finished it after getting sidetracked by our security fixes - for whatever it's worth, I've attached the work-in-progress I had - I don't even remember at this point what was still left to do. -- -Alan Coopersmith-

[PATCH 2/2] Use unique display name for each xi2 test program

2014-09-23 Thread Alan Coopersmith
make -j 8 check was sporadically failing in different xi2 tests. After adding the asserts in the previous commit to catch xkb failure it became easier to catch the failures and see that multiple tests were running at once trying to write to /tmp/server-(null).xkm and then delete it, and interfering

[PATCH 1/2] Abort xi2 tests if ActivateDevice() fails

2014-09-23 Thread Alan Coopersmith
I was getting segfaults in xi2 tests from trying to copy XKB keyboard state to NULL pointers with a stack of: 0 0x006244d2 in XkbPushLockedStateToSlaves (master=0x7b4650, evtype=0, key=0) at xkbActions.c:1189 1 0x004f450a in EnableDevice (dev=0x7b3810, sendevent=0 '\000')

[PATCH driver/intel] In sna_pixmap_alloc_gpu() process user selected tiling thru kgem_choose_tiling()

2014-09-23 Thread Egbert Eich
From: Egbert Eich In sna_pixmap_alloc_gpu() a different than the default tiling may be picked by a usage hint. Before passing the tiling to kgem_create_2d() fix it up by calling kgem_choose_tiling(). This avoids kgem_surface_size() not being able to find a surface size for the tiling value. Sign

[PATCH driver/intel] Allow copy_front() to fail and clean up gracefully if it does

2014-09-23 Thread Egbert Eich
From: Egbert Eich copy_front() calls sna_pixmap_force_to_gpu() which may fail. If we pretend to have been successful and continue the caller sna_mode_resize() may finish successfully pretending a mode change has succeeded which might leave a mode behind which is unusable. This patch makes copy_fr

[PATCH] uxa/video: only call intel_xvmc_adaptor_init when xvmc is enabled

2014-09-23 Thread tobias . jakobi1
Signed-off-by: Tobias Jakobi --- src/uxa/intel_video.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/src/uxa/intel_video.c b/src/uxa/intel_video.c index 310b6c9..33d447c 100644 --- a/src/uxa/intel_video.c +++ b/src/uxa/intel_video.c @@ -239,8 +239,10 @@ void intel_video_init(ScreenPtr scr

Re: [PATCH 17/18] mi: miSlideAndSizeWindow -> miResizeWindow

2014-09-23 Thread Adam Jackson
On Tue, 2014-09-23 at 13:07 -0600, Jasper St. Pierre wrote: > I sort of like "slide" because it gives the impression that we copy > the framebuffer contents if the size of the window hasn't changed. > That said, if we want to change this, we should change the name of the > slot too. Meh. This cha

Re: [PATCH 13/18] dix: Lower backStorage to a bit instead of a pointer

2014-09-23 Thread Adam Jackson
On Tue, 2014-09-23 at 13:03 -0600, Jasper St. Pierre wrote: > Here you use 0. > > Why the inconsistency? No especially good reason. In the tree I'm actually working on [1] this particular lowering happened after I'd factored out the redirection logic in compChangeWindowAttributes to its own fun

Re: [PATCH 17/18] mi: miSlideAndSizeWindow -> miResizeWindow

2014-09-23 Thread Jasper St. Pierre
I sort of like "slide" because it gives the impression that we copy the framebuffer contents if the size of the window hasn't changed. That said, if we want to change this, we should change the name of the slot too. Reviewed-by: Jasper St. Pierre On Tue, Sep 23, 2014 at 12:32 PM, Adam Jackson w

Re: [PATCH 13/18] dix: Lower backStorage to a bit instead of a pointer

2014-09-23 Thread Jasper St. Pierre
On Tue, Sep 23, 2014 at 12:32 PM, Adam Jackson wrote: > Signed-off-by: Adam Jackson > --- > composite/compinit.c | 4 ++-- > dix/window.c | 2 +- > include/windowstr.h | 2 +- > mi/miexpose.c| 2 +- > 4 files changed, 5 insertions(+), 5 deletions(-) > > diff --git a/composite/c

[PATCH 10/18] mi: Remove a can't-happen from miValidateTree

2014-09-23 Thread Adam Jackson
The only way you can get VisibilityNotViewable is to be, you know, not viewable. Since this test is inside if (pWin->viewable)... Signed-off-by: Adam Jackson --- mi/mivaltree.c | 30 -- 1 file changed, 30 deletions(-) diff --git a/mi/mivaltree.c b/mi/mivaltree.c ind

[PATCH 17/18] mi: miSlideAndSizeWindow -> miResizeWindow

2014-09-23 Thread Adam Jackson
Make the function name match the screen slot name. Signed-off-by: Adam Jackson --- mi/mi.h| 12 ++-- mi/miscrinit.c | 2 +- mi/miwindow.c | 5 ++--- 3 files changed, 9 insertions(+), 10 deletions(-) diff --git a/mi/mi.h b/mi/mi.h index 8cb3ce7..5a455c9 100644 --- a/mi/mi.h ++

[PATCH 12/18] dix: Remove DIXsaveUnder bit from the Window

2014-09-23 Thread Adam Jackson
Signed-off-by: Adam Jackson --- dix/window.c| 1 - include/windowstr.h | 1 - 2 files changed, 2 deletions(-) diff --git a/dix/window.c b/dix/window.c index 52e69ef..f227e4c 100644 --- a/dix/window.c +++ b/dix/window.c @@ -362,7 +362,6 @@ SetWindowToDefaults(WindowPtr pWin) pWin->cu

[PATCH 16/18] dix: Remove an obfuscatory macro

2014-09-23 Thread Adam Jackson
Signed-off-by: Adam Jackson --- dix/window.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/dix/window.c b/dix/window.c index 295038a..7a2866a 100644 --- a/dix/window.c +++ b/dix/window.c @@ -1812,8 +1812,6 @@ ResizeChildrenWinSize(WindowPtr pWin, int dx, int dy, int dw,

[PATCH 15/18] dix: Remove some pointless casting of NULL

2014-09-23 Thread Adam Jackson
Signed-off-by: Adam Jackson --- dix/window.c | 23 ++- 1 file changed, 10 insertions(+), 13 deletions(-) diff --git a/dix/window.c b/dix/window.c index e49670a..295038a 100644 --- a/dix/window.c +++ b/dix/window.c @@ -357,8 +357,8 @@ SetWindowToDefaults(WindowPtr pWin) p

[PATCH 18/18] fb: fb{Map,Unmap}Window -> fb{Realize,Unrealize}Window

2014-09-23 Thread Adam Jackson
Make the function names match the screen slot name. Signed-off-by: Adam Jackson --- fb/fb.h| 4 ++-- fb/fbscreen.c | 4 ++-- fb/fbwindow.c | 4 ++-- fb/wfbrename.h | 4 ++-- 4 files changed, 8 insertions(+), 8 deletions(-) diff --git a/fb/fb.h b/fb/fb.h index 9057767..d176bb3 100644 -

[PATCH 03/18] rootless: remove redundant RootlessShapedWindowIn

2014-09-23 Thread Adam Jackson
miShapedWindowIn is identical. Which you would expect, since neither one takes an actual WindowPtr argument, so they couldn't possibly make reference to rootlessness. Signed-off-by: Adam Jackson --- miext/rootless/rootlessValTree.c | 65 ++-- 1 file changed,

[PATCH 14/18] dix: Remove an empty if

2014-09-23 Thread Adam Jackson
Signed-off-by: Adam Jackson --- dix/window.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/dix/window.c b/dix/window.c index e1645c3..e49670a 100644 --- a/dix/window.c +++ b/dix/window.c @@ -2806,8 +2806,6 @@ UnmapSubwindows(WindowPtr pWin) pChild->mapped = FALSE;

[PATCH 09/18] mi: Move pScreen->SendGraphicsExpose up to dix

2014-09-23 Thread Adam Jackson
No DDX is overriding this and it's fairly absurd to expose it as a screen operation anyway. Signed-off-by: Adam Jackson --- Xext/panoramiXprocs.c | 10 -- dix/dispatch.c| 52 +++ include/dix.h | 6 ++ include/scrnintstr

[PATCH 13/18] dix: Lower backStorage to a bit instead of a pointer

2014-09-23 Thread Adam Jackson
Signed-off-by: Adam Jackson --- composite/compinit.c | 4 ++-- dix/window.c | 2 +- include/windowstr.h | 2 +- mi/miexpose.c| 2 +- 4 files changed, 5 insertions(+), 5 deletions(-) diff --git a/composite/compinit.c b/composite/compinit.c index 48e938f..111c16e 100644 --- a/comp

[PATCH 11/18] mi: Rewrite a conditional chain to be a bit more obvious

2014-09-23 Thread Adam Jackson
Signed-off-by: Adam Jackson --- mi/mivaltree.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/mi/mivaltree.c b/mi/mivaltree.c index b1caec9..1b68739 100644 --- a/mi/mivaltree.c +++ b/mi/mivaltree.c @@ -648,17 +648,15 @@ miValidateTree(WindowPtr pParent, /* Paren

[PATCH 02/18] xquartz: Remove useless DRIWindowExposures

2014-09-23 Thread Adam Jackson
Reviewed-by: Keith Packard Signed-off-by: Adam Jackson --- hw/xquartz/xpr/dri.c | 21 - hw/xquartz/xpr/dri.h | 4 2 files changed, 25 deletions(-) diff --git a/hw/xquartz/xpr/dri.c b/hw/xquartz/xpr/dri.c index 0f19047..565d94f 100644 --- a/hw/xquartz/xpr/dri.c +++ b/hw

[PATCH 00/18] Misc exposure/validation cleanups, v2

2014-09-23 Thread Adam Jackson
This series no longer has the spontaneous combustion removal. 5 and 6 are instead just propagating through the 'exposures = prgn' bit of the logic. It also no longer has the doVisibilityNotify refactor, since in 10 we discover that the second path can't actually get hit so there's no reason to fac

[PATCH 04/18] dix: Drop the third argument from WindowExposuresProcPtr

2014-09-23 Thread Adam Jackson
A careful read shows that it was always NULL. It hasn't always been; as the DDX spec indicates, it was the "occluded region that has backing store", but since that backing store code is long gone nothing, we can nuke it. mi{,Overlay}WindowExposures get slightly simpler here, and will get even sim

[PATCH 01/18] kdrive: Remove vestigial reference to fbInitValidateTree

2014-09-23 Thread Adam Jackson
Reviewed-by: Keith Packard Signed-off-by: Adam Jackson --- hw/kdrive/src/kdrive.c | 4 1 file changed, 4 deletions(-) diff --git a/hw/kdrive/src/kdrive.c b/hw/kdrive/src/kdrive.c index 5dbff3f..dddbe6e 100644 --- a/hw/kdrive/src/kdrive.c +++ b/hw/kdrive/src/kdrive.c @@ -909,10 +909,6 @@ Kd

[PATCH 06/18] mi: Deobfuscate miOverlayWindowExposures

2014-09-23 Thread Adam Jackson
Signed-off-by: Adam Jackson --- mi/mioverlay.c | 40 1 file changed, 12 insertions(+), 28 deletions(-) diff --git a/mi/mioverlay.c b/mi/mioverlay.c index f894e2b..2ad6bc0 100644 --- a/mi/mioverlay.c +++ b/mi/mioverlay.c @@ -983,28 +983,19 @@ miOverlayWind

[PATCH 05/18] mi: Deobfuscate miWindowExposures

2014-09-23 Thread Adam Jackson
Signed-off-by: Adam Jackson --- mi/miexpose.c | 41 +++-- 1 file changed, 11 insertions(+), 30 deletions(-) diff --git a/mi/miexpose.c b/mi/miexpose.c index 23987fa..de0e148 100644 --- a/mi/miexpose.c +++ b/mi/miexpose.c @@ -425,17 +425,11 @@ miWindowExposures

[PATCH 07/18] mi: Simplify composite border clip redirection interface

2014-09-23 Thread Adam Jackson
There's not really a good reason for mi to not just call the composite code directly. Reviewed-by: Keith Packard Signed-off-by: Adam Jackson --- composite/compext.c | 3 --- mi/mi.h | 11 --- mi/mivaltree.c | 52 +++- 3 f

[PATCH 08/18] mi: Drop plane argument from miHandleExposures

2014-09-23 Thread Adam Jackson
This existed to be passed to the bs recovery routine; since we back all planes, we don't care. Signed-off-by: Adam Jackson --- fb/fbcopy.c | 2 +- glamor/glamor_copy.c | 3 +-- hw/dmx/dmxgcops.c| 8 mi/mi.h | 3 +-- mi/mibitblt.c| 5 ++--- mi/micopy.c

Re: F21/F22: xorg-x11-drv: which for SiS?

2014-09-23 Thread LaƩrcio de Sousa
According to http://pkgs.fedoraproject.org/cgit/xorg-x11-drv-sis.git/commit/?id=95dc18d4c803988702974635badb391cc50b6a63 , this package is dead for Fedora 21 and later due to lack of KMS support. See also: https://lists.fedoraproject.org/pipermail/devel/2013-August/188429.html 2014-09-23 3:37 G