[PATCH:libXTrap 2/2] Remove unnecessary memset return value casts to void.

2012-07-20 Thread Thomas Klausner
Signed-off-by: Thomas Klausner w...@netbsd.org --- src/XEConTxt.c | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git a/src/XEConTxt.c b/src/XEConTxt.c index d075c4f..531ced2 100644 --- a/src/XEConTxt.c +++ b/src/XEConTxt.c @@ -69,7 +69,7 @@ XETC

Re: [PATCH:libXTrap] Fix memset usage.

2012-07-20 Thread Thomas Klausner
On Fri, Jul 20, 2012 at 09:32:10PM +0200, Rémi Cardona wrote: It's definitely worth an extra patch if it's more widespread than just this bit. Ok, done and sent. In any case, the previous patch is: Reviewed-by: Rémi Cardona remi.card...@free.fr Thanks, noted in the new version of the

[PATCH:libXt 1/2] Avoid referencing something that isn't defined. Bring in the definition from another manual page.

2012-07-18 Thread Thomas Klausner
From Quentin Garnier c...@netbsd.org Signed-off-by: Thomas Klausner w...@netbsd.org --- man/XtAppCreateShell.man | 1 + 1 file changed, 1 insertion(+) diff --git a/man/XtAppCreateShell.man b/man/XtAppCreateShell.man index 3d09f88..73218e6 100644 --- a/man/XtAppCreateShell.man +++ b/man

[PATCH:libXt 2/2] Fix DEBUG build (TMparse.c:376:1: error: overflow in implicit constant conversion)

2012-07-18 Thread Thomas Klausner
From Christos Zoulas chris...@netbsd.org Signed-off-by: Thomas Klausner w...@netbsd.org --- src/TMparse.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/TMparse.c b/src/TMparse.c index d233644..5594cad 100644 --- a/src/TMparse.c +++ b/src/TMparse.c @@ -372,8 +372,8

[PATCH:libXTrap] Fix memset usage.

2012-07-18 Thread Thomas Klausner
From Joerg Sonnenberger jo...@netbsd.org Signed-off-by: Thomas Klausner w...@netbsd.org --- src/XEConTxt.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/XEConTxt.c b/src/XEConTxt.c index e2dff16..d075c4f 100644 --- a/src/XEConTxt.c +++ b/src/XEConTxt.c @@ -69,7 +69,7

[PATCH:libXext] Avoid having macros expand code to be: ((f) ? (f)-m1 : NULL)-m2

2012-07-18 Thread Thomas Klausner
From Matthew R. Green m...@netbsd.org Signed-off-by: Thomas Klausner w...@netbsd.org --- src/XSync.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/XSync.c b/src/XSync.c index df7c435..5775293 100644 --- a/src/XSync.c +++ b/src/XSync.c @@ -107,8 +107,8 @@ static

Re: libdrm-2.4.37: use ETIMEDOUT instead of ETIME?

2012-07-17 Thread Thomas Klausner
On Tue, Jul 17, 2012 at 07:02:56AM -0700, Matt Turner wrote: On Mon, Jul 16, 2012 at 11:34 AM, Thomas Klausner w...@netbsd.org wrote: libdrm-2.4.37 added a use of ETIME (from errno(3)) in intel/intel_bufmgr_gem.c. This errno is not defined on (at least) DragonFly BSD. A Linux man page

Re: libdrm-2.4.37: use ETIMEDOUT instead of ETIME?

2012-07-17 Thread Thomas Klausner
On Tue, Jul 17, 2012 at 12:04:26PM -0700, Matt Turner wrote: I was asking mostly out of curiosity, but at the same time I don't think compiling this (libdrm_intel) is useful without KMS. Ok, that might be. So unless I'm wrong on that point I've got to question why you're bothering to ship

[PATCH:libXv] Uppercase SH arguments.

2012-07-17 Thread Thomas Klausner
Signed-off-by: Thomas Klausner w...@netbsd.org --- man/XvListImageFormats.man | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/man/XvListImageFormats.man b/man/XvListImageFormats.man index c5159e5..51e5a2e 100644 --- a/man/XvListImageFormats.man +++ b/man

Re: [PATCH] Do not unconditionally define DEBUG.

2012-07-17 Thread Thomas Klausner
On Mon, Jul 16, 2012 at 10:26:37PM -0700, Alan Coopersmith wrote: Sorry, that's what I get for relying on memory instead of testing - the = was a mistake, it should be a space, as in: git config format.subjectprefix PATCH:xscope (actually tested this time to be sure) Ok, thanks, that

libdrm-2.4.37: use ETIMEDOUT instead of ETIME?

2012-07-16 Thread Thomas Klausner
Hi! libdrm-2.4.37 added a use of ETIME (from errno(3)) in intel/intel_bufmgr_gem.c. This errno is not defined on (at least) DragonFly BSD. A Linux man page for errno(3) says: ETIME Timer expired (POSIX.1 (XSI STREAMS option)) (POSIX.1 says STREAM

[xinit] XSLASHGLOB

2012-07-12 Thread Thomas Klausner
Hi! While looking at NetBSD xsrc patches I found one for xinit. Index: xinit/dist/xinitrc.cpp === RCS file: /cvsroot/xsrc/external/mit/xinit/dist/xinitrc.cpp,v retrieving revision 1.1.1.3 retrieving revision 1.2 diff -u -r1.1.1.3

[xkbdata] colemak support

2012-07-12 Thread Thomas Klausner
Another patch to NetBSD xsrc adds Colemak data to xkbdata. The files are marked: 2006-01-01 Shai Coleman, http://colemak.com/ . Public domain. so they should be safe to include. I didn't find an anongit repository for xkbdata, so the two files are added as attachment with corresponding

[PATCH libFS] Fix a prototype error

2012-07-12 Thread Thomas Klausner
Another simple fix, this time for libFS -- a broken prototype. ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

[PATCH libFS] Fix a prototype error

2012-07-12 Thread Thomas Klausner
Per NetBSD PR 41899 from Henning Petersen. Signed-off-by: Thomas Klausner w...@netbsd.org --- src/FSlibInt.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/FSlibInt.c b/src/FSlibInt.c index db9cc47..a04d3cd 100644 --- a/src/FSlibInt.c +++ b/src/FSlibInt.c @@ -1194,7

[PATCH xman] avoid PIC macro

2012-07-12 Thread Thomas Klausner
Lots of compiler setting recommendations include -DPIC -fPIC for compiling position-independent code. This patch avoids a problem with that in xman. ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info:

[PATCH] Rename PIC to XMAN_PIC to avoid problems with -DPIC compilations.

2012-07-12 Thread Thomas Klausner
Signed-off-by: Thomas Klausner w...@netbsd.org --- misc.c | 2 +- vendor.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/misc.c b/misc.c index 8818aa8..7592996 100644 --- a/misc.c +++ b/misc.c @@ -764,7 +764,7 @@ ConstructCommand(cmdbuf, path, filename, tempfile

Re: [xkbdata] colemak support

2012-07-12 Thread Thomas Klausner
On Thu, Jul 12, 2012 at 06:51:04AM -0700, Alan Coopersmith wrote: xkbdata is long dead - xkeyboard-config replaced it shortly after the X11R7.0 release. Thanks for the info. Upon checking further, NetBSD has already switched to xkeyboard-config (in 2009 or so) but just didn't remove xkbdata

Re: [PATCH] Do not unconditionally define DEBUG.

2012-07-12 Thread Thomas Klausner
On Wed, Jul 11, 2012 at 05:56:45PM -0700, Alan Coopersmith wrote: Works for me. Applied pushed to git master: To ssh://git.freedesktop.org/git/xorg/app/xedit 33dacad..ce36f7b master - master Thank you! As Matt noted, please include the module name in the [PATCH module] header for

[PATCH xman] Changed patch after suggestion by Walter Harms

2012-07-12 Thread Thomas Klausner
The same patch as before, but with s/XMAN/ROFF/ -- pick either version :) [PATCH] Rename PIC to ROFF_PIC to avoid problems with -DPIC ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info:

[PATCH] Rename PIC to ROFF_PIC to avoid problems with -DPIC compilations. From Christos Zoulas chris...@netbsd.org.

2012-07-12 Thread Thomas Klausner
Signed-off-by: Thomas Klausner w...@netbsd.org --- misc.c | 2 +- vendor.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/misc.c b/misc.c index 8818aa8..abe410e 100644 --- a/misc.c +++ b/misc.c @@ -764,7 +764,7 @@ ConstructCommand(cmdbuf, path, filename, tempfile

Re: [PATCH] Rename PIC to XMAN_PIC to avoid problems with -DPIC compilations.

2012-07-12 Thread Thomas Klausner
On Thu, Jul 12, 2012 at 07:00:52PM +0200, walter harms wrote: I see, to be fair i do not know the code but the names are roff/nroff precompiler therefore i would expect a name like roff_pic. Fine with me, I've just resent the patch with the change as suggested. Pick either, I don't really

Re: Integrating NetBSD patches?

2012-07-11 Thread Thomas Klausner
On Tue, Jul 10, 2012 at 01:22:26PM -0700, Keith Packard wrote: They'd need to be rebased on top of the current development branches of each repository. That can vary from trivial to a huge amount of work. Starting with simple fixes to learn where the pitfalls are is probably a good idea. Ok,

[PATCH] Do not unconditionally define DEBUG.

2012-07-11 Thread Thomas Klausner
--- lisp/re/re.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/lisp/re/re.c b/lisp/re/re.c index fca7e28..f4c1246 100644 --- a/lisp/re/re.c +++ b/lisp/re/re.c @@ -31,7 +31,7 @@ #include stdio.h #include rep.h -#define DEBUG + /* * Types */ -- 1.7.11.1

Patches from NetBSD's xsrc

2012-07-11 Thread Thomas Klausner
The simplest patch I could find first, for xedit: [PATCH] Do not unconditionally define DEBUG. ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

Integrating NetBSD patches?

2012-07-10 Thread Thomas Klausner
Hi! I'm currently looking at migrating the changes NetBSD has in its copy of xorg in the NetBSD CVS tree into pkgsrc. (Just to get an overview if I'll manage to do that or if it's too much effort). This means extracting all the local patches. I guess that most of these haven't been fed upstream

[bug 50940] sessreg-1.0.7: Compilation error in sessreg.c -- undefined *TMPX paths

2012-06-15 Thread Thomas Klausner
Jeremy Huddleston has asked me to send the patch I submitted for the bug report in the subject to this list for review. My bug report was: Compilation of sessreg-1.0.7 on NetBSD-6.99.7/amd64 fails with: --- sessreg.o --- CC sessreg.o sessreg.c:257:16: error: use of undeclared identifier

<    1   2   3   4   5