zhihai xu created YARN-2799:
-------------------------------

             Summary: cleanup TestLogAggregationService based on the change in 
YARN-90
                 Key: YARN-2799
                 URL: https://issues.apache.org/jira/browse/YARN-2799
             Project: Hadoop YARN
          Issue Type: Improvement
          Components: test
            Reporter: zhihai xu
            Priority: Minor


cleanup TestLogAggregationService based on the change in YARN-90.
The following code is added to setup in YARN-90, 
{code}
    dispatcher = createDispatcher();
    appEventHandler = mock(EventHandler.class);
    dispatcher.register(ApplicationEventType.class, appEventHandler);
{code}
In this case, we should remove all these code from each test function to avoid 
duplicate code.

Same for dispatcher.stop() which is in tearDown,
we can remove dispatcher.stop() from from each test function also because it 
will always be called from tearDown for each test.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to