On Tue, 26 Oct 2021 22:37:02 GMT, Hai-May Chao <hc...@openjdk.org> wrote:

> This change does a few improvements to the output of `keytool -printcert 
> -jarfile` command to help readability and diagnosis.

src/java.base/share/classes/sun/security/tools/keytool/Main.java line 2878:

> 2876:                             out.println();
> 2877:                             out.println();
> 2878:                             out.println(rb.getString("Signature."));

Please remove a newline as well. There needn't be 3 `println()` calls.

src/java.base/share/classes/sun/security/tools/keytool/Resources.java line 469:

> 467:         {"one.in.many", "%1$s #%2$d of %3$d"},
> 468:         {"one.in.many1", "%1$s of signer #%2$d"},
> 469:         {"one.in.many2", "%1$s #%2$d of %3$d of signer #%4$d"},

`certificate #1 of 2 of signer #1` is a little too complicated. The second 
number is not really necessary. I think `certificate #1 of signer #1` is enough.

-------------

PR: https://git.openjdk.java.net/jdk/pull/6126

Reply via email to