On Wed, 26 Aug 2026 05:40:10 GMT, Quan Anh Mai <[email protected]> wrote:

>> Shawn Emery has updated the pull request incrementally with one additional 
>> commit since the last revision:
>> 
>>   Implement comment from merykitty
>
> test/micro/org/openjdk/bench/javax/crypto/full/PolynomialP256Bench.java line 
> 59:
> 
>> 57:     final ImmutableIntegerModuloP x = residueField.getElement(refx);
>> 58:     final ImmutableIntegerModuloP X = montField.getElement(refx);
>> 59:     final ImmutableIntegerModuloP one = residueField.get1();
> 
> Since you are here, I would suggest having better names for these fields.

Agreed.  Done!

> test/micro/org/openjdk/bench/javax/crypto/full/PolynomialP256Bench.java line 
> 100:
> 
>> 98:     @Benchmark
>> 99:     public MutableIntegerModuloP benchAssign() {
>> 100:         MutableIntegerModuloP test1;
> 
> Are these changes still necessary?

I believe so.  I'm not for sure why the lone intrinsics for 
`IntegerPolynomialP256` were not tested in this benchmark from the beginning.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32047#discussion_r3860129314
PR Review Comment: https://git.openjdk.org/jdk/pull/32047#discussion_r3858657102

Reply via email to