Shouldnt this lines in File_Persistent_Stream_Repository

    "public synchronized InputStream get( final String key )
    ...
    final ArrayList list = new ArrayList();
    list.add( o );
    list.add( stream );
    m_inputs.put( key, stream );
    ...
    }
    "
look like this

    "public synchronized InputStream get( final String key )
    ...
    final ArrayList list = new ArrayList();
    list.add( o );
    list.add( stream );
    m_inputs.put( key, list);
    ...
    }
    "
Its not clear to me whether theres a greater purpose behind it especially in 
conjunction with the remove(...)-methode.
The same in put(...) and File_Persistent_Object_Repository.

M

Reply via email to