On 6/14/06, Stefano Bagnara <[EMAIL PROTECTED]> wrote:
We should also keep in mind the Delivery Status Notification services
while thinking at this changes.

Yes, def.

Imo the *must* are a little different:
a) letting the mailet indicate that it consumed the message
b) letting the mailet return multiple mails (resulting from a split, or
newly generated) without the use of sendMail.

Right!  That's not even possible now.  So a) consume b) inject in
current spot of processor c) inject into another processor.

I use "inject" rather than "return an array" because I think it is
easier to call mailetcontext.injectHere(Mail) 4 times than to keep all
those Mail in memory, construct a 4 element array and populate that
way.  I find it intuitive, but others may not.  I think this is better
from a memory/heap usage perspective though.

So my method signatures would like like...

public interface Mailet {
/**
 * return boolean Whether mailet consumed it
 */
public boolean service(Mail mail)
}

public interface MailetContext {
 public void injectHere(Mail);
 public void injectElsewhere(Mail, String spoolname);
}

Those names are not good, but that's the rough signature.

--
Serge Knystautas
Lokitech >> software . strategy . design >> http://www.lokitech.com
p. 301.656.5501
e. [EMAIL PROTECTED]

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to