On Thu, 27 Apr 2023 04:52:53 GMT, Serguei Spitsyn <sspit...@openjdk.org> wrote:

>> This refactoring to separate ThreadStart/ThreadEnd events posting code in 
>> the JVMTI VTMS transitions is needed for future work on JVMTI scalability 
>> and performance improvements. It is to easier put this code on slow path.
>> 
>> Testing: mach5 tiers 1-6 were successful.
>
> Serguei Spitsyn has updated the pull request incrementally with two 
> additional commits since the last revision:
> 
>  - Merge branch 'br29' of https://github.com/sspitsyn/jdk into br29
>    merge with branch29
>  - move code a little bit

Hi Serguei,

Changes look good to me. Thanks for taking care of the refactoring.

Patricio

src/hotspot/share/runtime/sharedRuntime.cpp line 639:

> 637: JRT_END
> 638: 
> 639: JRT_ENTRY(void, SharedRuntime::notify_jvmti_vthread_start(oopDesc* vt, 
> jboolean dummy, JavaThread* current))

Maybe rename dummy to hide and just assert is false in this case and true for 
the vthread_end case?

-------------

Marked as reviewed by pchilanomate (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/13484#pullrequestreview-1407836173
PR Review Comment: https://git.openjdk.org/jdk/pull/13484#discussion_r1181722432

Reply via email to