salman wrote:
Hello,
While attempting to upgrade to 2.0, I'm getting this error when
running slonik_update_nodes. Can I simply symlink the first .sql (see
below) file into usr/share to get around this?
I see the file at the following locations:
/usr/src/slony1-2.0.0/src/backend/slony1_funcs.sql (md5:
5c47555b5e2ae556ed6958a4d5f9bfa2)
/usr/local/postgresql/8.3.1/share/slony1_funcs.sql (md5:
538bc6f60dda20fcde704a673f89afbe)
pg_config output is as follows:
BINDIR = /usr/local/postgresql/8.3.1/bin
DOCDIR = /usr/local/postgresql/8.3.1/doc
INCLUDEDIR = /usr/local/postgresql/8.3.1/include
PKGINCLUDEDIR = /usr/local/postgresql/8.3.1/include
INCLUDEDIR-SERVER = /usr/local/postgresql/8.3.1/include/server
LIBDIR = /usr/local/postgresql/8.3.1/lib
PKGLIBDIR = /usr/local/postgresql/8.3.1/lib
LOCALEDIR =
MANDIR = /usr/local/postgresql/8.3.1/man
SHAREDIR = /usr/local/postgresql/8.3.1/share
SYSCONFDIR = /usr/local/postgresql/8.3.1/etc
PGXS = /usr/local/postgresql/8.3.1/lib/pgxs/src/makefiles/pgxs.mk
CONFIGURE = '--prefix=/usr/local/postgresql/8.3.1' '--with-python'
'--with-perl' '--enable-thread-safety' '--enable-depend' '--with-openssl'
CC = gcc
CPPFLAGS = -D_GNU_SOURCE
CFLAGS = -O2 -Wall -Wmissing-prototypes -Wpointer-arith -Winline
-Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing -fwrapv
CFLAGS_SL = -fpic
LDFLAGS = -Wl,-rpath,'/usr/local/postgresql/8.3.1/lib'
LDFLAGS_SL =
LIBS = -lpgport -lssl -lcrypto -lz -lreadline -ltermcap -lcrypt -ldl -lm
VERSION = PostgreSQL 8.3.1
slony config string:
./configure --prefix=/usr --sysconfdir=/etc/slony --with-perltools
--with-pgconfigdir=/usr/local/postgresql/current/bin/
-salman
Had to roll back to the previous version of slony as the attempted
broken update was causing app errors on inserts. Just got around to
trying the upgrade, again and ran into the same issue. For now I've just
uninstalled slony and then did a re-init on the slave. However, even
with that I ran into the following problems:
1) slonik was looking for slony1_funcs.sql file in usr/share instead of
$PGSHAREDIR -- fixed by copying the .sql files in src/backend to
usr/share/ and $PGSHAREDIR by hand.
2) slon_start wouldn't actually start a slon_daemon but also wouldn't
show any error messages. Looking at the log file, I discovered that
slon_start was attempting to start slon with the -d flag but was not
passing any value. Fixed by adding $DEBUGLEVEL="0" into my slon_tools.conf
3) slon_watchdog would not start due to a missing ';' at the end of line
46. Fixed by editing the file.
This is all on RHEL 5.1 and postgres-8.3.1
-salman
_______________________________________________
Slony1-general mailing list
[email protected]
http://lists.slony.info/mailman/listinfo/slony1-general