Ok, now truly resolved.

Resolution:

1. - Typo in index.shtml to include "file.html" instead of "file.shtml".
Corrected this and the server loaded the page correctly.
2. - I remembered "file.html" used to get included before. Checked
htttpd.conf and found that the "new & improved" httpd.conf did not
include:

AddType text/html .html
AddHandler server-parsed .html

Now all works well.

Thanks Tony and Jeff for your efforts.

Cheers,
      Craige.

As my previous version had.

Tony Cook wrote:
> 
> Oops, for the .htaccess way to work you also need to have:
> 
>    AllowOverride Options
> 
> for the directory for the virtual host (assuming you don't have that in
> some parent directory.)  Or you could just put the Includes in the
> https?d.conf file.
> 
> Do you see anything in the error log?
> 
> On Thu, 22 Jun 2000, Craige McWhirter wrote:
> 
> > I think that's getting to the root of the problem. Follwing your idea I
> > now get an error:
> >
> > "Document Contains No Data"
> >
> > No web pages at all any more.
> >
> > Does this mean I have to replicate my entire "base" server into the
> > virtual hosts? I was of the impression that if the option weren't
> > specified for a virtual host they took the options from the main server.
> >
> > Cheers,
> >       Craige.
> >
> > Tony Cook wrote:
> > >
> > > On Thu, 22 Jun 2000, Craige McWhirter wrote:
> > > > I've recently created a virtual server with Apache (1.3.12) but once the
> > > > data is in place it appears to ignore my include statements, while the
> > > > includes work fine for the documents being served from the "traditional"
> > > > server root.
> > > >
> > > > I do get my web pages, just minus their included data. No errors either.
> > > >
> > > > I've gone over the <Directory> and <VirtualHost> information in the
> > > > online doco but while quite good, don't seem to help me out of my
> > > > scenario.
> > > >
> > > > Is someone able to point in the right direction for where I can find
> > > > more information on SSI & virtual hosts?
> > >
> > > The documentation for mod_include in the apache docs is the best SSI docs
> > > I know of.
> > >
> > > Did you check that Includes are enables in the Options for the directories
> > > for the virtual hosts?
> > >
> > > You might want to check by adding:
> > >
> > > Options +Includes
> > >
> > > to the .htaccess file at the root of one your virtual hosts (and move it
> > > to the https?d.conf file if that fixes it).
> > --
> > SLUG - Sydney Linux Users Group Mailing List - http://www.slug.org.au
> > To unsubscribe send email to [EMAIL PROTECTED] with
> > unsubscribe in the text
> >
> 
> --
> SLUG - Sydney Linux Users Group Mailing List - http://www.slug.org.au
> To unsubscribe send email to [EMAIL PROTECTED] with
> unsubscribe in the text
--
SLUG - Sydney Linux Users Group Mailing List - http://www.slug.org.au
To unsubscribe send email to [EMAIL PROTECTED] with
unsubscribe in the text

Reply via email to