[ 
https://issues.apache.org/jira/browse/SOLR-1710?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Chris Male updated SOLR-1710:
-----------------------------

    Attachment: SOLR-1710-readable.patch

Attaching a first pass at improving the readability of this code.  

Focused mostly on breaking up #incrementToken, extracting common behavior into 
helper methods, documenting each method, putting fields in a consistent place, 
trimming if else statement blocks etc etc.

I imagine there might be a small performance improvement due to these 
improvements, but they could have all been done by the compiler too.

> convert worddelimiterfilter to new tokenstream API
> --------------------------------------------------
>
>                 Key: SOLR-1710
>                 URL: https://issues.apache.org/jira/browse/SOLR-1710
>             Project: Solr
>          Issue Type: Improvement
>          Components: Schema and Analysis
>            Reporter: Robert Muir
>         Attachments: SOLR-1710-readable.patch, SOLR-1710.patch, 
> SOLR-1710.patch
>
>
> This one was a doozy, attached is a patch to convert it to the new 
> tokenstream API.
> Some of the logic was split into WordDelimiterIterator (exposes a 
> BreakIterator-like api for iterating subwords)
> the filter is much more efficient now, no cloning.
> before applying the patch, copy the existing WordDelimiterFilter to 
> OriginalWordDelimiterFilter
> the patch includes a testcase (TestWordDelimiterBWComp) which generates 
> random strings from various subword combinations.
> For each random string, it compares output against the existing 
> WordDelimiterFilter for all 512 combinations of boolean parameters.
> NOTE: due to bugs found (SOLR-1706), this currently only tests 256 of these 
> combinations. The bugs discovered in SOLR-1706 are fixed here.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to