Module Name:    src
Committed By:   uebayasi
Date:           Sat Nov 20 07:52:31 UTC 2010

Modified Files:
        src/sys/uvm [uebayasi-xip]: uvm_page.c

Log Message:
Don't set PG_FAKE for device pages.

XXX PG_FAKE should be renamed as PG_UNINITED!


To generate a diff of this commit:
cvs rdiff -u -r1.153.2.65 -r1.153.2.66 src/sys/uvm/uvm_page.c

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

Modified files:

Index: src/sys/uvm/uvm_page.c
diff -u src/sys/uvm/uvm_page.c:1.153.2.65 src/sys/uvm/uvm_page.c:1.153.2.66
--- src/sys/uvm/uvm_page.c:1.153.2.65	Mon Nov 15 17:32:01 2010
+++ src/sys/uvm/uvm_page.c	Sat Nov 20 07:52:30 2010
@@ -1,4 +1,4 @@
-/*	$NetBSD: uvm_page.c,v 1.153.2.65 2010/11/15 17:32:01 uebayasi Exp $	*/
+/*	$NetBSD: uvm_page.c,v 1.153.2.66 2010/11/20 07:52:30 uebayasi Exp $	*/
 
 /*
  * Copyright (c) 2010 The NetBSD Foundation, Inc.
@@ -97,7 +97,7 @@
  */
 
 #include <sys/cdefs.h>
-__KERNEL_RCSID(0, "$NetBSD: uvm_page.c,v 1.153.2.65 2010/11/15 17:32:01 uebayasi Exp $");
+__KERNEL_RCSID(0, "$NetBSD: uvm_page.c,v 1.153.2.66 2010/11/20 07:52:30 uebayasi Exp $");
 
 #include "opt_ddb.h"
 #include "opt_uvmhist.h"
@@ -862,7 +862,7 @@
 		paddr_t paddr = (start + i) << PAGE_SHIFT;
 
 		pg->phys_addr = paddr;
-		pg->flags |= PG_FAKE | PG_CLEAN | PG_DEVICE;
+		pg->flags |= PG_CLEAN | PG_DEVICE;
 		if (prot == VM_PROT_READ)
 			pg->flags |= PG_RDONLY;
 #ifdef __HAVE_VM_PAGE_MD

Reply via email to