On Fri, Dec 10, 2010 at 6:46 AM, Wolfram Sang <w.s...@pengutronix.de> wrote:
> Hi,
>
> thanks for the submission. It has some issues, though:

Hi Wolfram,

Thanks for the comments, I appreciate your interest in the RFC.

> On Thu, Dec 09, 2010 at 03:34:55PM -0500, Ben Gardiner wrote:
>
>> +             nsecs =
>> +#if defined(CONFIG_SLOWER_SPI_GPIO)
>> +                             !cs->nsecs ? cs->nsecs : 100;
>> +#else
>> +             100;
>> +#endif
>
> This coding style is very hard to read and gains nothing for it. Also,
> slower_spi should rather be a per-device than a config option.

Yes, now that you mention it the implementation looks very clunky.

I think it is starting to sink-in that a 'slower' spi gpio _driver_ is
needed. I can think of a couple different ways to make the CS-to-data
delay assigned to 'nsecs' a per-device feature:
1) a flag or 2) a function pointer in struct spi_bitbang. Were you
thinking of something else entirely?

Best Regards,
Ben Gardiner

---
Nanometrics Inc.
http://www.nanometrics.ca

------------------------------------------------------------------------------
Lotusphere 2011
Register now for Lotusphere 2011 and learn how
to connect the dots, take your collaborative environment
to the next level, and enter the era of Social Business.
http://p.sf.net/sfu/lotusphere-d2d
_______________________________________________
spi-devel-general mailing list
spi-devel-general@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/spi-devel-general

Reply via email to