It makes me twitch when I see the following:

Base = declarative_base(metadata=metadata)

class Spam(Base):
    ...

Base is a singularly undescriptive name to use for the base class of a
declarative table class.  People are doing this because it's in the
documentation.  If it were changed there, I think people would generally
follow along.  Would others be in favor of changing the documentation to
something like this?

Declarative = declarative_base(metadata=metadata)

class Spam(Declarative):
   ...

I'd be happy to implement the change throughout the declarative docs if
there's support for the idea.  

Cheers,
Cliff


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"sqlalchemy" group.
To post to this group, send email to sqlalchemy@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/sqlalchemy?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to