>
>   If it's just, you want to set up the two relationships as explicit code 
> for readability, that's great, use back_populates.   This is probably how 
> apps should be doing it anyway, in the early SQLAlchemy days there was a 
> lot of pressure to not require too much boilerplate, hence "backref".   
> These days, the community has moved well past the whole notion of "super 
> minimal declaration / magic == good", thankfully.
>

Personally, I would LOVE a "strict" config setting that would raise an 
exception if both sides of a relationship weren't explicitly defined.  

This is convenient...

    class Users(Base):
        addresses = relationship(Addresses, backref="users")

    class Addresses(Base):
        pass
  
But when you're tracking down bugs and dealing with code that probably 
(honestly) should have failed a peer review, that can make all the 
difference.

-- 
You received this message because you are subscribed to the Google Groups 
"sqlalchemy" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sqlalchemy+unsubscr...@googlegroups.com.
To post to this group, send email to sqlalchemy@googlegroups.com.
Visit this group at http://groups.google.com/group/sqlalchemy.
For more options, visit https://groups.google.com/d/optout.

Reply via email to