On Thu, 2008-09-18 at 13:00 +1000, Benno Rice wrote: > This is a forward-port of the HTCP changes I made to squid 2.HEAD. > > Changes include: > > - Ability to send HTCP CLR requests when objects are invalidated or purged > from > the cache. > - Config logic to allow the following: > - HTCP peers who ONLY receive CLR messages from us. > - HTCP peers who NEVER receive CLR messages from us. > - HTCP peers who NEVER receive CLR messages from us for PURGE requests. > - HTCP peers who are forwarded CLR messages we receive. > - Code to support all of the above.
Please document htcpForwardClr() purpose. Are we forwarding something to all HTCP peers there? Please document htcpClear() purpose. Please document neighborsHtcpClear() purpose. If possible, please document htcpHandle() since you are modifying and renaming it. Here and above, I am just asking for a brief "purpose" comment before the function, for those who will need to debug it or see it in a stack trace. > + htcpStuff stuff; Not your fault, but is there a more descriptive name for that object? :-) > debug(15, 1) ("neighborsHtcpClear: clear reason: %d\n", reason); There are a few statements logged at level 1, including statements inside loops. That may be perfectly fine, but please make sure you intended it that way. Thank you, Alex.